Transmission module update !! - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 / E61 (2004 - 2010)

E60 / E61 (2004 - 2010)
BMW 5-Series E60 Sedan was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E61 wagon followed shortly there after. The E60/E61 5 series is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 06-29-2019, 02:18 AM
zjor2000 zjor2000 is offline
Registered User
 
Join Date: May 2019
Posts: 33
Mein Auto:
Transmission module update !!

hello

i want to update my transmission , which of these modules should i do , i don't want to update the whole modules coz it will take alote of time ....

* there's a Slam on starting up the car only, how the update will fix it

photo attached

thanks
Attached Thumbnails
Click image for larger version

Name:	WhatsApp Image 2019-06-22 at 6.09.42 PM.jpg
Views:	91
Size:	125.7 KB
ID:	856393   Click image for larger version

Name:	WhatsApp Image 2019-06-17 at 7.07.39 PM.jpeg
Views:	51
Size:	106.5 KB
ID:	856429  

Last edited by zjor2000; 06-29-2019 at 07:37 AM.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 06-29-2019, 07:17 AM
pshovest pshovest is offline
BMW CCA 69606
Location: DE
 
Join Date: Dec 2009
Posts: 1,918
Mein Auto: '15 435i '10 535i '08 X5
Re-programming didn't fix my startup clank.

https://www.bimmerfest.com/forums/sh...ighlight=clank
Reply With Quote
  #3  
Old 06-29-2019, 07:32 AM
zjor2000 zjor2000 is offline
Registered User
 
Join Date: May 2019
Posts: 33
Mein Auto:
then u suggest not doing it ???
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 06-29-2019, 07:40 AM
zjor2000 zjor2000 is offline
Registered User
 
Join Date: May 2019
Posts: 33
Mein Auto:
Quote:
Originally Posted by pshovest View Post
Re-programming didn't fix my startup clank.

https://www.bimmerfest.com/forums/sh...ighlight=clank
i went to a shop and they updated EGS & DME , are those the only modules to update for transmission ?

as u see from the photo only 2 are 2019 and the rest are quite old
Reply With Quote
  #5  
Old 06-29-2019, 09:31 AM
pshovest pshovest is offline
BMW CCA 69606
Location: DE
 
Join Date: Dec 2009
Posts: 1,918
Mein Auto: '15 435i '10 535i '08 X5
Quote:
Originally Posted by zjor2000 View Post
then u suggest not doing it ???
Nope, just reporting my experience with the so called "software fix"

Quote:
Originally Posted by zjor2000 View Post
i went to a shop and they updated EGS & DME , are those the only modules to update for transmission ?

as u see from the photo only 2 are 2019 and the rest are quite old
Tell us if it fixes the problem.
Reply With Quote
  #6  
Old 08-25-2019, 01:31 PM
2010sport535i 2010sport535i is offline
Registered User
Location: Los Angeles
 
Join Date: Aug 2017
Posts: 3
Mein Auto: 2010 535i Sport
Did the problem get fixed?
Reply With Quote
  #7  
Old 08-26-2019, 01:53 AM
zjor2000 zjor2000 is offline
Registered User
 
Join Date: May 2019
Posts: 33
Mein Auto:
Quote:
Originally Posted by 2010sport535i View Post
Did the problem get fixed?
do u have the same problem ?
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 / E61 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:14 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.