All BMWs Coding connection problems - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming

BMW Coding and Programming
Discuss coding options and features on your BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 09-13-2019, 11:01 AM
Lynchygt3 Lynchygt3 is offline
Registered User
 
Join Date: Sep 2019
Posts: 12
Mein Auto:
Coding connection problems

Hi guys, new to the forum so nice to meet everyone.

I have a 2015 F11 and I have retro fitted the paddle shifters.

I am now trying to code them in (my first time coding) along with the sport transmission option to. (Sat)

After installing e-sys to my lap top coping the instructions step by step, I can't get it to connect to the car properly... it is picking the vin number up but it won't let me continue from there? The connect button won't respond.

Can anyone shed some light on what I may be doing wrong please? I'm not great on computers so please excuse my lack of understanding in certain areas.

I'll try and work out how to post a snap shot of the screen on here to show what I'm seeing.

Thanks.
Kevin.
Attached Thumbnails
Click image for larger version

Name:	5AB9D780-B64E-483F-AD67-EEE94D76D6A8_1568397571960.jpg
Views:	22
Size:	73.9 KB
ID:	864513   Click image for larger version

Name:	6E97E103-D389-45F9-99BC-751C36D583E2_1568397588644.jpg
Views:	19
Size:	65.8 KB
ID:	864515  
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 09-13-2019, 11:03 AM
Lynchygt3 Lynchygt3 is offline
Registered User
 
Join Date: Sep 2019
Posts: 12
Mein Auto:
My PSdz file doesn't have a folder icon... that's the only thing I can see different to the guide I followed, not sure why or if that matters? Please see pic bellow.
Attached Thumbnails
Click image for larger version

Name:	64D97C6F-7564-4215-87AF-E4378CC2FBDA_1568397788068.jpg
Views:	25
Size:	69.5 KB
ID:	864517  
Reply With Quote
  #3  
Old 09-13-2019, 09:53 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
bimmerfest Supporting Member
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 36,420
Mein Auto: 2016 650i GC M-Sport
Quote:
Originally Posted by Lynchygt3 View Post
My PSdz file doesn't have a folder icon... that's the only thing I can see different to the guide I followed, not sure why or if that matters? Please see pic bellow.
That is the psdzdata archive. You need to open and extract the .rar file with 7-Zip and then you will have an actual psdzdata folder.
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 09-14-2019, 01:30 AM
Lynchygt3 Lynchygt3 is offline
Registered User
 
Join Date: Sep 2019
Posts: 12
Mein Auto:
Great thanks I will try and do that now and let you know what happens.
Reply With Quote
  #5  
Old 09-14-2019, 03:14 AM
Lynchygt3 Lynchygt3 is offline
Registered User
 
Join Date: Sep 2019
Posts: 12
Mein Auto:
Quote:
Originally Posted by shawnsheridan View Post
Quote:
Originally Posted by Lynchygt3 View Post
My PSdz file doesn't have a folder icon... that's the only thing I can see different to the guide I followed, not sure why or if that matters? Please see pic bellow.
That is the psdzdata archive. You need to open and extract the .rar file with 7-Zip and then you will have an actual psdzdata folder.
Done as recommended above and reinstalled everything again, token created again etc

Still picks up my vin but won't connect or Show any list in the screen bellow

What would I do next?

Thanks
Attached Thumbnails
Click image for larger version

Name:	image_1568455991584.jpg
Views:	21
Size:	81.0 KB
ID:	864639  
Reply With Quote
  #6  
Old 09-14-2019, 04:32 AM
Lynchygt3 Lynchygt3 is offline
Registered User
 
Join Date: Sep 2019
Posts: 12
Mein Auto:
Sorted now guys thank you very much.

Next problem is I coded SAT in and I now have sport + but my retro fitted paddle shifters still are not working... I though that was part of SAT?

Do I have to program them in separately? If so can some one tell me what code to add?

Thanks again.
Reply With Quote
  #7  
Old 09-14-2019, 07:49 AM
tafikhulafa tafikhulafa is offline
Registered User
Location: indonesia
 
Join Date: Apr 2018
Posts: 60
Mein Auto: E39 530i
Quote:
Originally Posted by Lynchygt3 View Post
Sorted now guys thank you very much.

Next problem is I coded SAT in and I now have sport + but my retro fitted paddle shifters still are not working... I though that was part of SAT?

Do I have to program them in separately? If so can some one tell me what code to add?

Thanks again.


VO code the SZL module or you can FDL Code it, but i cant remember exactly what’s the value to change, might as well to VO Code it just to be sure.

Hope it helps


Sent from my iPhone using Tapatalk
Reply With Quote
  #8  
Old 09-14-2019, 08:07 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
bimmerfest Supporting Member
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 36,420
Mein Auto: 2016 650i GC M-Sport
FDL Code SZL => Lenkrad_Schaltpaddles = aktiv
__________________

2016 650i GC M-Sport w/ 20" 373M Wheels; Alpine White; Individual Opal White Full Merino Leather; Gray Poplar Wood Trim
Anthracite Alcantara Headliner; Ceramic Controls; Executive Package w/ B&O Sound System; Integral Active Steering, etc.
Reply With Quote
  #9  
Old 09-14-2019, 12:15 PM
Lynchygt3 Lynchygt3 is offline
Registered User
 
Join Date: Sep 2019
Posts: 12
Mein Auto:
Right I've VO coded it but for some strange reason the left paddle does nothing! And the right paddle changes down... haha do we think that's a coding issue? Has anyone else had that before?

The paddles and extra cable behind the airbag are genuine brand new BMW parts so I can't see those being faulty?

It's not been as simple as I hoped! Haha.
Reply With Quote
  #10  
Old 09-14-2019, 12:18 PM
Lynchygt3 Lynchygt3 is offline
Registered User
 
Join Date: Sep 2019
Posts: 12
Mein Auto:
Quote:
Originally Posted by shawnsheridan View Post
FDL Code SZL => Lenkrad_Schaltpaddles = aktiv
I opened every folder looking for this so I could FDL Code it but couldn't find it in any?

Am I right in thinking I right click on the green highlighted menu under SLZ then click read code and it should come up?

I checked them all and none said > Lenkrad_Schaltpaddles

Last edited by Lynchygt3; 09-14-2019 at 12:19 PM.
Reply With Quote
  #11  
Old 09-14-2019, 02:10 PM
tafikhulafa tafikhulafa is offline
Registered User
Location: indonesia
 
Join Date: Apr 2018
Posts: 60
Mein Auto: E39 530i
Search "paddle" related value on the SZL_LWS, it should be there

Sent from my SM-G950F using Tapatalk
Reply With Quote
  #12  
Old 09-15-2019, 05:31 AM
Lynchygt3 Lynchygt3 is offline
Registered User
 
Join Date: Sep 2019
Posts: 12
Mein Auto:
Quote:
Originally Posted by tafikhulafa View Post
Search "paddle" related value on the SZL_LWS, it should be there

Sent from my SM-G950F using Tapatalk
I'll give that a try thank you;

It was quite daunting at first but I'm starting to get a feel for the coding.

Just need to learn my way around it a little more.
Reply With Quote
  #13  
Old 09-16-2019, 03:16 AM
Lynchygt3 Lynchygt3 is offline
Registered User
 
Join Date: Sep 2019
Posts: 12
Mein Auto:
Well I've been in to SZL and searched 'paddle' and it came up! Great idea I didn't know you could use the search bar.

Anyway that is set to activ... I reset it just to make sure but the paddles are just the same! The right one changes down and the left one does nothing at all.

I suppose it would have to be coded in for either paddle to do anything so I can only assume I have a faulty new paddle? The wiring runs through the right one then to the left so I suspect the fault lies there? I don't have access to other paddles to try though unfortunately, so I'm not sure what to do next.

Has no one reported similar issues on here before?

Thanks
Kevin.
Reply With Quote
  #14  
Old 09-16-2019, 05:45 AM
tafikhulafa tafikhulafa is offline
Registered User
Location: indonesia
 
Join Date: Apr 2018
Posts: 60
Mein Auto: E39 530i
Quote:
Originally Posted by Lynchygt3 View Post

The right one changes down and the left one does nothing at all.


Thanks
Kevin.


There are two possibilities for this issue:

1. Maybe the wiring is not correct
2. You bought the wrong paddle shift, might be you bought for F30. Not for F10 the resistor value on the paddles on those two are different.



Sent from my iPhone using Tapatalk
Reply With Quote
  #15  
Old 09-16-2019, 11:57 PM
Lynchygt3 Lynchygt3 is offline
Registered User
 
Join Date: Sep 2019
Posts: 12
Mein Auto:
I would love to think I've just been supplied the wrong paddles!

I thought I bought everything directly from BMW but I didn't... I bought the steering wheel cowling and the wiring from them and the paddles from a chap on eBay!

He has asked for a pic of the rear of the paddles to check the part numbers, so fingers crossed.

Would anyone have the correct part number for my 2015 LCI F11 by any chance? So I can check my self.

Click image for larger version

Name:	E9D25421-1E19-44CF-8E93-747C3A5E141A_1568703428528.jpeg
Views:	31
Size:	380.7 KB
ID:	864969
Attached Thumbnails
Click image for larger version

Name:	3D55F8C3-EE4C-428D-9CC3-DF1729F70312_1568703438178.jpg
Views:	11
Size:	67.8 KB
ID:	864971  
Reply With Quote
  #16  
Old 09-17-2019, 02:17 AM
milkyway's Avatar
milkyway milkyway is offline
Officially Welcomed to the 'Fest
Location: OWL, Germany
 
Join Date: Jan 2013
Posts: 1,063
Mein Auto: F10 M5
Hello!

Nice F30 steering wheel paddels. Unfortunately NOT usefull for a F10.

CU Oliver
__________________
BMW F30 330e Hybrid 2016 in tansanit blue, cohibabrown for every day (10/2019 G20 330e in tansanit 2 blue, all in )
Jaguar XK8 Cabrio, 2006, black, 20" for the summer time
BMW M4 F83 Cabrio competition in black for the wife
Reply With Quote
  #17  
Old 09-17-2019, 03:53 AM
weebyx weebyx is offline
Officially Welcomed to the 'Fest
Location: Denmark
 
Join Date: May 2018
Posts: 255
Mein Auto: BMW 320d F30 2018
Quote:
Originally Posted by Lynchygt3 View Post
I would love to think I've just been supplied the wrong paddles!

I thought I bought everything directly from BMW but I didn't... I bought the steering wheel cowling and the wiring from them and the paddles from a chap on eBay!

He has asked for a pic of the rear of the paddles to check the part numbers, so fingers crossed.

Would anyone have the correct part number for my 2015 LCI F11 by any chance? So I can check my self.

Attachment 864969

If you have the courage, then it should be possible to fix the paddles to work with(at least an F10, which probably is the same as F11).

The paddles are "resistor encoded" regarding the signal, so changing a few resistors should fix them.

https://f10.5post.com/forums/showthread.php?t=1274977

/Weebyx
Reply With Quote
  #18  
Old 09-17-2019, 04:39 AM
tafikhulafa tafikhulafa is offline
Registered User
Location: indonesia
 
Join Date: Apr 2018
Posts: 60
Mein Auto: E39 530i
Weebyx is right, if you have the courage to redo the resistor value, you should do it.

Best of luck!

Sent from my SM-G950F using Tapatalk
Reply With Quote
  #19  
Old 09-17-2019, 05:27 AM
Lynchygt3 Lynchygt3 is offline
Registered User
 
Join Date: Sep 2019
Posts: 12
Mein Auto:
Haha yes the seller has just told me they have sent the wrong ones in error! Bloody hell fire, what a chew on.

They are sending the correct ones straight out so hopefully that's the end of the drama!

I most definitely wouldn't have the courage to try and make these ones work may I add! Haha.

Thanks for all your help guys, I will report back hopefully confirming the new ones work in a few days.

Cheers.
Reply With Quote
  #20  
Old 09-17-2019, 05:30 AM
weebyx weebyx is offline
Officially Welcomed to the 'Fest
Location: Denmark
 
Join Date: May 2018
Posts: 255
Mein Auto: BMW 320d F30 2018
Quote:
Originally Posted by Lynchygt3 View Post
Haha yes the seller has just told me they have sent the wrong ones in error! Bloody hell fire, what a chew on.

They are sending the correct ones straight out so hopefully that's the end of the drama!

I most definitely wouldn't have the courage to try and make these ones work may I add! Haha.

Thanks for all your help guys, I will report back hopefully confirming the new ones work in a few days.

Cheers.
That is also a good solution, to just get the correct ones from seller

/Weebyx
Reply With Quote
  #21  
Old 10-07-2019, 11:25 AM
Lynchygt3 Lynchygt3 is offline
Registered User
 
Join Date: Sep 2019
Posts: 12
Mein Auto:
All sorted guys, they sent the correct paddles and they worked straight away! Took them 2 weeks to send them though...
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:35 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.