Z4M Brake Pad Wear Sensor - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)

E85 / E86 Z4 (2003-2008)
E85 Z4 Roadster, E86 Z4 Coupe, E85 Z4 M Roadster, and E86 Z4 M Coupe talk with our BMW gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 08-11-2019, 05:45 PM
golferguy golferguy is offline
Registered User
Location: Fort Worth, TX
 
Join Date: Feb 2012
Posts: 54
Mein Auto: 2008 E85 Z4 M
Z4M Brake Pad Wear Sensor

I recently replaced my front brake rotors and pads and also a new wear sensor on my '08 Z4 M. The sensor seems to fit loosely in the slot that the pad has and the brake pad wear indicator light is still lit. Anyone have a tip on what I might have done incorrectly? The brakes themselves work great.
__________________
2008 Black Sapphire Metallic/Imola Red ///M Roadster 6sp Manual
2012 Vermilion Red/Oyster 128i Convertible Auto
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:53 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.