Zf5hp19 (p0741 code) help - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 08-15-2019, 09:27 PM
Ianfl Ianfl is online now
Registered User
 
Join Date: Aug 2019
Posts: 5
Mein Auto:
Zf5hp19 (p0741 code) help

So I just bought a 2002 bmw 530i with 161k miles sr trans. After driving 200ish miles (mostly on the highway) SES light came on. Stopped at autozone (p0741) and proceeded to drive 60+ miles with no shifting issues at all. (also rpm on highway is around 2500-2700) Then light came back on. If it was the torque converter wouldn’t the rpm be higher at highway speeds? No shifting problems so what do you think? I’m not sure on transmission service history but to my knowledge the fluid has never been flushed and no new filter. Could this be causing the code since it seems to be driving fine?


Sent from my iPhone using Bimmerfest mobile app
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 08-15-2019, 09:31 PM
edjack edjack is offline
Officially Welcomed to the 'Fest
Location: San Jose, CA
 
Join Date: May 2007
Posts: 14,900
Mein Auto: '97 540i 6 speed
Define that code, and where are you located?

We don't memorize the codes.
__________________


Ed in San Jose '97 540i 6 speed aspensilber over aubergine leather. Build date 3/97. Golden Gate Chapter BMW CCA Nr 62319.

Last edited by edjack; 08-15-2019 at 09:35 PM.
Reply With Quote
  #3  
Old 08-15-2019, 09:37 PM
Ianfl Ianfl is online now
Registered User
 
Join Date: Aug 2019
Posts: 5
Mein Auto:
P0741-Torque converter Clutch solenoid Circuit performance or stuck off


Sent from my iPhone using Bimmerfest
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 08-15-2019, 09:37 PM
Ianfl Ianfl is online now
Registered User
 
Join Date: Aug 2019
Posts: 5
Mein Auto:
Quote:
Originally Posted by Ianfl View Post
P0741-Torque converter Clutch solenoid Circuit performance or stuck off


Sent from my iPhone using Bimmerfest

Located in Dayton Ohio.


Sent from my iPhone using Bimmerfest mobile app
Reply With Quote
  #5  
Old 08-16-2019, 02:27 AM
Chedley Chedley is offline
Officially Welcomed to the 'Fest
Location: Beaverton, Oregon, USA
 
Join Date: Oct 2016
Posts: 1,097
Mein Auto: 2001 E39 540i
No, the transmission service -or lack of- should not cause the error you are having. Though, given the age of your car, it is a very good idea to do a full transmission service: replace the transmission filter, fluid and pan gasket, screws and plugs.

But how is your battery and alternator ?? I'd check and test it first. A weak or discharged battery/alternator is known to cause many sporadic errors on the ZF tranny.
__________________
<=E39=>

Last edited by Chedley; 08-16-2019 at 02:42 AM.
Reply With Quote
  #6  
Old 08-16-2019, 07:33 AM
Ianfl Ianfl is online now
Registered User
 
Join Date: Aug 2019
Posts: 5
Mein Auto:
Quote:
Originally Posted by Chedley View Post
No, the transmission service -or lack of- should not cause the error you are having. Though, given the age of your car, it is a very good idea to do a full transmission service: replace the transmission filter, fluid and pan gasket, screws and plugs.

But how is your battery and alternator ?? I'd check and test it first. A weak or discharged battery/alternator is known to cause many sporadic errors on the ZF tranny.


I went out and accessed the voltmeter on the dash and it was around 13v with nothing on. Turned high beams, wipers and rear defroster. 13.5v doesn’t seem to be alternator? Or am I missing something?


Sent from my iPhone using Bimmerfest mobile app
Reply With Quote
  #7  
Old 08-16-2019, 03:39 PM
mattmar1's Avatar
mattmar1 mattmar1 is offline
Wingnut
Location: Louisiana
 
Join Date: Dec 2014
Posts: 3,062
Mein Auto: 1999 5281 5 sp msport
at idle or a higher rpm? the OBC voltage tends to run around .3vdc lower than actual. id say it looks ok.
__________________
99 528i 5sp sport


be alert...the world needs more lerts
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:52 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.