F30 2012 - No communication with driver module left. Help with wiring needed - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series & 4 Series > F30 / F31 / F32 / F33 / F34 / F36 (2012 - current)

F30 / F31 / F32 / F33 / F34 / F36 (2012 - current)
The sixth generation BMW 3 Series Sedan F30/F31/F34 and the first first generation 4 Series Coupe F32/F33/F36. Get the latest 3 and 4 series pricing from our ordering and pricing guide sticky thread.

Reply
 
Thread Tools Display Modes
  #1  
Old 07-04-2018, 01:48 PM
Kjetil93 Kjetil93 is offline
Fisherman
Location: Norway
 
Join Date: Jun 2018
Posts: 9
Mein Auto: BMW 320d F30 2012
F30 2012 - No communication with driver module left. Help with wiring needed

Recently got problems with my left headlight driver module on my F30 2012 mod.
Fault in dashboard: Headlight Vertical Aim Control Failure

Had the car at the local BMW workshop, told me the driver module was broken, got a brand new.

Changed the module and put in the new one, angel eyes(day/parkinglight) stopped working.
Still same faultcodes in Ista;
- LWR System Faulty
- Headlight Driver Module (TMS) Left (LIN): No LIN slave
(No communication with left-hand headlight driver module)

If I put the old module back the angel eyes are working, but stay on for a while after I lock the car (Only left side)

I have looked at wiring diagrams and forums for weeks to try to solve this.

Things I have done so far:

- Reattached and cleaned the left headlight connector (Many times)
- Reattached the headlight driver module (3 different cards)
- Checked all fuses in the rear and front power supply/fuse box.
- Checked for damaged wiring
- Updated all firmware
- Initialize module in Ista (No connection)

Everything else is working just fine on the headlights, only impact on the daylight left.
As far as I understand the headlight wiring comes directly from FEM, but thats about it.. Have also been told the driver module have its own voltage supply.

I am just about to go on my Europe roadtrip, so any help solving this matter would be greatly appreciated!
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 07-05-2018, 04:53 AM
Kjetil93 Kjetil93 is offline
Fisherman
Location: Norway
 
Join Date: Jun 2018
Posts: 9
Mein Auto: BMW 320d F30 2012
Update on this case:

I have double checked supply and grounding to the module, ~12v.

I now believe the signal from the LIN-bus in the headlight to FEM is broken/interrupted.
The signal cable is A173*4B, Pin 53. I know the cable comes from FEM, but where is it connected to the headlight?

If anyone know more about this please let me know!
Reply With Quote
  #3  
Old 10-15-2019, 06:28 AM
Pederseen Pederseen is offline
Registered User
Location: Norway
 
Join Date: Feb 2019
Posts: 6
Mein Auto: E61 530XD LCI
Quote:
Originally Posted by Kjetil93 View Post
Update on this case:

I have double checked supply and grounding to the module, ~12v.

I now believe the signal from the LIN-bus in the headlight to FEM is broken/interrupted.
The signal cable is A173*4B, Pin 53. I know the cable comes from FEM, but where is it connected to the headlight?

If anyone know more about this please let me know!
Have you come to any solution for this? I am having problem with my E61 and no connection with LIN bus...
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 10-15-2019, 08:57 AM
Kjetil93 Kjetil93 is offline
Fisherman
Location: Norway
 
Join Date: Jun 2018
Posts: 9
Mein Auto: BMW 320d F30 2012
Quote:
Originally Posted by Pederseen View Post
Quote:
Originally Posted by Kjetil93 View Post
Update on this case:

I have double checked supply and grounding to the module, ~12v.

I now believe the signal from the LIN-bus in the headlight to FEM is broken/interrupted.
The signal cable is A173*4B, Pin 53. I know the cable comes from FEM, but where is it connected to the headlight?

If anyone know more about this please let me know!
Have you come to any solution for this? I am having problem with my E61 and no connection with LIN bus...
Hello Pederseen ***x1f642;

For me it was only a bad cable in the headlight (Yellow/Brown signal cable) Cable looked OK, but was broken inside. Check all the cables going to the headlight with a multimeter. But could also be other problems I guess. Feel free to contact me if you need more help. I still have all the wiring diagrams etc. I see you also live in norway so it should be no problem ***x1f609;
Reply With Quote
  #5  
Old 10-15-2019, 10:51 AM
adhrp adhrp is offline
Officially Welcomed to the 'Fest
Location: US
 
Join Date: Feb 2014
Posts: 602
Mein Auto: 2012 F30 328i
I had a similar issue where my car (2012 328i F30) had started throwing a warning on the dash saying 'adaptive light malfunction' and 'vertical aim malfunction'. The auto high beams did not activate on either side, and the passenger side headlights stayed on for about 5 minutes after the car was shut-off and locked. I believe the cornering lights were malfunctioning too. One of the indy's tried changing the headlight module but it made no difference. Then he suggested the FEM module. I doubted that. So I went to another top indy in my area and after a few hours of diagnosing they found that it was a chafed cable on the malfunctioning side (passenger side). They spliced the cable and problem solved!
__________________


2012 328i Luxury Line | Glacier Silver/Saddle Brown | Premium pkg | Tech pkg | Cold weather pkg | Lighting pkg | Park distance control | Anti-theft alarm system
Reply With Quote
  #6  
Old 10-15-2019, 11:22 AM
Pederseen Pederseen is offline
Registered User
Location: Norway
 
Join Date: Feb 2019
Posts: 6
Mein Auto: E61 530XD LCI
Quote:
Originally Posted by Kjetil93 View Post
Hello Pederseen ***x1f642;

For me it was only a bad cable in the headlight (Yellow/Brown signal cable) Cable looked OK, but was broken inside. Check all the cables going to the headlight with a multimeter. But could also be other problems I guess. Feel free to contact me if you need more help. I still have all the wiring diagrams etc. I see you also live in norway so it should be no problem ***x1f609;
Guess i'll need to find my multimeter and start meassuring...
Problem is that I cant find any chart of what the different cables in the headlight is for. So hard to see what is earth and etc...
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series & 4 Series > F30 / F31 / F32 / F33 / F34 / F36 (2012 - current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:56 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.