power steering problem - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 06-12-2019, 05:35 PM
mohamedrani mohamedrani is offline
Officially Welcomed to the 'Fest
Location: Russia
 
Join Date: May 2018
Posts: 175
Mein Auto: 520i 1998
power steering problem

Hey guys ,
the situation is this :

my steering wheel whine so bad when i drive for few minutes ( when it gets hot actually), so i changed the oil in the resivour and flushed it couple of times and then filled it and cleared the air from the system , it got quite as new , but the problem raised again when i try to get the steering wheel near to max write or left and the steering feels like something is blocking it or just heavy ,
i think it's the pump itself needs to be changed , what should i buy
only the pump as in pic 1&2 , or like in page 3 because i got confused
do i need to change the resivour and hoses also or not ?
Attached Thumbnails
Click image for larger version

Name:	FfFPofIu.png
Views:	31
Size:	126.5 KB
ID:	854717   Click image for larger version

Name:	srWIoM0b.png
Views:	30
Size:	144.3 KB
ID:	854719   Click image for larger version

Name:	hpUEOoY8.png
Views:	30
Size:	245.7 KB
ID:	854721  
__________________
Current Garage
98 E39 520i - 260k KM
bn63605
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 06-12-2019, 07:56 PM
CSMBlack-540i CSMBlack-540i is offline
Search, Read, THEN Ask
Location: "Empire State" of Mind
 
Join Date: Sep 2002
Posts: 2,870
Mein Auto: CDN 98 540i M62 3.15
Did you check RealOEM?

https://www.realoem.com/bmw/enUS/sho...diagId=32_0720

If new pump, look for the equivalent of the below part number 32411094098 in Russia:

https://www.fcpeuro.com/products?utf...ds=32411094098

https://www.ecstuning.com/b-luk-part...411094098~luk/

So, if you plan to keep the car for a long time, I would replace the hoses too since most of them are leaking by now.

Since you've cleaned the reservoir and flushed the system already, the reservoir filter should be rather clean. On the other hand, the reservoir is only USD$15-$20. Therefore, up to you if worth it or not since it's rather cheap since you'll be overhauling the PS system with pump, hoses and new fluid.

Last edited by CSMBlack-540i; 06-13-2019 at 06:55 AM.
Reply With Quote
  #3  
Old 06-14-2019, 09:19 AM
mohamedrani mohamedrani is offline
Officially Welcomed to the 'Fest
Location: Russia
 
Join Date: May 2018
Posts: 175
Mein Auto: 520i 1998
Quote:
Originally Posted by CSMBlack-540i View Post
Did you check RealOEM?

https://www.realoem.com/bmw/enUS/sho...diagId=32_0720

If new pump, look for the equivalent of the below part number 32411094098 in Russia:

https://www.fcpeuro.com/products?utf...ds=32411094098

https://www.ecstuning.com/b-luk-part...411094098~luk/

So, if you plan to keep the car for a long time, I would replace the hoses too since most of them are leaking by now.

Since you've cleaned the reservoir and flushed the system already, the reservoir filter should be rather clean. On the other hand, the reservoir is only USD$15-$20. Therefore, up to you if worth it or not since it's rather cheap since you'll be overhauling the PS system with pump, hoses and new fluid.
thanks alot, will change them , the problem is i can't find anywhere the hoses for the system,only original and the delivery will be after 68 days...yes 68 days i'm not kidding and the price is almost 300$ for only one of them )
__________________
Current Garage
98 E39 520i - 260k KM
bn63605
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 06-14-2019, 10:13 AM
528iAut 528iAut is offline
Officially Welcomed to the 'Fest
Location: Moraira, Spain
 
Join Date: May 2016
Posts: 2,072
Mein Auto: 1996 528i
Think its normal with a little noise when steering wheel is all the way to one side.
__________________
E39 528i Steptronic 1996, Comfort seats, Rear sunshade, Focal amplifier and front speakers, Oxford Green.
Reply With Quote
  #5  
Old 06-15-2019, 05:35 PM
mohamedrani mohamedrani is offline
Officially Welcomed to the 'Fest
Location: Russia
 
Join Date: May 2018
Posts: 175
Mein Auto: 520i 1998
Quote:
Originally Posted by 528iAut View Post
Think its normal with a little noise when steering wheel is all the way to one side.
unfortunately i don't have " little noise" i have very freakin loud whining plus the steering wheel gets heavy too !
__________________
Current Garage
98 E39 520i - 260k KM
bn63605
Reply With Quote
  #6  
Old 06-15-2019, 05:52 PM
Chedley Chedley is online now
Officially Welcomed to the 'Fest
Location: Beaverton, Oregon, USA
 
Join Date: Oct 2016
Posts: 1,053
Mein Auto: 2001 E39 540i
Did you by chance mix power steering fluids, using a different new fluid ? Did you fully flush out the old ?
Did you unscrew the bolt at the bottom of the pump to drain all the old fluid ?? Did you use the right synthetic type of new power steering fluid ??

Any or all the above can cause the symptoms you are describing. But your power steering pump may be just fine.
__________________
<=E39=>
Reply With Quote
  #7  
Old 06-15-2019, 05:53 PM
Chedley Chedley is online now
Officially Welcomed to the 'Fest
Location: Beaverton, Oregon, USA
 
Join Date: Oct 2016
Posts: 1,053
Mein Auto: 2001 E39 540i
Did you by chance mix power steering fluids, using a different new fluid ? Did you fully flush out the old ?
Did you unscrew the bolt at the bottom of the pump to drain all the old fluid ?? Did you use the right synthetic type of new power steering fluid ??

Any or all the above can cause the symptoms you are describing. But your power steering pump may be just fine.
__________________
<=E39=>
Reply With Quote
  #8  
Old 06-15-2019, 06:12 PM
mohamedrani mohamedrani is offline
Officially Welcomed to the 'Fest
Location: Russia
 
Join Date: May 2018
Posts: 175
Mein Auto: 520i 1998
Quote:
Originally Posted by Chedley View Post
Did you by chance mix power steering fluids, using a different new fluid ? Did you fully flush out the old ?
Did you unscrew the bolt at the bottom of the pump to drain all the old fluid ?? Did you use the right synthetic type of new power steering fluid ??

Any or all the above can cause the symptoms you are describing. But your power steering pump may be just fine.
well , i didn't mix fluids, i emptied the tank and filled it totally with new one
about the bolt, i didn't know about that, where should it be , if you have any photo would be great

what i did:
1-lift the car on jacks
2-sucked all the fluid from the tank
3-kept turning the wheel to lock right and left
4-sucked the fluid again
5-kept doing that couple of times
6-took the tank away and cleaned it with fuel then installed it again
7-filled the tank and removed the air from the system

results:
less than one day enjoying quiet smooth steering wheel then the sound appeared again
__________________
Current Garage
98 E39 520i - 260k KM
bn63605

Last edited by mohamedrani; 06-15-2019 at 06:13 PM.
Reply With Quote
  #9  
Old 06-15-2019, 09:44 PM
Chedley Chedley is online now
Officially Welcomed to the 'Fest
Location: Beaverton, Oregon, USA
 
Join Date: Oct 2016
Posts: 1,053
Mein Auto: 2001 E39 540i
Step 7 above should be :
-- Unscrew the bolt at the bottom of the power steering pump (with a 7mm Allen socket wrench)
-- Drain the remaining fluid
-- Screw the bolt back in hand tight- after replacing its O-ring gasket, though it is not necessary
-- Refill the power steering fluid to the max mark
__________________
<=E39=>
Reply With Quote
  #10  
Old 06-16-2019, 08:12 AM
mohamedrani mohamedrani is offline
Officially Welcomed to the 'Fest
Location: Russia
 
Join Date: May 2018
Posts: 175
Mein Auto: 520i 1998
Quote:
Originally Posted by Chedley View Post
Step 7 above should be :
-- Unscrew the bolt at the bottom of the power steering pump (with a 7mm Allen socket wrench)
-- Drain the remaining fluid
-- Screw the bolt back in hand tight- after replacing its O-ring gasket, though it is not necessary
-- Refill the power steering fluid to the max mark
will do that today,
someone told me that to complete the process , i need to empty the fluid from the Steer.col is that true?
__________________
Current Garage
98 E39 520i - 260k KM
bn63605
Reply With Quote
  #11  
Old 06-16-2019, 08:32 AM
mohamedrani mohamedrani is offline
Officially Welcomed to the 'Fest
Location: Russia
 
Join Date: May 2018
Posts: 175
Mein Auto: 520i 1998
Quote:
Originally Posted by Chedley View Post
Did you by chance mix power steering fluids, using a different new fluid ? Did you fully flush out the old ?
Did you unscrew the bolt at the bottom of the pump to drain all the old fluid ?? Did you use the right synthetic type of new power steering fluid ??

Any or all the above can cause the symptoms you are describing. But your power steering pump may be just fine.
DEXRON III semi-synthetics that's what i'm using , is that normal?
__________________
Current Garage
98 E39 520i - 260k KM
bn63605
Reply With Quote
  #12  
Old 06-17-2019, 05:27 AM
528iAut 528iAut is offline
Officially Welcomed to the 'Fest
Location: Moraira, Spain
 
Join Date: May 2016
Posts: 2,072
Mein Auto: 1996 528i
On the filler cap it should say ATF only, and you use ATF so it should be ok.
__________________
E39 528i Steptronic 1996, Comfort seats, Rear sunshade, Focal amplifier and front speakers, Oxford Green.
Reply With Quote
  #13  
Old 06-17-2019, 12:06 PM
mattmar1's Avatar
mattmar1 mattmar1 is offline
Wingnut
Location: Louisiana
 
Join Date: Dec 2014
Posts: 3,000
Mein Auto: 1999 5281 5 sp msport
newer ps caps have chf 115 on them, but the usage of chf 115 didnt start til the E60. dont use it on the e39.
__________________
99 528i 5sp sport


be alert...the world needs more lerts
Reply With Quote
  #14  
Old 06-17-2019, 03:25 PM
mohamedrani mohamedrani is offline
Officially Welcomed to the 'Fest
Location: Russia
 
Join Date: May 2018
Posts: 175
Mein Auto: 520i 1998
Quote:
Originally Posted by mattmar1 View Post
newer ps caps have chf 115 on them, but the usage of chf 115 didnt start til the E60. dont use it on the e39.
well yeah , i use ATF and the cap has ATF only written on it, but i used semi-synthetics fluid dexron III , will flush and fill it with synthetics fluid dexron III and hopefully it fixes the issue
__________________
Current Garage
98 E39 520i - 260k KM
bn63605
Reply With Quote
  #15  
Old 06-18-2019, 04:07 PM
mohamedrani mohamedrani is offline
Officially Welcomed to the 'Fest
Location: Russia
 
Join Date: May 2018
Posts: 175
Mein Auto: 520i 1998
UPDATE :

Unfortunatly i drained the system , took the air out , but yet again started to whine when it got warm, so i'm going to get a new pump with new resoviuor
__________________
Current Garage
98 E39 520i - 260k KM
bn63605
Reply With Quote
  #16  
Old 06-18-2019, 11:34 PM
Chedley Chedley is online now
Officially Welcomed to the 'Fest
Location: Beaverton, Oregon, USA
 
Join Date: Oct 2016
Posts: 1,053
Mein Auto: 2001 E39 540i
If you are installing a new pump and new reservoir, you might as well replace the hoses.
Certainly, make sure you use new clamps to tighten them up.
__________________
<=E39=>
Reply With Quote
  #17  
Old 06-21-2019, 04:39 PM
mohamedrani mohamedrani is offline
Officially Welcomed to the 'Fest
Location: Russia
 
Join Date: May 2018
Posts: 175
Mein Auto: 520i 1998
UPDATE:

changed everything and just noticed that I've always had a problem with that pump , there was always a sound like i'm driving an electrical car when i accelerate , that of course before the whining sound started to be high and the wheel gets heavy , but i thought maybe that's the car's sound
__________________
Current Garage
98 E39 520i - 260k KM
bn63605
Reply With Quote
  #18  
Old 06-22-2019, 08:54 AM
crazy4trains's Avatar
crazy4trains crazy4trains is offline
Officially Welcomed to the 'Fest
Location: Milton, WV
 
Join Date: Mar 2011
Posts: 2,326
Mein Auto: 2002 530i Sport
So, did changing the pump solve the problem?
__________________
2002 530i
Reply With Quote
  #19  
Old 06-22-2019, 09:28 AM
mohamedrani mohamedrani is offline
Officially Welcomed to the 'Fest
Location: Russia
 
Join Date: May 2018
Posts: 175
Mein Auto: 520i 1998
Quote:
Originally Posted by crazy4trains View Post
So, did changing the pump solve the problem?
Yep , all good now ))
__________________
Current Garage
98 E39 520i - 260k KM
bn63605
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:20 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.