bad vibrations - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 / E61 (2004 - 2010)

E60 / E61 (2004 - 2010)
BMW 5-Series E60 Sedan was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E61 wagon followed shortly there after. The E60/E61 5 series is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 07-09-2008, 10:33 AM
winger winger is offline
 
Join Date: Sep 2007
Posts: 8
Mein Auto:
Unhappy bad vibrations

I know we are all passionate about our Bimmers and it gets us in trouble as we sometimes expect perfection, however.... Ever since I got my torsion arm replaced in my 04 530i I have experienced vibration in the steering wheel. It happens at idle and when driving. no engine lights on. I am thinking that it has to do with engine mounts. Its driving me nuts, while its not a huge vibration, I hate it. Any suggestions... Do you think they forgot a grommet or two. They actually replaced one engine mount but that did not make any difference. Please tell me I am not going nuts!
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 / E61 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:05 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.