Signs of a failing ignition switch? - Page 3 - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #51  
Old 04-19-2014, 08:05 AM
Libryum1 Libryum1 is offline
Registered User
Location: Orange County
 
Join Date: Apr 2014
Posts: 3
Mein Auto: 2002 525i
Quote:
Originally Posted by QSilver7 View Post
You "read that it could be the ignition switch"....so, did you watch the video in post #1 & post #19 (the follow up video)? And if you did...were you able to replicate any of the odd electrical gremlins?
Hi QSilver7 - I did watch both videos and I even tried the visor thing to see if I would replicate the electrical gremlins, and I had no luck using the visor approach. However, when I pull down the visor, the light automatically comes on which is strange because it should only come on when I slide the mirror cover to the left. On the driver side visor, this does not happen. But I am experiencing all the other gremlins you mention: steering wheel moving up and down, radio shuts off or sometimes does not work, steering wheel control buttons don't work at times and same with the horn and airbag light is on, etc.. And right now it feels as if my car is driving in another gear. Do you think this is still the ignition switch? Thoughts? Your input us much appreciated.
Reply With Quote
Sponsored Links
Advertisement
 
  #52  
Old 05-01-2014, 07:31 PM
bluebee's Avatar
bluebee bluebee is offline
Seek to understand,^Value
Location: San Jose, California
 
Join Date: Mar 2008
Posts: 25,199
Mein Auto: 02 BMW 525i M54 auto 130K
Another failed ignition switch today:
> E39 (1997 - 2003) > Spinning Key ignition ( tumbler )
Quote:
Originally Posted by Bmw e39 prob View Post
Hello guys,

I own a 1997 e39 and when i got home and removed the key the car stayed on. Now I've dealt with this problem only a week ago with my other 1998 e39 and successfully removed the tumbler fairly easy.

However, this case is different as the tumbler acts as if its the wrong key (trust me its not). It rotates freely and I can remove the key in any position id like. So I'm not sure how to tackle this I've tried over 4 hours with the pin but no luck.

I place the key where position 2 would be but nothing. Any ideas ??
__________________
Please read the suggested threads and add value, either by pictures or by descriptions, so the next person stands on your shoulders.
See also: E39 Bestlinks & How to easily find what you need
Reply With Quote
  #53  
Old 05-14-2014, 10:02 AM
bluebee's Avatar
bluebee bluebee is offline
Seek to understand,^Value
Location: San Jose, California
 
Join Date: Mar 2008
Posts: 25,199
Mein Auto: 02 BMW 525i M54 auto 130K
For the record, this failing ignition switch thread was updated today;
> E39 (1997 - 2003) > Help- Can't remove key from the ignition
__________________
Please read the suggested threads and add value, either by pictures or by descriptions, so the next person stands on your shoulders.
See also: E39 Bestlinks & How to easily find what you need
Reply With Quote
Sponsored Links
Advertisement
 
  #54  
Old 06-03-2014, 01:54 PM
MJB9 MJB9 is offline
Officially Welcomed to the 'Fest
Location: Keller, TX (DFW)
 
Join Date: Feb 2012
Posts: 503
Mein Auto: 2002 525i (E39)
Quote:
Originally Posted by shenecke View Post
Un-foking believable! I had the same symptoms radio turning off, steering wheel raising and none of the buttons on the steering wheel working. Did the passenger mirror trick and radio off, wheel raises! Bad ignition switch. Cost me about $80 for the switch, 1 hour and it fixed all the problems. Took the old one apart and it did'nt even look that bad. No pitting on the contacts, just a little black carbon on them. I never would have guessed it was bad just from looking at the contacts.

Kudos to whom ever first diagnosed this problem and the cure!
Same exact problems (although no trainy light like some others here). Will replace. Was going to rebuild the switch, but for the money, I'll just buy new for peace of mind. I rebuilt my instrument cluster because that was too costly to get new, but for $70 for a new switch, I'll buy new.
Reply With Quote
  #55  
Old 06-06-2014, 07:39 PM
MJB9 MJB9 is offline
Officially Welcomed to the 'Fest
Location: Keller, TX (DFW)
 
Join Date: Feb 2012
Posts: 503
Mein Auto: 2002 525i (E39)
Quote:
Originally Posted by mjbennett9 View Post
Same exact problems (although no trainy light like some others here). Will replace. Was going to rebuild the switch, but for the money, I'll just buy new for peace of mind. I rebuilt my instrument cluster because that was too costly to get new, but for $70 for a new switch, I'll buy new.
Replaced today in about 45 minutes, including dropping the lower part of the dash under the steering wheel. Note. be sure to align the white plastic end that inserts into the steering column. I installed mine initially but the key wouldn't turn. I didn't have it aligned right, but it installed like it did. I had to take apart, align the new part, and reinstall. Good to go!

Last edited by MJB9; 02-22-2015 at 02:25 PM.
Reply With Quote
  #56  
Old 06-07-2014, 08:32 AM
freeboy freeboy is offline
Registered User
Location: uyo,akwa ibom,nigeria
 
Join Date: Jun 2014
Posts: 2
Mein Auto: bmw 528i
hi
Reply With Quote
  #57  
Old 06-07-2014, 08:34 AM
freeboy freeboy is offline
Registered User
Location: uyo,akwa ibom,nigeria
 
Join Date: Jun 2014
Posts: 2
Mein Auto: bmw 528i
my e39 is given me hard starting
Reply With Quote
  #58  
Old 02-22-2015, 12:40 PM
1SRS7886X5 1SRS7886X5 is offline
EMPR"X5"ARIO
Location: SURFCITYUSA
 
Join Date: Feb 2015
Posts: 12
Mein Auto: e53 X5 4.4i
Great input Qsilver7 shed sunlight on this dark situation!
Reply With Quote
  #59  
Old 02-22-2015, 12:47 PM
1SRS7886X5 1SRS7886X5 is offline
EMPR"X5"ARIO
Location: SURFCITYUSA
 
Join Date: Feb 2015
Posts: 12
Mein Auto: e53 X5 4.4i
Thank you for input

Great input Qsilver7 shed sunlight on this dark situation!
Reply With Quote
  #60  
Old 02-22-2015, 04:13 PM
QSilver7's Avatar
QSilver7 QSilver7 is online now
Officially Welcomed to the 'Fest
Location: Northeast Indiana
 
Join Date: Aug 2008
Posts: 11,891
Mein Auto: 2006 X5 4.4/2013 650ix GC
__________________
Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 2013 F06 650ix Gran Coupe` (Black Sapphire) 1/13 mfg date
(SOLD)
97 740iL (Arctic Silver) <<~>> 99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

https://www.bimmerforums.com/forum/attachment.php?attachmentid=637911&d=1538398374&thumb=1&stc=1
Reply With Quote
  #61  
Old 02-22-2015, 08:05 PM
brc5 brc5 is offline
Officially Welcomed to the 'Fest
Location: QLD, Aus
 
Join Date: Sep 2011
Posts: 190
Mein Auto: 535i, X5, 911
For me, cruise control kept cutting out and airbag light came on. Fixed with new switch.
__________________

Limiters limiting the fun
Reply With Quote
  #62  
Old 02-23-2015, 11:26 AM
MJB9 MJB9 is offline
Officially Welcomed to the 'Fest
Location: Keller, TX (DFW)
 
Join Date: Feb 2012
Posts: 503
Mein Auto: 2002 525i (E39)
for me, several electric gremlins, steering column acting out on its own/sticking in a position, or going in/out non-stop. Intermittent hard starting/no starting. Replaced (OEM) and all good.
Reply With Quote
  #63  
Old 02-23-2015, 04:42 PM
540 M-Sport's Avatar
540 M-Sport 540 M-Sport is offline
Officially Welcomed to the 'Fest
Location: Seattle, WA
 
Join Date: Apr 2004
Posts: 7,047
Mein Auto: M550i, 540M-Sport, Scud
I replaced my ignition switch (oem) in summer 2009, and a few months ago, it started the intermittent problem of continuously cranking when starting. I have to return to position "0" to get it to stop. When I start again, all is well. This happens about once per month. Bought a new oem switch, have not had time to install it...may just give it to my tech to handle...
__________________
540 M-Sport package (Canadian market), factory Bluetooth phone integration, factory M-Audio 10" dual voice coil subs, Homelink, Eibach front and rear anti-roll bars, M5 rear traction rods, H&R 15mm wheel spacers, ST X (KW) coilovers, Strong Strut front upper stress bar, BMP strut tower reinforcement kit, Stop Tech ss brake lines, Akebono Euro Ceramic brake pads, Zimmerman rotors, Dinan Stage 1 software, USA Spec Ipod/Iphone integration.
Reply With Quote
  #64  
Old 04-20-2016, 08:29 PM
ID540i ID540i is offline
Registered User
Location: Meridian, Idaho
 
Join Date: Apr 2016
Posts: 4
Mein Auto: 2002 BMW 540i
Thanks

Thanks to bobdmac and bimmerfest. Would never have look for faultyy ignition switch with issues we were having. Video in thread was invaluable. $55 and an hour or so and all is well. Thanks again
Reply With Quote
  #65  
Old 04-20-2016, 09:20 PM
Sroor9001 Sroor9001 is offline
ALGhoul
Location: Bahrain
 
Join Date: May 2014
Posts: 1,254
Mein Auto: Bmw 525i 2002
For me I've added push start button with RFID for the push start button so Iam playing with wires so no more failing ignition switch which is crazy in our e39
Reply With Quote
  #66  
Old 04-21-2016, 06:32 AM
QSilver7's Avatar
QSilver7 QSilver7 is online now
Officially Welcomed to the 'Fest
Location: Northeast Indiana
 
Join Date: Aug 2008
Posts: 11,891
Mein Auto: 2006 X5 4.4/2013 650ix GC
Quote:
Originally Posted by 540 M-Sport View Post
I replaced my ignition switch (oem) in summer 2009, and a few months ago, it started the intermittent problem of continuously cranking when starting. I have to return to position "0" to get it to stop. When I start again, all is well. This happens about once per month. Bought a new oem switch, have not had time to install it...may just give it to my tech to handle...
Although this is a reply to a post that is over a year old...I thought something should be said just in case someone doesn't know about the "one-touch-start" aka "convenience start" aka "auto start" feature.

The text bolded in the quote above (continuous cranking when starting)...isn't necessarily an issue with the ignition switch...nor the starter on the V8 or V12 engines from the BMW (e38/e39/e52/e53) generation.

These models have a "convenience start" feature that will continue to run until the engine starts. So if you are experiencing this issue...again, its probably not the ignition or the starter...but an issue with the engine whereby something is preventing the correct mixture of fuel/air/spark that would allow the engine to normally start.

This convenience start/auto start feature is explained in the 2nd paragraph taken from the owners manual:


This feature is also mentioned in this EWS chart which reveals when this feature debuted and what engines received it...look in the "one touch start" column:

__________________
Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 2013 F06 650ix Gran Coupe` (Black Sapphire) 1/13 mfg date
(SOLD)
97 740iL (Arctic Silver) <<~>> 99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

https://www.bimmerforums.com/forum/attachment.php?attachmentid=637911&d=1538398374&thumb=1&stc=1
Reply With Quote
  #67  
Old 04-21-2016, 04:42 PM
540 M-Sport's Avatar
540 M-Sport 540 M-Sport is offline
Officially Welcomed to the 'Fest
Location: Seattle, WA
 
Join Date: Apr 2004
Posts: 7,047
Mein Auto: M550i, 540M-Sport, Scud
Interesting, but I disagree....I had the ignition switched replaced a couple months after I posted, and the issue went away, just like when I replaced the switch previously.
__________________
540 M-Sport package (Canadian market), factory Bluetooth phone integration, factory M-Audio 10" dual voice coil subs, Homelink, Eibach front and rear anti-roll bars, M5 rear traction rods, H&R 15mm wheel spacers, ST X (KW) coilovers, Strong Strut front upper stress bar, BMP strut tower reinforcement kit, Stop Tech ss brake lines, Akebono Euro Ceramic brake pads, Zimmerman rotors, Dinan Stage 1 software, USA Spec Ipod/Iphone integration.
Reply With Quote
  #68  
Old 07-07-2016, 01:05 PM
jaytee1972 jaytee1972 is offline
Registered User
Location: Florida Gulf coast
 
Join Date: Jul 2016
Posts: 2
Mein Auto: 2001 530i
Thank you so much for this post, had I not read this post before my daughter had the problem I would have thought she was smoking crack! Fixed it no problem after 3 trips to the part store.

Note to self: Always take the part with you to the store to compare.

Oddly 2 parts were labeled by advanced auto as a match, but the "L-shaped" doo-hickey in the connector was backwards.
Reply With Quote
  #69  
Old 08-25-2016, 06:06 AM
Rec0n Rec0n is offline
Registered User
Location: Melbourne
 
Join Date: Jun 2016
Posts: 2
Mein Auto: E60, 530i Motorsport
Thanks to the OP for creating this thread. My Google search yielded this thread straight away, and much to my shock, I got the radio etc to work again by flipping down the passenger visor and turning on the vanity light.
I will add my symptoms for the sake of the next person who Googles this issue.
  • Radio display off - radio on.......then it turns off again randomly. A flip of the vanity fixes it.
  • Airbag light is on all the time - fades out sometimes when I wiggle the cables on the Ign Sw
  • Clock turns off randomly and pressing the SET button brings it on.
  • Steering wheel controls don't work, incl illumination
  • Mirrors not moving at times
  • Accessory power to my dash-cam cuts out at times
  • Accessory power to mobile BT module cuts out at times and reconnects
  • iPod interface module power drops out at times (GRoM accessory unit)
  • car will not crank - I have to tap the back of the ignition switch with a screwdriver handle to get it going until my switch comes into stock

This will be my second ignition switch in 4 years on mine too. The first time the car just would not crank - never noticed anything else happening.

Thanks again for this great forum that shares all of the odd ball BMW issues so we can all enjoy these great machines!

UPDATE: Replaced the ignition switch today after a wait for parts. All issues now fixed and she starts like it should again. Easy fix for anyone who is worried about tackling this yourself, so give it a go.
__________________

2006 530i Motorsport, Titansilber

Last edited by Rec0n; 09-01-2016 at 05:43 AM. Reason: updated info
Reply With Quote
  #70  
Old 07-07-2019, 01:23 AM
Pls Pls is offline
Registered User
 
Join Date: Jul 2019
Posts: 2
Mein Auto:
Okay, first of all, I just replaced my battery and starter. I am wondering if I need to replace my ignition switch, but I have an e90, 2006 325xi and do not know if this diagnosis applies to my model..... Symptoms include:

Instrument cluster turns on and of sporadically during driving, with ABS, airbag, and e brake lights coming on.

Radio turns on and off randomly while driving

Wipers will not work while driving but turn themselves on randomly in the middle of the night! Key out, car off... Scary!

Blinkers work, but display on dash sporadically.

Please help, I feel like my car is going to eat me!
Reply With Quote
  #71  
Old 07-07-2019, 05:51 AM
528iAut 528iAut is offline
Officially Welcomed to the 'Fest
Location: Moraira, Spain
 
Join Date: May 2016
Posts: 2,331
Mein Auto: 1996 528i
Did you post in the correct forum also? This is about e39 only....
__________________
E39 528i Steptronic 1996, Comfort seats, Rear sunshade, Focal amplifier and front speakers, Oxford Green.
Reply With Quote
  #72  
Old 07-07-2019, 08:58 AM
Pls Pls is offline
Registered User
 
Join Date: Jul 2019
Posts: 2
Mein Auto:
I did not, I could not find any similar threads in the 3 series forums. I was hoping just for some insight from someone with a similar issue.
Reply With Quote
  #73  
Old 07-07-2019, 12:29 PM
mattmar1's Avatar
mattmar1 mattmar1 is offline
Wingnut
Location: Louisiana
 
Join Date: Dec 2014
Posts: 3,508
Mein Auto: 1999 5281 5 sp msport
not knowing much about that model, but helped a friend with a similar problem once that did some similar things. turns out it was the "ECT" module (hope thats correct, been quite a while) mounted in the trunk above the battery, by putting manual pressure on the module, parts of the electric would shut off and return. might try posting in the e90 forum as well, maybe someone who can help you better will see your post.
__________________
99 528i 5sp sport


be alert...the world needs more lerts
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:08 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.