Coding Used EPS - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming

BMW Coding and Programming
Discuss coding options and features on your BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 06-11-2015, 05:00 PM
Antare Antare is offline
Registered User
Location: Philippines
 
Join Date: May 2015
Posts: 7
Mein Auto: F10 520d, E90 320i, E39
Coding Used EPS

Hi, EPS got water damaged and we bought a used EPS rack. Installed it and the car still gives out steering errors and disables power steering.

Checked that the part numbers and all are the same and I was wondering how to program the EPS from within ESYS? I would like to know how to do it in ESYS because I fear that ISTA-P might just brick the module.

Thanks in advance for any help
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 06-12-2015, 02:53 AM
BMWzone BMWzone is offline
Officially Welcomed to the 'Fest
Location: Italy
 
Join Date: May 2013
Posts: 189
Mein Auto: F10 530d
Quote:
Originally Posted by Antare View Post
Hi, EPS got water damaged and we bought a used EPS rack. Installed it and the car still gives out steering errors and disables power steering.

Checked that the part numbers and all are the same and I was wondering how to program the EPS from within ESYS? I would like to know how to do it in ESYS because I fear that ISTA-P might just brick the module.

Thanks in advance for any help
You need a code EPS with Esys.
After connected car with enet-Choice your chassis-Expert Mode-Coding-Read FA-Activate FA-Read SVT-Go to EPS ECU-Detect CAFD for SWE-Choice CAFD
__________________
F10 530d 0911
Retrofit 223 245 248 2VB 2ND 316 337 3AH 4M5 416 ->451/488-->456 453 465 494 496 552 5AD 5AE 5AG NBT 654 FM2 610 620[CIC] 677 6NR 6WA & 6WB715 760 8TH[KAFAS2-FSC] KeyFOB Mperformance Gxx Series
Reset Kombi Gxx, Virginize VINs and Mileage

Last edited by BMWzone; 06-12-2015 at 02:54 AM.
Reply With Quote
  #3  
Old 06-13-2015, 12:39 PM
Antare Antare is offline
Registered User
Location: Philippines
 
Join Date: May 2015
Posts: 7
Mein Auto: F10 520d, E90 320i, E39
Thanks

Will try this.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 06-13-2015, 01:44 PM
ac_schnitzer ac_schnitzer is offline
BMW user
Location: AT
 
Join Date: Nov 2014
Posts: 176
Mein Auto: M550i
You need only VO EPS with your FA and everithing worked - tested on my Car 100% work dont need to flash ig but i suggest to flash it to have same I - level
Reply With Quote
  #5  
Old 06-13-2015, 04:27 PM
ap90500's Avatar
ap90500 ap90500 is offline
Officially Welcomed to the 'Fest
Location: Finland
 
Join Date: Oct 2013
Posts: 1,086
Mein Auto: F30 320d xDrive -14
Yeah, vo-coding the EPS should be enough. I once coded one replaced EPS and it worked straight after vo-coding. There is one thing, servotronic. It is adaptive power steering force, and it is produced via software on cars with EPS. You must install original EPS FSC code, if you can. Limiting factor is production date of this donor EPS (if it came from a car with servotronic fsc). If this donor EPS is without servotronic FSC, then you can install repair FSC. Also if donor is older than original, then you can install repair FSC. If donor EPS is newer, maybe it is easiest to just remove servotronic from FA and code EPS.

Last edited by ap90500; 06-13-2015 at 04:28 PM.
Reply With Quote
  #6  
Old 06-15-2015, 04:18 PM
Antare Antare is offline
Registered User
Location: Philippines
 
Join Date: May 2015
Posts: 7
Mein Auto: F10 520d, E90 320i, E39
Thanks for the help. I got my EPS coded and everything is working great! to everyone who helped.
Now to off to ode other stuff to the car

Last edited by Antare; 06-15-2015 at 04:21 PM.
Reply With Quote
  #7  
Old 01-13-2016, 10:03 AM
BMW-4-Life BMW-4-Life is offline
Registered User
Location: Surrey, UK
 
Join Date: Sep 2015
Posts: 52
Mein Auto: 520d - manual - 2010
Hi guys, my F10's rack is worn out and I've bought a used replacement.

I have ISTA-P + D running OK over eNet cable ... but I'm waiting for my E-Sys token to be activated (some time in the next 48 hours) - so I can't use that for the moment.

Can I use ISTA-P to code in the replacement rack instead of E-Sys ?

The plan is to check that I have a compatible rack by plugging in the replacement and coding it in - before fitting it.

Many thanks.
Reply With Quote
  #8  
Old 01-13-2016, 10:43 AM
Secret_Asian Secret_Asian is offline
Registered User
Location: USA
 
Join Date: Sep 2013
Posts: 50
Mein Auto: 535
no token needed for this step you can do it now
Reply With Quote
  #9  
Old 01-13-2016, 01:01 PM
BMW-4-Life BMW-4-Life is offline
Registered User
Location: Surrey, UK
 
Join Date: Sep 2015
Posts: 52
Mein Auto: 520d - manual - 2010
Quote:
Originally Posted by Secret_Asian View Post
no token needed for this step you can do it now
Thankyou, SA.



I'll give it a whirl.
Reply With Quote
  #10  
Old 01-13-2016, 04:25 PM
BMW-4-Life BMW-4-Life is offline
Registered User
Location: Surrey, UK
 
Join Date: Sep 2015
Posts: 52
Mein Auto: 520d - manual - 2010
Quote:
Originally Posted by BMW-4-Life View Post
Thankyou, SA.



I'll give it a whirl.
I think it's a pre-activation issue.
The installation guide says : -
"Since people have tried to exploit the generous free tool created by Token Master, he has implemented a
48 hour delay before the software can be used. It also will only function for 1 specific model, chosen by
chassis code, so be sure to set it correctly. Please see screenshots below:"

And I get the same "Abort" rather than "Launch now" option that the screenshot refers to.

The "Abort" option window auto-closes after 5 secs and E-sys opens.
And the "Connection via VIN" even shows the correct (ZGW) IP ... but the "Connect" button stays greyed out - regardless of what connection type is selected.

Looks like I'll have to wait the 48 hours.
But thanks for your input.
Reply With Quote
  #11  
Old 01-18-2016, 08:28 AM
BMW-4-Life BMW-4-Life is offline
Registered User
Location: Surrey, UK
 
Join Date: Sep 2015
Posts: 52
Mein Auto: 520d - manual - 2010
It turned out the PSZ data files were in the wrong location (garbled installation instructions).

So I've coded in E-sys to remember the last engine Start/Stop setting used.
And I've looked through some of the EPS FA settings - but I have no idea what to change to accommodate my (used) replacement rack !

Can it ALL be done in ISTA-P (rather than just the recalibratiion of the replacement rack) ?

Your kind help greatly appreciated.


Last edited by BMW-4-Life; 01-18-2016 at 08:30 AM.
Reply With Quote
  #12  
Old 01-18-2016, 08:36 AM
BMW-4-Life BMW-4-Life is offline
Registered User
Location: Surrey, UK
 
Join Date: Sep 2015
Posts: 52
Mein Auto: 520d - manual - 2010
I just re-read BMWzone's instructions - which I now understand, having used E-sys ... props and big thanks to you, BMWzone.

------------------

After connecting car with eNet : -

Expert Mode-Coding

Read FA

Activate FA

Read SVT

Select EPS ECU

Detect CAFD for SWE

Choose CAFD

Click Code

... and you'll finally be presented with a report in green font if coding was successful - or red if it wasn't.

-------

Last edited by BMW-4-Life; 03-01-2016 at 05:51 PM.
Reply With Quote
  #13  
Old 07-15-2016, 01:56 AM
BMW-4-Life BMW-4-Life is offline
Registered User
Location: Surrey, UK
 
Join Date: Sep 2015
Posts: 52
Mein Auto: 520d - manual - 2010
The important thing when changing any rack is ensuring that the clock spring (which has an end-stop approx. 1.5 turns from centre in each direction) in the steering wheel remains in the centre position during operations.
Turning the steering wheel (unconstrained because it's disconnected from the rack) beyond the clock-spring's end-stop will break it.
The steering rack must also be in its centre position when re-mated to the steering column - or you risk breaking the clock-spring by taking it beyond its end-stop when turning the rack to full-lock.

Last edited by BMW-4-Life; 07-15-2016 at 02:02 AM.
Reply With Quote
  #14  
Old 08-12-2016, 05:21 AM
BMW-4-Life BMW-4-Life is offline
Registered User
Location: Surrey, UK
 
Join Date: Sep 2015
Posts: 52
Mein Auto: 520d - manual - 2010
Here's my old rack internals on video .... post-autopsy

Last edited by BMW-4-Life; 08-12-2016 at 05:23 AM.
Reply With Quote
  #15  
Old 08-20-2016, 11:05 AM
atsapS atsapS is offline
Registered User
Location: Monaco
 
Join Date: Jun 2015
Posts: 10
Mein Auto: BMW
I got this at the moment:

F31 Pre Facelift with a used EPS motor installed because the original motors plastic cover was damaged by an accident.
Injected a caf file and vo coded the EPS module. Power steering still not working and now this is happening when the engine is on:



Only way to stop this is by shutting the engine off.

Anyone an idea?
Reply With Quote
  #16  
Old 03-19-2017, 04:11 AM
fatfash fatfash is offline
Registered User
Location: Nigeria
 
Join Date: May 2014
Posts: 19
Mein Auto: BMW X3 2012
I recently installed used EPS on my car, but tried VO coding but fails.On diagnosing ISTA/D says there is no power to the module which i have checked to be false. Does it have anything to do with the used steering rack i bought, because the donor rack is a 2017 model while my car is 2012. Any info/help will be highly appreciated.

Thanks
Reply With Quote
  #17  
Old 11-25-2017, 05:21 PM
DTKT DTKT is offline
Registered User
Location: Singapore
 
Join Date: Feb 2008
Posts: 74
Mein Auto: BMW E90 325
Quote:
Originally Posted by fatfash View Post
I recently installed used EPS on my car, but tried VO coding but fails.On diagnosing ISTA/D says there is no power to the module which i have checked to be false. Does it have anything to do with the used steering rack i bought, because the donor rack is a 2017 model while my car is 2012. Any info/help will be highly appreciated.

Thanks


Hi, im having this same issue, did you resolve it now ?


Sent from my iPhone using Tapatalk
Reply With Quote
  #18  
Old 11-25-2017, 05:28 PM
BMW-4-Life BMW-4-Life is offline
Registered User
Location: Surrey, UK
 
Join Date: Sep 2015
Posts: 52
Mein Auto: 520d - manual - 2010
Quote:
Originally Posted by fatfash View Post
I recently installed used EPS on my car, but tried VO coding but fails.On diagnosing ISTA/D says there is no power to the module which i have checked to be false. Does it have anything to do with the used steering rack i bought, because the donor rack is a 2017 model while my car is 2012. Any info/help will be highly appreciated.

Thanks
32106865433
AT-steering box, electr.

5' F10 ***8195; (01/2009 06/2013)

5' F10 LCI ***8195; (08/2012 10/2016)

http://www.realoem.com/bmw/enUS/part...&q=32106865433
Reply With Quote
  #19  
Old 11-25-2017, 08:02 PM
DTKT DTKT is offline
Registered User
Location: Singapore
 
Join Date: Feb 2008
Posts: 74
Mein Auto: BMW E90 325
Quote:
Originally Posted by BMW-4-Life View Post
32106865433

AT-steering box, electr.



5' F10 ***8195; (01/2009 06/2013)



5' F10 LCI ***8195; (08/2012 10/2016)



http://www.realoem.com/bmw/enUS/part...&q=32106865433


Hi,

Can advise please,
My current steering rack original parts number is 32106864965, but checking with the new parts number base on my car vin, its has replaced with new parts number all with 2VL, and i have purchased and installed the one with 2VL to my car and its still dont work,


Sent from my iPhone using Tapatalk
Reply With Quote
  #20  
Old 11-25-2017, 11:54 PM
fatfash fatfash is offline
Registered User
Location: Nigeria
 
Join Date: May 2014
Posts: 19
Mein Auto: BMW X3 2012
Is there power to the EPS?try turning the steering from right to left, if it turns freely fine, If not, check the B+ distribution box for broken fuse ? its on the passenger side of the engine compartment. The fuse to the EPS might be broken but there is a spare one in the same box. You will need to remove the cable supplying power to the EPS from the broken one to the spare. Also, ensure that all your power cables are well terminated. Finally you can get repair FSC code from user "acolt" for coding your new EPS with ISTA/P though you can still make use of the EPS without coding but you will always "drive rain malfunction" active while driving.

Last edited by fatfash; 11-26-2017 at 01:26 AM.
Reply With Quote
  #21  
Old 11-25-2017, 11:58 PM
fatfash fatfash is offline
Registered User
Location: Nigeria
 
Join Date: May 2014
Posts: 19
Mein Auto: BMW X3 2012
Check the link below to show you how the B+ distribution box looks like

https://www.ebay.com/itm/BMW-X3-F25-...item466b5a4b3a
Reply With Quote
  #22  
Old 11-26-2017, 12:52 AM
BMW-4-Life BMW-4-Life is offline
Registered User
Location: Surrey, UK
 
Join Date: Sep 2015
Posts: 52
Mein Auto: 520d - manual - 2010
Quote:
Originally Posted by DTKT View Post
Hi,

Can advise please,
My current steering rack original parts number is 32106864965, but checking with the new parts number base on my car vin, its has replaced with new parts number all with 2VL, and i have purchased and installed the one with 2VL to my car and its still dont work,


Sent from my iPhone using Tapatalk
Have you tried coding the replacement rack in with ISTA-P or eSys ?
Reply With Quote
  #23  
Old 11-26-2017, 01:49 AM
DTKT DTKT is offline
Registered User
Location: Singapore
 
Join Date: Feb 2008
Posts: 74
Mein Auto: BMW E90 325
Quote:
Originally Posted by BMW-4-Life View Post
Have you tried coding the replacement rack in with ISTA-P or eSys ?


Yes, but no luck


Sent from my iPhone using Tapatalk
Reply With Quote
  #24  
Old 11-26-2017, 02:55 AM
BMW-4-Life BMW-4-Life is offline
Registered User
Location: Surrey, UK
 
Join Date: Sep 2015
Posts: 52
Mein Auto: 520d - manual - 2010
I see ISTA-D ... but have you tried it with ISTA-P ? ... which offers you prompts to recode the ECU you choose.

eSys is a bit more hit and miss.
Reply With Quote
  #25  
Old 11-26-2017, 03:09 AM
DTKT DTKT is offline
Registered User
Location: Singapore
 
Join Date: Feb 2008
Posts: 74
Mein Auto: BMW E90 325
Quote:
Originally Posted by BMW-4-Life View Post
I see ISTA-D ... but have you tried it with ISTA-P ? ... which offers you prompts to recode the ECU you choose.

eSys is a bit more hit and miss.


Thanks, i dont have ISTA-P, so cannot try it ,

Thanks again, will try to source for it


Sent from my iPhone using Tapatalk
Reply With Quote
Reply

See More Related BMW Stories

Tags
eps, f10


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:22 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.