Phone issues with iDrive - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series & 8 Series > 7 Series - G11 / G12 (2016 - current)

7 Series - G11 / G12 (2016 - current)
The next generation G11/G12 BMW 7 Series flagship forum. Unveiled June 10th, with production starting in August the 6th generation 7 Series comes in a light weight package with extensive use of BMW i carbon fiber technology. The interior quality raises the bar with a touch screen and gesture controlled infotainment system. Exterior styling has been a sticking point with mixed reviews so far.

Reply
 
Thread Tools Display Modes
  #1  
Old 10-06-2018, 03:16 PM
M6 in Bama M6 in Bama is offline
Registered User
Location: South Alabama
 
Join Date: Apr 2018
Posts: 30
Mein Auto: 2016 740i, 2014 M6
Phone issues with iDrive

Hey folks, any of you guys have any issues like this with you phone pairing in BT with iDrive?

Every time I pair my Note 9, the system will reset itself several times. Black screen, no response to any inputs and after all of that, the phone lost its connection and all my settings are gone. Nav, audio, driver profile, everything.

I am going to go connect it via USB and see if I can fix it. But wanted to know if I am the only one meaning most likely defective system.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 10-07-2018, 03:04 PM
Popoemt's Avatar
Popoemt Popoemt is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2012
Posts: 5,716
Mein Auto: 2017 750i
Nothing at all, connects seamlessly, I would say it's not the phone, but an issue with the idrive...
__________________

2017 750i
2015 750i (Lease End)
2013 740 Li (Lease End)
2007 G35 (trade-in)
2003 Z06 (Black, 50th Anniversary)
2001 Z06 (Torch Red)
Reply With Quote
  #3  
Old 10-18-2018, 02:48 PM
M6 in Bama M6 in Bama is offline
Registered User
Location: South Alabama
 
Join Date: Apr 2018
Posts: 30
Mein Auto: 2016 740i, 2014 M6
Must have just been a series of updates. Been fine for over a week now.

Also, I removed the front license plate holder because my state doesn't require it. Next day, I get an iDrive notice that my front collision system has failed and my cruise control won't engage. Tried to set up an appointment where I bought the car, but after a week of them not being able to get to it and provide me with a loaner, I had an idea, wonder what would happen if I put the license plate holder back on.

Sensor has been working perfectly since then as has the cruise control. Amazing. Must be something to do with being calibrated to see through that plastic plate and it didn't know how to act without it on there.

Anybody else ever have that happen?
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 10-18-2018, 09:23 PM
Popoemt's Avatar
Popoemt Popoemt is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2012
Posts: 5,716
Mein Auto: 2017 750i
Quote:
Originally Posted by M6 in Bama View Post
Must have just been a series of updates. Been fine for over a week now.

Also, I removed the front license plate holder because my state doesn't require it. Next day, I get an iDrive notice that my front collision system has failed and my cruise control won't engage. Tried to set up an appointment where I bought the car, but after a week of them not being able to get to it and provide me with a loaner, I had an idea, wonder what would happen if I put the license plate holder back on.

Sensor has been working perfectly since then as has the cruise control. Amazing. Must be something to do with being calibrated to see through that plastic plate and it didn't know how to act without it on there.

Anybody else ever have that happen?
That is just odd. What year car?
__________________

2017 750i
2015 750i (Lease End)
2013 740 Li (Lease End)
2007 G35 (trade-in)
2003 Z06 (Black, 50th Anniversary)
2001 Z06 (Torch Red)
Reply With Quote
  #5  
Old 10-19-2018, 03:50 AM
bimmerfestfan bimmerfestfan is offline
Officially Welcomed to the 'Fest
Location: BMW Welt
 
Join Date: Jan 2014
Posts: 265
Mein Auto: G32
I'm getting dropped calls on BT with my Android phone. Is iOS the only way to go if you want perfect compatibility with iDrive?
Reply With Quote
  #6  
Old 10-19-2018, 06:26 AM
M6 in Bama M6 in Bama is offline
Registered User
Location: South Alabama
 
Join Date: Apr 2018
Posts: 30
Mein Auto: 2016 740i, 2014 M6
Quote:
Originally Posted by Popoemt View Post
That is just odd. What year car?
2016 740i. I have never heard of anything like that before.
Reply With Quote
  #7  
Old 10-19-2018, 06:31 AM
M6 in Bama M6 in Bama is offline
Registered User
Location: South Alabama
 
Join Date: Apr 2018
Posts: 30
Mein Auto: 2016 740i, 2014 M6
Quote:
Originally Posted by bimmerfestfan View Post
I'm getting dropped calls on BT with my Android phone. Is iOS the only way to go if you want perfect compatibility with iDrive?
I haven't had that issue. What phone and what version of Android?
Reply With Quote
  #8  
Old 06-16-2019, 08:24 PM
ImolaMMM's Avatar
ImolaMMM ImolaMMM is offline
Officially Welcomed to the 'Fest
Location: Atlanta
 
Join Date: Feb 2008
Posts: 2,092
Mein Auto: 2013 750 Li
My dealer says that thereís supposed to be a software update coming in July thatís going to address the issue...
__________________


2013 750 Li Alpine White/Black|M-Sport Pkg|LED Lighting Pkg|Exec Pkg|Drivers Assist Pkg|760 Exhaust Tips|Painted Calipers|CQuartz Finest

2008 Toyota Sequoia Platinum--Arctic Frost Pearl/Red Rock

2006 750 Li-Retired
2006 330i-Retired
2002 M3-Retired
2000 323Ci-Retired
1991 M3-Retired
Reply With Quote
  #9  
Old 06-17-2019, 02:35 PM
M6 in Bama M6 in Bama is offline
Registered User
Location: South Alabama
 
Join Date: Apr 2018
Posts: 30
Mein Auto: 2016 740i, 2014 M6
Quote:
Originally Posted by ImolaMMM View Post
My dealer says that thereís supposed to be a software update coming in July thatís going to address the issue...
I sure hope so. I have a service due in July anyway. Love the car other than this but this is just stupid.
Reply With Quote
  #10  
Old 06-18-2019, 12:14 PM
phamaker phamaker is offline
Registered User
Location: NL
 
Join Date: Dec 2013
Posts: 82
Mein Auto: F10 - 523
I have the same and is caused by the contacts in my iPhone, somehow it cannot deal with certain characters and linked contacts. If i scan all my contacts and remove any linked accounts it works again. Super ridiculous, i tried BT software update, but alas......error remains. Let me know if update of software resolves it, might then also upgrade the software version.
Reply With Quote
  #11  
Old 06-26-2019, 06:55 AM
JHinman JHinman is offline
Officially Welcomed to the 'Fest
Location: Idaho
 
Join Date: Dec 2015
Posts: 273
Mein Auto: 2018 Ford F350 Limited
I had issues with my iPhone in a 2016 X5. It would occasionally not load music, or The list in the HUP would stop after driving for a while. There were several idiosyncratic bugs. The dealership blamed Apple. None of the phone updates or BMW updates made any difference.

One day I took my car in for service, and the phone connection stopped on the way to the dealership. The service tech took one look at the HUD and said ďoh, thatís not right.Ē They kept my car all day and reprogrammed everything. Since then it has been much better.

My point is that it could be a software problem with your car.
Reply With Quote
  #12  
Old 07-11-2019, 03:07 PM
M6 in Bama M6 in Bama is offline
Registered User
Location: South Alabama
 
Join Date: Apr 2018
Posts: 30
Mein Auto: 2016 740i, 2014 M6
Goes in for service tomorrow. My iDrive screen resets probably 25 times a month. Sometimes 5 times a day. Just goes blank, then comes on and makes me take my eyes off the road to confirm I won't let it distract me (GRRRR) and works till the next time. Sometimes it remembers my phone, sometimes not. Always remembers my iPad. Sometimes it loses my other settings. Just so frustrating. If they can't fix it I will get rid of it which is a shame. I love everything else about the car.
Reply With Quote
  #13  
Old 07-18-2019, 11:58 AM
M6 in Bama M6 in Bama is offline
Registered User
Location: South Alabama
 
Join Date: Apr 2018
Posts: 30
Mein Auto: 2016 740i, 2014 M6
Well so far so good. They said the iDrive system had a fault so they reset that and installed an update. So far, no resets, no black screens and it hasn't lost connection with my Note 9.
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series & 8 Series > 7 Series - G11 / G12 (2016 - current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:21 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.