No beep - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 01-29-2020, 11:30 AM
dmaisenh dmaisenh is offline
Officially Welcomed to the 'Fest
Location: Baltimore, MD
 
Join Date: Oct 2005
Posts: 165
Mein Auto: 99 528iAT
No beep

Suddenly the car no longer chirps when I lock and unlock it.
Any ideas?
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 01-29-2020, 12:44 PM
edjack edjack is offline
Officially Welcomed to the 'Fest
Location: San Jose, CA
 
Join Date: May 2007
Posts: 15,166
Mein Auto: '97 540i 6 speed
Does the siren work? Lock the car and open the bonnet.
__________________


Ed in San Jose '97 540i 6 speed aspensilber over aubergine leather. Build date 3/97. Golden Gate Chapter BMW CCA Nr 62319.
Reply With Quote
  #3  
Old 01-29-2020, 03:09 PM
Nfs021's Avatar
Nfs021 Nfs021 is offline
What Speed Limit?
Location: Portland, OR
 
Join Date: Nov 2012
Posts: 1,818
Mein Auto: 2003 M5, 2002 540i RIP :(
I'm in the same boat. My GM module on my M5 crapped out few weeks back. Replaced it with the exact same part from another car. And since then my alarm won't chirp either. Lights just blink when lock/unlock and nothing else. When I open the trunk with the doors locked the lights flash as if the alarm has gone off but there's no sound. Also I noticed the clown nose light on the the rearview mirror doesn't blink at all when I lock the car.

Of course I have loads of other electrical issues that could be affecting it. But let me know what you find.

Sent from Uranus with Love

Last edited by Nfs021; 01-29-2020 at 03:10 PM.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 01-30-2020, 12:48 AM
mjalloul11's Avatar
mjalloul11 mjalloul11 is offline
BMW forever
Location: Lebanon
 
Join Date: Apr 2012
Posts: 1,177
Mein Auto: 1996 528i 1999 MB C240
The sieren could have gone bad,or even the GM module could have forgotten the code,you could program it ON Off.

Sent from my SAMSUNG-SM-G935A using Tapatalk
__________________
Working on my car is a pastime
Reply With Quote
  #5  
Old 02-07-2020, 05:36 PM
scottjoh scottjoh is offline
Officially Welcomed to the 'Fest
Location: Los Angeles, CA
 
Join Date: May 2006
Posts: 701
Mein Auto: 1999 323i
No beep

Quote:
Originally Posted by dmaisenh View Post
Suddenly the car no longer chirps when I lock and unlock it.

Any ideas?


It is probably a bad sensor. Itís like when you arm the alarm with the trunk open. The car locks, but, doesnít chirp until you close the trunk. One of the sensor is not set. Most likely itís the hood/bonnet sensor.

Nfs021 has a different problem since he has a big unknown with that used general module thatís coded to a different car.

Last edited by scottjoh; 02-07-2020 at 05:37 PM.
Reply With Quote
  #6  
Old 02-07-2020, 06:58 PM
dmaisenh dmaisenh is offline
Officially Welcomed to the 'Fest
Location: Baltimore, MD
 
Join Date: Oct 2005
Posts: 165
Mein Auto: 99 528iAT
Quote:
Originally Posted by scottjoh View Post
It is probably a bad sensor. Itís like when you arm the alarm with the trunk open. The car locks, but, doesnít chirp until you close the trunk. One of the sensor is not set. Most likely itís the hood/bonnet sensor.

Nfs021 has a different problem since he has a big unknown with that used general module thatís coded to a different car.
The hood switch has been unplugged for awhile and it worked with it disconnected.
Reply With Quote
  #7  
Old 02-07-2020, 07:14 PM
Nfs021's Avatar
Nfs021 Nfs021 is offline
What Speed Limit?
Location: Portland, OR
 
Join Date: Nov 2012
Posts: 1,818
Mein Auto: 2003 M5, 2002 540i RIP :(
Quote:
Originally Posted by scottjoh View Post
It is probably a bad sensor. Itís like when you arm the alarm with the trunk open. The car locks, but, doesnít chirp until you close the trunk. One of the sensor is not set. Most likely itís the hood/bonnet sensor.

Nfs021 has a different problem since he has a big unknown with that used general module thatís coded to a different car.
I think that maybe the alarm could've been coded off with the used module. I also still have issues with the central locking fuse blowing. But that's all been put on the back burner for now while I get caught up on maintenance stuff with the car. I exhausted too much time on that issue with no luck and will deal with it later on.

Sent from Uranus with Love
Reply With Quote
  #8  
Old 02-08-2020, 03:53 AM
Burning2nd's Avatar
Burning2nd Burning2nd is online now
Under the lift arms
Location: Under the lift Arm
 
Join Date: Aug 2010
Posts: 12,657
Mein Auto: e39, e83, e60
make sure all your doors and trunk and hood are closed (one of the switches is open)

that open makes it so it doesn't beeb to let you know that you have a door that is not closed

iD start with disconnecting the hood switch if you are one of the legend's that still has that connected

you can view the live data on the central locking system also to let you know what circuit is reporting open
__________________
Specializing In Breaking Things Professionally


15486372<-----
Reply With Quote
  #9  
Old 02-08-2020, 11:09 AM
QSilver7's Avatar
QSilver7 QSilver7 is offline
Officially Welcomed to the 'Fest
Location: Northeast Indiana
 
Join Date: Aug 2008
Posts: 11,804
Mein Auto: 2006 X5 4.4/2013 650ix GC
The clown nose (below the interior rear view mirror) can give some info as to what "some" of the problems are. It is the status LED for the DWA (anti-theft alarm siren system). It should illuminate and flash continuously (slowly, too) when the vehicle is locked using the remote fob or manually locking the car using the driver's exterior door lock cylinder. If the light isn't coming on, then the DWA system hasn't been initiated.

If the clown nose does illuminate and flash...then the way that it flashes indicates what is going on with the system:


If the alarm siren isn't making an audible sound when locking/unlocking the car (which can be coded off/on with software/hardware)....then you can also double check that the alarm siren still works by activating the PANIC button on the remote fob. I turned off the audible alert on my 97 e38 because I hated the sound of the "wolf whistle"...and if a GM was installed from another BMW...this could be the reason no audible lock/unlock alerts are heard. See instructions from the owners manual below on how to initiate the PANIC alarm to see if the siren can actually make noise. Do note that the system needs to be ARMED for the alarm to sound off:


If you can't get the alarm siren to make an audible sound...then perhaps its internal battery is dead...which could create many of the situations mentioned above:


Attached Thumbnails
Click image for larger version

Name:	DWA%20Red%20Anti%20theft%20LED%20Status%20Flash.jpg
Views:	81
Size:	48.6 KB
ID:	881237   Click image for larger version

Name:	Panic%20Mode%20Old%20Style%20Key.jpg
Views:	81
Size:	38.1 KB
ID:	881243   Click image for larger version

Name:	DWA%20Alarm%20Siren%20Location%20and%20Description.jpg
Views:	82
Size:	57.1 KB
ID:	881245  
__________________
Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 2013 F06 650ix Gran Coupe` (Black Sapphire) 1/13 mfg date
(SOLD)
97 740iL (Arctic Silver) <<~>> 99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

https://www.bimmerforums.com/forum/attachment.php?attachmentid=637911&d=1538398374&thumb=1&stc=1

Last edited by QSilver7; 02-08-2020 at 11:12 AM.
Reply With Quote
  #10  
Old 02-08-2020, 01:16 PM
Nfs021's Avatar
Nfs021 Nfs021 is offline
What Speed Limit?
Location: Portland, OR
 
Join Date: Nov 2012
Posts: 1,818
Mein Auto: 2003 M5, 2002 540i RIP :(
Quote:
Originally Posted by QSilver7 View Post
The clown nose (below the interior rear view mirror) can give some info as to what "some" of the problems are. It is the status LED for the DWA (anti-theft alarm siren system). It should illuminate and flash continuously (slowly, too) when the vehicle is locked using the remote fob or manually locking the car using the driver's exterior door lock cylinder. If the light isn't coming on, then the DWA system hasn't been initiated.

If the clown nose does illuminate and flash...then the way that it flashes indicates what is going on with the system:


If the alarm siren isn't making an audible sound when locking/unlocking the car (which can be coded off/on with software/hardware)....then you can also double check that the alarm siren still works by activating the PANIC button on the remote fob. I turned off the audible alert on my 97 e38 because I hated the sound of the "wolf whistle"...and if a GM was installed from another BMW...this could be the reason no audible lock/unlock alerts are heard. See instructions from the owners manual below on how to initiate the PANIC alarm to see if the siren can actually make noise. Do note that the system needs to be ARMED for the alarm to sound off:


If you can't get the alarm siren to make an audible sound...then perhaps its internal battery is dead...which could create many of the situations mentioned above:


I've got no flashing light from the clown nose at all, no audible sound when lock/unlocking. And I can't test the panic alarm because my fob buttons don't work when I press them and I can't rsync them to the used module. The fob and it's battery work. I had the BMW dealer test it awhile back when I had them check the airbag light. They couldn't get it to program either, but that was when the old gm was still working.

The gm from the other car, could've been programmed so the alarm doesn't chirp like you have stated. And like I said I have so much other electrical crap to sort out and just don't want to deal with it anymore at this time. My brain is fried from looking at all the damn wiring diagrams online and reading countless threads on the issue. I'll get back to it when I feel like it lol.

Sent from Uranus with Love
Reply With Quote
  #11  
Old 02-09-2020, 04:16 PM
dmaisenh dmaisenh is offline
Officially Welcomed to the 'Fest
Location: Baltimore, MD
 
Join Date: Oct 2005
Posts: 165
Mein Auto: 99 528iAT
Here's what I have so far.
When the alarm is set the clown nose flashes fast for about 10 sec then slow.
When I press the panic button the light flash like the alarm is going off but there is no sound.
This looks to me like siren failure but the question is why would that cause the 10 second fast flash?

Update, I just checked the 5A fuse number 48 and it is good.

Last edited by dmaisenh; 02-09-2020 at 04:32 PM.
Reply With Quote
  #12  
Old 02-09-2020, 05:29 PM
mattmar1's Avatar
mattmar1 mattmar1 is offline
Wingnut
Location: Louisiana
 
Join Date: Dec 2014
Posts: 3,437
Mein Auto: 1999 5281 5 sp msport
the initial "fast flash" when enabling the alarm system is normal for a system that has open sensors at the time its set...hood switch, headliner sensor removed etc.
__________________
99 528i 5sp sport


be alert...the world needs more lerts
Reply With Quote
  #13  
Old 02-09-2020, 06:13 PM
dmaisenh dmaisenh is offline
Officially Welcomed to the 'Fest
Location: Baltimore, MD
 
Join Date: Oct 2005
Posts: 165
Mein Auto: 99 528iAT
Ok so it has been doing the fast blink and I just didn't notice it and it is unrelated to the siren crapping out.

Last edited by dmaisenh; 02-09-2020 at 07:24 PM.
Reply With Quote
  #14  
Old 02-09-2020, 07:22 PM
dmaisenh dmaisenh is offline
Officially Welcomed to the 'Fest
Location: Baltimore, MD
 
Join Date: Oct 2005
Posts: 165
Mein Auto: 99 528iAT
Does anyone know the difference between the sedan siren and the touring siren? They have different part numbers.
The sedan one is shared with E46s X3s and X5s as well as E38s. Meaning that there are multiple sources for ones out of newer cars.

The touring one is shared with the E36 and E36 Z3 as well as the 8 series.

My local automotive recycling center doesn't have any tourings.
Reply With Quote
  #15  
Old 02-10-2020, 08:41 AM
528iAut 528iAut is offline
Officially Welcomed to the 'Fest
Location: Moraira, Spain
 
Join Date: May 2016
Posts: 2,298
Mein Auto: 1996 528i
Just search on the part number and try a used one.
__________________
E39 528i Steptronic 1996, Comfort seats, Rear sunshade, Focal amplifier and front speakers, Oxford Green.
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:11 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.