Battery warning light - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)

E85 / E86 Z4 (2003-2008)
E85 Z4 Roadster, E86 Z4 Coupe, E85 Z4 M Roadster, and E86 Z4 M Coupe talk with our BMW gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 03-29-2017, 09:34 AM
WI03Z4 WI03Z4 is offline
Registered User
Location: Wisconsin
 
Join Date: Mar 2017
Posts: 43
Mein Auto: 2003 BMW Z4 2.5i
Battery warning light

I have an 03 Z4 2.5i and the battery warning light comes on and stays on. I just replaced the alternator and belt but no change. Has anyone else experienced this?

Sent from my SM-N910V using Bimmerfest mobile app
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 03-29-2017, 09:54 AM
acoste's Avatar
acoste acoste is offline
Officially Welcomed to the 'Fest
Location: California
 
Join Date: Nov 2011
Posts: 5,330
Mein Auto: 2010 550i MT
Get a multimeter and measure the battery voltage when the engine is running.
__________________
__________________
2010 BMW 550i MT
2003 BMW 325i @216k and counting
1998 BMW 528i MT @ 231k //sold
1997 Saab 9000 //sold
Reply With Quote
  #3  
Old 03-29-2017, 01:19 PM
2.5i_z4 2.5i_z4 is offline
Officially Welcomed to the 'Fest
Location: Los Angeles
 
Join Date: Jan 2017
Posts: 151
Mein Auto: 2003 BMW Z4 2.5i
5 bucks for a multi meter at harbor freight. Or go to your local auto parts store they'll probably check it for free

Sent from my LG-D851 using Bimmerfest mobile app
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 03-29-2017, 01:49 PM
WI03Z4 WI03Z4 is offline
Registered User
Location: Wisconsin
 
Join Date: Mar 2017
Posts: 43
Mein Auto: 2003 BMW Z4 2.5i
Thanks

Sent from my SM-N910V using Bimmerfest mobile app
Reply With Quote
  #5  
Old 09-11-2019, 04:05 PM
Stolizino Stolizino is offline
Registered User
Location: SAT/SEA
 
Join Date: Feb 2013
Posts: 15
Mein Auto: 2006 M Roadster
After years of trouble-free ownership, my battery warning light sometimes flickers after starting the engine, most of the time turning off but occasionally it will remain illuminated until I've driven about half a block. I have no other indication of anything amiss. It starts quickly and everything works. It has an OEM battery installed and programmed by a factory authorized independent BMW garage. What am I missing? 27,300 miles.
Reply With Quote
  #6  
Old 09-12-2019, 03:43 PM
golferguy golferguy is offline
Registered User
Location: Fort Worth, TX
 
Join Date: Feb 2012
Posts: 58
Mein Auto: 2008 E85 Z4 M
How old is your battery? If it's more than 3 years old, that's the immediate suspect. Here in Texas the heat can kill a battery in less than 3 years.

Quote:
Originally Posted by Stolizino View Post
After years of trouble-free ownership, my battery warning light sometimes flickers after starting the engine, most of the time turning off but occasionally it will remain illuminated until I've driven about half a block. I have no other indication of anything amiss. It starts quickly and everything works. It has an OEM battery installed and programmed by a factory authorized independent BMW garage. What am I missing? 27,300 miles.
__________________
2008 Black Sapphire Metallic/Imola Red ///M Roadster 6sp Manual
2012 Vermilion Red/Oyster 128i Convertible Auto
Reply With Quote
  #7  
Old 09-12-2019, 08:19 PM
Clearancediver's Avatar
Clearancediver Clearancediver is offline
Officially Welcomed to the 'Fest
Location: Victoria BC, Canada
 
Join Date: Oct 2012
Posts: 631
Mein Auto: 2004 Z4, 2009 Nomad mc
What he says....

However battery doesn’t need to be programmed to the car. If your independent charged you for that I’d rethink using him again.


Sent from my iPhone using Bimmerfest mobile app
Reply With Quote
  #8  
Old 09-13-2019, 07:45 AM
Rob2m Rob2m is offline
Registered User
Location: uk
 
Join Date: Dec 2017
Posts: 42
Mein Auto: Z4
Quote:
Originally Posted by Stolizino View Post
After years of trouble-free ownership, my battery warning light sometimes flickers after starting the engine, most of the time turning off but occasionally it will remain illuminated until I've driven about half a block. I have no other indication of anything amiss. It starts quickly and everything works. It has an OEM battery installed and programmed by a factory authorized independent BMW garage. What am I missing? 27,300 miles.

Historically with cars a loose alternator belt is the cause of this, I have no direct experience on a Z4 though.
__________________
"Today’s ride will remind me forever how good it is to be a motorcyclist, how good it is to be alive and how much we need to live life, rather than watch it pass us by." Green VFR.
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:46 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.