2001 X5 - speedometer and odometer stopped working - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 09-18-2019, 06:39 AM
BMW_John7313 BMW_John7313 is offline
Registered User
 
Join Date: Aug 2018
Posts: 25
Mein Auto:
2001 X5 - speedometer and odometer stopped working

Someone told me that it was the rear left speed sensor. I replaced it and nothing changed. I am also having trouble getting my scanner to communicate with the port under the hood. Any help would be amazing! Click image for larger version

Name:	IMG_0752.jpg
Views:	13
Size:	113.7 KB
ID:	865047Click image for larger version

Name:	IMG_0753.jpg
Views:	14
Size:	132.5 KB
ID:	865049


Sent from my iPhone using Bimmerfest mobile app
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 09-18-2019, 07:19 AM
BMW_John7313 BMW_John7313 is offline
Registered User
 
Join Date: Aug 2018
Posts: 25
Mein Auto:
Click image for larger version

Name:	IMG_0754.jpg
Views:	12
Size:	143.7 KB
ID:	865051


Sent from my iPhone using Bimmerfest mobile app
Reply With Quote
  #3  
Old 09-18-2019, 11:08 PM
JohnyX5 JohnyX5 is offline
Registered User
 
Join Date: Jan 2019
Posts: 5
Mein Auto:
In my case the Meg speedometer and cruise control went bad plus a few others. It was diagnosed that the DSC module was bad. Replacement is $1,000 but I found a company that will repair it and guarantee it for life. Cost is ridiculously cheap at less than $100. I will post it here when I find the information.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 09-19-2019, 01:32 PM
BMW_John7313 BMW_John7313 is offline
Registered User
 
Join Date: Aug 2018
Posts: 25
Mein Auto:
I had one rebuilt on an E39 for that price a few years ago. But that was just the lights on, not the speedometer and odometer not working or


Sent from my iPhone using Bimmerfest
Reply With Quote
  #5  
Old 09-20-2019, 06:07 AM
JohnyX5 JohnyX5 is offline
Registered User
 
Join Date: Jan 2019
Posts: 5
Mein Auto:
I was under the impression that they rebuild the entire unit as far as physical problems like bad solder joints or capacitors that type of thing. The software portion was not limited too what you tell them is wrong. Usually the physical repair of the unit would correct all problems even though you don't mention. I'll find out soon because I have to send another unit in to be repaired.
Reply With Quote
  #6  
Old 09-20-2019, 06:40 AM
BMW_John7313 BMW_John7313 is offline
Registered User
 
Join Date: Aug 2018
Posts: 25
Mein Auto:
When my E39 has the abs light on, their service completely fixed it. It didnít have problems like this though. On top of that, my diagnostic port under the hood has problems.


Sent from my iPhone using Bimmerfest
Reply With Quote
  #7  
Old 09-20-2019, 07:36 AM
Rickster X5 Rickster X5 is offline
Registered User
Location: Florida
 
Join Date: Aug 2017
Posts: 69
Mein Auto: X5
Hi John,

Not being a smart a$$.... mine was sitting on zero about a month ago while I was driving on the highway... so I banged the top of my dash and it kicked up to 80. Been fine ever since. If it happens again I will buy a used cluster from a salvage yard. Cheaper than a repair, 5 minute job.

Good luck.

Rick
__________________
2003 X5 3.0
Reply With Quote
  #8  
Old 09-20-2019, 08:14 AM
BMW_John7313 BMW_John7313 is offline
Registered User
 
Join Date: Aug 2018
Posts: 25
Mein Auto:
Hmm Iíll give that a try today


Sent from my iPhone using Bimmerfest
Reply With Quote
  #9  
Old 09-20-2019, 10:41 AM
JohnyX5 JohnyX5 is offline
Registered User
 
Join Date: Jan 2019
Posts: 5
Mein Auto:
My diagnostic port is trash as well..... I'll have to try that banging fix. I take a while to find the exact spot. You got skills brother.... A gift from the BMW God
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:17 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.