HELP E93 top stuck in trunk only used 1 time - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series & 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 05-22-2019, 01:45 PM
cwc5150 cwc5150 is offline
Registered User
Location: Sacramento
 
Join Date: May 2019
Posts: 15
Mein Auto: 2011 E93 335i
HELP E93 top stuck in trunk only used 1 time

hello this is my first time posting on any forum (please be kind)
i just got a 2011 BMW E93 335i on my way home from just getting the loan from my credit union so i haven't even made payment yet. I put the top down all seemed fine went to go home. when i got home i tried putting it back up. windows went down but rear module didn't move, windows and trunk wouldn't move and red light on convertible switch would blink, dash displayed red convertible top symbol that says top wasn't finished. when I hit the switch the other direction it allows the windows and trunk to open and the blinking light and dash display both turn off. if the turn the engine off i can hear a lock or something move but cant see anything move. I've changed both salmon relays with no change. fluid is above the + symbol. I own a Bimmergeeks cable and have both of there apps. I also bought a dedicated laptop with all the BMW software like ISTA+ I'm not sure I fully understand the programs but think I got the most of it. I ran some test with the hall sensors and switches. but nothing stood out. no errors codes other than footwell module

Last edited by cwc5150; 05-22-2019 at 05:23 PM.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 05-22-2019, 04:50 PM
Glenpointe Glenpointe is offline
Registered User
Location: Michigan
 
Join Date: Nov 2012
Posts: 60
Mein Auto: M3 and Saturn VUE
I have exactly the same problem. I checked all the fuses and replaced the salmon relays, but no changes. I believe the footwell module (lighting control module) causes the top not to operate properly. The hardtop module gets inputs from other modules before it lower/raise the top. Unplug the footwell module for 5 minutes and plug it back, it may reset the module and allows the top to operate. Try it and let us know.
Reply With Quote
  #3  
Old 05-22-2019, 06:58 PM
cwc5150 cwc5150 is offline
Registered User
Location: Sacramento
 
Join Date: May 2019
Posts: 15
Mein Auto: 2011 E93 335i
Quote:
Originally Posted by cwc5150 View Post
hello this is my first time posting on any forum (please be kind)
i just got a 2011 BMW E93 335i on my way home from just getting the loan from my credit union so i haven't even made payment yet. I put the top down all seemed fine went to go home. when i got home i tried putting it back up. windows went down but rear module didn't move, windows and trunk wouldn't move and red light on convertible switch would blink, dash displayed red convertible top symbol that says top wasn't finished. when I hit the switch the other direction it allows the windows and trunk to open and the blinking light and dash display both turn off. if the turn the engine off i can hear a lock or something move but cant see anything move. I've changed both salmon relays with no change. fluid is above the + symbol. I own a Bimmergeeks cable and have both of there apps. I also bought a dedicated laptop with all the BMW software like ISTA+ I'm not sure I fully understand the programs but think I got the most of it. I ran some test with the hall sensors and switches. but nothing stood out. no errors codes other than footwell module
Ok I unplugged all 3 wire harness for about 40 minutes then plugged back in but no changes
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 05-22-2019, 07:13 PM
Glenpointe Glenpointe is offline
Registered User
Location: Michigan
 
Join Date: Nov 2012
Posts: 60
Mein Auto: M3 and Saturn VUE
Open the glove box. Twist of two screws and remove the back cover you will see the fuse box. Check the fuses to see if they are OK. By the way, when you try to raise the top, did the trunk lid open up?
Reply With Quote
  #5  
Old 05-22-2019, 07:29 PM
cwc5150 cwc5150 is offline
Registered User
Location: Sacramento
 
Join Date: May 2019
Posts: 15
Mein Auto: 2011 E93 335i
i already checked every fuse a while back when it first started. no it dont move but i do hear i think the locking latchs unlocking but thats it. i think it could use some lube but i dont see a way to access the locking latchs without the rear module being open
Reply With Quote
  #6  
Old 05-23-2019, 06:24 AM
Glenpointe Glenpointe is offline
Registered User
Location: Michigan
 
Join Date: Nov 2012
Posts: 60
Mein Auto: M3 and Saturn VUE
My 2011 335is with 40k miles, but has a lot of issues. It's my third BMW and will be my last.
Reply With Quote
  #7  
Old 05-24-2019, 06:18 AM
cwc5150 cwc5150 is offline
Registered User
Location: Sacramento
 
Join Date: May 2019
Posts: 15
Mein Auto: 2011 E93 335i
I understand I bought this car and only got to use the top one time down with less than two tanks of gas and already have other problems as well
Reply With Quote
  #8  
Old 05-29-2019, 03:34 PM
Glenpointe Glenpointe is offline
Registered User
Location: Michigan
 
Join Date: Nov 2012
Posts: 60
Mein Auto: M3 and Saturn VUE
I replaced the footwell module, the top operates normal now.
Reply With Quote
  #9  
Old 05-29-2019, 04:27 PM
cwc5150 cwc5150 is offline
Registered User
Location: Sacramento
 
Join Date: May 2019
Posts: 15
Mein Auto: 2011 E93 335i
Did your windows go down before you changed your footwell module
Reply With Quote
  #10  
Old 05-29-2019, 04:29 PM
cwc5150 cwc5150 is offline
Registered User
Location: Sacramento
 
Join Date: May 2019
Posts: 15
Mein Auto: 2011 E93 335i
Also did get a new footwell module and reprogram it or just get the old one updated
Reply With Quote
  #11  
Old 05-29-2019, 04:45 PM
Glenpointe Glenpointe is offline
Registered User
Location: Michigan
 
Join Date: Nov 2012
Posts: 60
Mein Auto: M3 and Saturn VUE
my windows stopped working after the footwell fried. It's under warranty for 10 years and 156K miles. I had it replaced for free.
Reply With Quote
  #12  
Old 05-29-2019, 07:36 PM
cwc5150 cwc5150 is offline
Registered User
Location: Sacramento
 
Join Date: May 2019
Posts: 15
Mein Auto: 2011 E93 335i
Oh ok that's great news good for you glad to hear it fixed your issues. I wonder if mine is also bad because all my windows work but when I use ISTA + is reads 1 or 2 in the wrong position if I play with them a little the show the correct position but still dosen't fix my RHT
Reply With Quote
  #13  
Old 06-13-2019, 09:01 PM
cwc5150 cwc5150 is offline
Registered User
Location: Sacramento
 
Join Date: May 2019
Posts: 15
Mein Auto: 2011 E93 335i
Got foot well module replaced with no cost for me dealership did it with no appointments with next day results. But my hard top still doesn't work
Reply With Quote
  #14  
Old 06-15-2019, 05:13 AM
roadkillrob roadkillrob is offline
Officially Welcomed to the 'Fest
Location: Boston
 
Join Date: Aug 2006
Posts: 2,711
Mein Auto: 325CIC, 335CIC
Maybe this document will help you - also have you tested the salmon relays, they are a common failure point - they are by the pump, a bit hard to get to I would assume with the top stowed but cause the pump not to run. Attached is the how it all works document and the sequence of things etc.
Attached Files
File Type: pdf 03_E93 Retractable Hardtop.pdf (1.21 MB, 46 views)
__________________
2008 335i E93 Montego/Saddle/Grey Poplar
2014 Mercedes C63 AMG Edition 507 Polar White
2019 X5 M-Sport Phytonic Blue/Ivory Extended Merino Leather
Reply With Quote
  #15  
Old 06-15-2019, 09:58 AM
cwc5150 cwc5150 is offline
Registered User
Location: Sacramento
 
Join Date: May 2019
Posts: 15
Mein Auto: 2011 E93 335i
I cant retrieve the link its says its broken. I actually bought 2 new salmon Relays first with no changes. Not sure where to check next. Was thinking about paying the dealership to manually close it. With low hopes it could correct it self. If not at least I would have better access to most of the components and I'll try lubrication.

Last edited by cwc5150; 06-15-2019 at 09:59 AM.
Reply With Quote
  #16  
Old 06-15-2019, 05:16 PM
roadkillrob roadkillrob is offline
Officially Welcomed to the 'Fest
Location: Boston
 
Join Date: Aug 2006
Posts: 2,711
Mein Auto: 325CIC, 335CIC
It works for me to download the file, doubt it is lubrication if it doesn't move at all, you can try unplugging the top module it is behind the passenger side back seat side panel area.
__________________
2008 335i E93 Montego/Saddle/Grey Poplar
2014 Mercedes C63 AMG Edition 507 Polar White
2019 X5 M-Sport Phytonic Blue/Ivory Extended Merino Leather
Reply With Quote
  #17  
Old 06-16-2019, 08:27 AM
cwc5150 cwc5150 is offline
Registered User
Location: Sacramento
 
Join Date: May 2019
Posts: 15
Mein Auto: 2011 E93 335i
I guess something is wrong with my phone I've tried 2 different browsers with no luck I might already have the file is it the E93 workbook? I was able to get to 1 of the wiring harness of the top module I unplugged it for 15 min but with no changes how do i get access to the module completely?
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20190616-082404_Hancom Office Editor_1560698739144.jpg
Views:	28
Size:	311.1 KB
ID:	854933  
Reply With Quote
  #18  
Old 06-16-2019, 07:08 PM
roadkillrob roadkillrob is offline
Officially Welcomed to the 'Fest
Location: Boston
 
Join Date: Aug 2006
Posts: 2,711
Mein Auto: 325CIC, 335CIC
Ya that looks the same. To get to the top module you have to remove the corner part of the seat back that transitions into the side panels. Best instructions are to lookup the smart top module install for the e93 and that has step by step to get to the module. It may be one of the latches for when it is stowed is stuck, that attachment gives everything involved in the process check each sensor and latch.
__________________
2008 335i E93 Montego/Saddle/Grey Poplar
2014 Mercedes C63 AMG Edition 507 Polar White
2019 X5 M-Sport Phytonic Blue/Ivory Extended Merino Leather
Reply With Quote
  #19  
Old 06-17-2019, 07:37 PM
cwc5150 cwc5150 is offline
Registered User
Location: Sacramento
 
Join Date: May 2019
Posts: 15
Mein Auto: 2011 E93 335i
I was able to verify that the the latchs were unlocking with my camera phone.but there was no changes And tried resetting the top module behind the back seat by unplugging them for over 30 minutes. But had no changes I do have a dedicated laptop with ISTA and other BMW software but not quite sure where to proceed from here
Reply With Quote
  #20  
Old 06-18-2019, 09:38 AM
Zeichen311's Avatar
Zeichen311 Zeichen311 is online now
Lost but making good time
Location: Here, there, or in transit
 
Join Date: Mar 2011
Posts: 5,049
Mein Auto: '11 335xi 4dr; '03 330Ci
Sometimes the smart move is to spend a little to save a lot. Consider taking the car to a dealership to ask them to diagnose the problem but not make repairs without authorization. For the cost of the diagnostic charge (typically, an hour of labor--most won't go beyond that without further authorization) you will learn what is wrong and, of equal importance, whether you have the tools and/or skills to fix it yourself.
__________________
2011 335xi Individual 6MT - Azurite Black Metallic / Oyster & Black / Anthracite Maple + all the good stuff
2003 330Ci Sport 5MT - Black Sapphire Metallic / Natural Brown / Myrtle + the important stuff (+ go-fast stuff)

BMW CCA
Reply With Quote
  #21  
Old 06-18-2019, 09:42 AM
cwc5150 cwc5150 is offline
Registered User
Location: Sacramento
 
Join Date: May 2019
Posts: 15
Mein Auto: 2011 E93 335i
I figured that as much thank you for your advice I was thinking about having them diagnose it and then go from there or have them manually put the roof back up and hopefully it could correct itself if not then least the top would be up and I would have access to the sensors easier with hope of it being the same cost as diagnosis
Reply With Quote
  #22  
Old 06-21-2019, 09:26 PM
cwc5150 cwc5150 is offline
Registered User
Location: Sacramento
 
Join Date: May 2019
Posts: 15
Mein Auto: 2011 E93 335i
Okay after going over all the BMW Workshop RHT. instruction manuals and everything else I can find I got a very good understanding how the system works now and I went through it very well with my ISTA plus dedicated laptop through diagnosis scans and on my checking of the hydraulic valves for valve one for the rear module it only activates in the down position never in the lifting position therefore I believe there might be something wrong with that still annoyed valve or the wiring there
Attached Thumbnails
Click image for larger version

Name:	1561177464450856998464594918947_1561177497915.jpg
Views:	15
Size:	59.2 KB
ID:	855587   Click image for larger version

Name:	15611775178371489571142076491091_1561177541050.jpg
Views:	13
Size:	63.0 KB
ID:	855589  
Reply With Quote
  #23  
Old 06-25-2019, 06:52 PM
cwc5150 cwc5150 is offline
Registered User
Location: Sacramento
 
Join Date: May 2019
Posts: 15
Mein Auto: 2011 E93 335i
Well I took it to the stealership and ask for them to diagnose the roof issue the had it since 7am at about 3pm was told some fuses and relays were bad and the hydraulic motor was seized. They put voltage to it directly with no response (so I'm sure the first part was B.S. ) said the pump needs to be replaced out door cost was about $4,874. So I declined. Went to pickup about 5pm (they got me uber back and forth from work. ) upon pick up the informed me they put the top back up which was cool because that was what I wanted. So for the minimum fee for anything was 1 hr =$195. So I'm thinking of buying a rebuilt upgraded pump for $520 with shipping that's has a 3 year warranty.

Last edited by cwc5150; 06-25-2019 at 11:17 PM.
Reply With Quote
  #24  
Old 08-17-2019, 08:08 PM
cwc5150 cwc5150 is offline
Registered User
Location: Sacramento
 
Join Date: May 2019
Posts: 15
Mein Auto: 2011 E93 335i
Okay after getting my pump rebuilt from Top hydraulics it was still not working at all it would fold up sometimes but not open the rear module but would not unfold ended up buying a used pump from Ebay that had been known working now it works flawlessly didn't need to bleed out or calibrate anything like the stealership led to believe
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series & 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:10 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.