E-39 Dash trunk open indicator light - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 02-10-2009, 11:35 AM
regeztoy regeztoy is offline
Registered User
Location: south carolina
 
Join Date: Oct 2008
Posts: 6
Mein Auto: 528I
E-39 Dash trunk open indicator light

Hello All,
I've recently noticed that my dashboard trunk open indicator light is staying on even though the trunk lid is closed and latched. I've tried several fixes, replaced actuator, tried taping over the latching bar on the body side of the trunk latching mechanism tried opening and closing the trunk multiple times manually and with the inside button by the driver footwell. I even opened up the old actuator to see if I could find the sensor, not sure what the sensor looks like. ( Did notice the grey drive shaft has a beige pulley of some sorts over it. Is this supposed to be one continuous piece or seperate pieces. Any other suggestions out there any pictures would be helpful. That darned light is making me crazy!!!!

Last edited by regeztoy; 02-10-2009 at 11:42 AM.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 02-10-2009, 01:21 PM
jglover jglover is offline
jedi knight
Location: Fairfield, California
 
Join Date: Sep 2005
Posts: 449
Mein Auto: 2000 528i
Dude, that light made me crazy for like a year until one of the members told me to look for a broke wire in the trunk loop( the one that goes from the car to the trunk lid) I had 4 broken wires! Light Gone!

Last edited by jglover; 02-10-2009 at 01:24 PM.
Reply With Quote
  #3  
Old 05-24-2009, 08:56 AM
ersmith ersmith is offline
 
Join Date: May 2009
Posts: 1
Mein Auto:
Broken wires trunk indicator light

Had 2001 E46 (325Ci) with following problems today:
Truck would not open by key remote, or interior push button, but would open with key
Trunk indicator light on (and won't go off) in the instrument panel.
Trunk light inoperable
Conv top would not go down

Searched this community for 30 minutes looking for clues. Narrowed to trunk lock actuator and faulty wiring. Checked wiring first, as it seemed the easiest. The problem was 3 wires broken in the bundle running from the body to the trunk lid (right side of trunk in a rubber boot) and 3 more ruptured and close. Spliced 6 wires and everything aok. Check this FIRST if your trunk open indicator light is on and won't go off!

Thanks JGlover for posting numerous responses to various posts for help on this issue as the cost to fix was $8, and saved numerous hours of hunting.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 09-10-2009, 03:20 PM
bluebee's Avatar
bluebee bluebee is offline
Seek to understand,^Value
Location: San Jose, California
 
Join Date: Mar 2008
Posts: 25,199
Mein Auto: 02 BMW 525i M54 auto 130K
Quote:
Originally Posted by ersmith View Post
The problem was 3 wires broken in the bundle running from the body to the trunk lid (right side of trunk in a rubber boot) and 3 more ruptured and close. Spliced 6 wires and everything aok. Check this FIRST if your trunk open indicator light is on and won't go off!
I wish I had known this six months ago!

We should compile a list of all the things that can be affected by faulty trunk wiring.

a) Trunk indicator
b) CHECK LICPLATE LIGHT
c) Trunk constantly unlocks
etc.

Reply With Quote
  #5  
Old 09-30-2009, 02:36 PM
roxon98 roxon98 is offline
Registered User
Location: California
 
Join Date: Sep 2009
Posts: 2
Mein Auto: BMW 528i
Problems with trunk

I'm having problems with trunk for a few years (in the order of starting):

Lights in trunk - Not working most of time, may work once in a year
Trunk opening - Only physical key would work. No remote, no push btton (driver seat, and the bar on trunk lid)
CD changer - "CD Error"
Trunk open indicator on panel - ON even I'm very sure the trunk is closed

A friend of mine (an auto mechanic) took a loot at it before, but couldn't find any problem.

I just read this post, and then opened the cover on trunk lid to check wires. It seems everything is OK.

Any clue/suggestion to go beyond visual checking?
Reply With Quote
  #6  
Old 04-24-2010, 03:53 AM
antselK antselK is offline
Registered User
Location: Estonia
 
Join Date: Apr 2010
Posts: 1
Mein Auto: BMW 530d (2002)
Quote:
Originally Posted by roxon98 View Post
I'm having problems with trunk for a few years (in the order of starting):

Lights in trunk - Not working most of time, may work once in a year
Trunk opening - Only physical key would work. No remote, no push btton (driver seat, and the bar on trunk lid)
CD changer - "CD Error"
Trunk open indicator on panel - ON even I'm very sure the trunk is closed

A friend of mine (an auto mechanic) took a loot at it before, but couldn't find any problem.

I just read this post, and then opened the cover on trunk lid to check wires. It seems everything is OK.

Any clue/suggestion to go beyond visual checking?
I have only: Trunk open indicator on panel - ON even I'm very sure the trunk is closed
Have checked wires, but all seams to be OK.
All lights in trunk go off, when I close bootlid (checked from inside the car).
When trunk is open and I press the button (installed trunk edge, between trunk and car) with my finger the lights don't go off - strange :S
Reply With Quote
  #7  
Old 04-24-2010, 11:09 AM
delimeat52 delimeat52 is offline
Registered User
Location: Rheinland-Pfalz, Deutschland
 
Join Date: Apr 2010
Posts: 54
Mein Auto: '02 530i Touring
The most common fault is like the picture QSilver7 showed, frayed wires. Take your housings or tape off from around them and have a good look. A good sign of wiring problems is intermittent warnings of the trunk being open, the electronic lock only working occasionally, and lights saying they're out intermittently but changing the bulb does nothing.

If that's not the case, then it may be the locking mechanism itself. I had a couple shops look at it and and try fixing it, but after no success, brought it to the dealership. They said there's a common problem in there, but I can't remember what they said it was. (sorry) I had the dealership replace it because they said that was the problem, which didn't work either.

If you get that far and you don't fix it, then it may be the GM III, which is located under the glove box. Seems relays die in there among other problems. That's where I'm at. Something on the underside of the board in the GM III is fried black. I know I've got a touring, but same principal. Picked up a used one, which isn't working! Part number matches one that should be installed in mine, but no luck. Trying to figure out if the software is different for sedans vs. touring. Anyone know?
Reply With Quote
  #8  
Old 06-17-2010, 05:10 PM
lucifermkd lucifermkd is offline
Registered User
Location: Macedonia
 
Join Date: Jun 2010
Posts: 1
Mein Auto: E39 530d
Hello everyone. I have problem with my BMW E39 530.open trunk indicator always ON.when trunk is closed.all other lights work perfectly. please help

Last edited by lucifermkd; 06-17-2010 at 05:17 PM.
Reply With Quote
  #9  
Old 06-17-2010, 09:08 PM
ProRail ProRail is offline
"Clunker" *****
Location: Columbia MD
 
Join Date: May 2006
Posts: 4,684
Mein Auto: 1999 BMW 528A-220K-traded
Quote:
Originally Posted by lucifermkd View Post
Hello everyone. I have problem with my BMW E39 530.open trunk indicator always ON.when trunk is closed.all other lights work perfectly. please help
find a local shop that works on Bimmers. I take mine to Urban in Catonsville MD and they know everything there is to know about Bimmers. With their help I will probably keep my 1999 528 running forever.
Reply With Quote
  #10  
Old 07-13-2012, 03:52 PM
roxon98 roxon98 is offline
Registered User
Location: California
 
Join Date: Sep 2009
Posts: 2
Mein Auto: BMW 528i
Quote:
Originally Posted by roxon98 View Post
I'm having problems with trunk for a few years (in the order of starting):

Lights in trunk - Not working most of time, may work once in a year
Trunk opening - Only physical key would work. No remote, no push btton (driver seat, and the bar on trunk lid)
CD changer - "CD Error"
Trunk open indicator on panel - ON even I'm very sure the trunk is closed

A friend of mine (an auto mechanic) took a loot at it before, but couldn't find any problem.

I just read this post, and then opened the cover on trunk lid to check wires. It seems everything is OK.

Any clue/suggestion to go beyond visual checking?
It is the wire - I opened it further and found 8 broken wires! No wonder nothing works in the trunk.

It's a bit deep in the rubber tube. Still trying to figure out to reconnect them.
Reply With Quote
  #11  
Old 08-21-2013, 03:50 PM
SteveAreno SteveAreno is offline
Registered User
Location: Scottsdale, AZ
 
Join Date: Sep 2010
Posts: 48
Mein Auto: 2001 540i Sedan
Have same exact issue. Started with the trunk release button on the actual trunk itself going dead and then got the trunk open warning all the time and now i get a license plate light warning. Opened up the loom and heres what I found. Seems pretty straightforward just splicing in some extra wire to reconnect everything but there are 2 wires (4 ends) that are broken that are both light blue with a brown stripe. No idea why BMW would do something like that. Every wire is completely different coloring and striping and 2 identical wires lol. Thanks BMW, hopefully I wont blow up my car when I reattach the wires wrong.
Attached Thumbnails
Click image for larger version

Name:	IMG_3932.jpg
Views:	29262
Size:	109.4 KB
ID:	392861  
__________________
2001 540i-6
Reply With Quote
  #12  
Old 08-21-2013, 07:01 PM
bluebee's Avatar
bluebee bluebee is offline
Seek to understand,^Value
Location: San Jose, California
 
Join Date: Mar 2008
Posts: 25,199
Mein Auto: 02 BMW 525i M54 auto 130K
Quote:
Originally Posted by SteveAreno View Post
Have same exact issue.
Thanks for the beautiful picture. I've added it to the canonical thread, so others benefit from everyone else:
> E39 Electrical Problems Traced to Trunk Lid Harness Wire Chafing (DIY Diagnostic)

As for the color and purpose and gauge of the wires, see that canonical thread for all the details.

It would be especially helpful if you can look closely at your broken wires to hazard a guess in that canonical thread as to what BMW did wrong ... as I don't think we have a consensus as to what exactly is wrong in the first place, to make them all break in the same spot.
__________________
Please read the suggested threads and add value, either by pictures or by descriptions, so the next person stands on your shoulders.
See also: E39 Bestlinks & How to easily find what you need
Reply With Quote
  #13  
Old 08-21-2013, 09:22 PM
GreenTiger GreenTiger is offline
Officially Welcomed to the 'Fest
Location: SoCal
 
Join Date: Jun 2009
Posts: 903
Mein Auto: 7/98 NonVanos 540iA
Sorry off topic. But Steve, where did you get your side skirts from?
Reply With Quote
  #14  
Old 08-22-2013, 01:30 AM
HTK12 HTK12 is offline
Officially Welcomed to the 'Fest
Location: Finland
 
Join Date: Aug 2012
Posts: 1,230
Mein Auto: E39 540i
Quote:
Originally Posted by SteveAreno View Post
Have same exact issue. Started with the trunk release button on the actual trunk itself going dead and then got the trunk open warning all the time and now i get a license plate light warning. Opened up the loom and heres what I found. Seems pretty straightforward just splicing in some extra wire to reconnect everything but there are 2 wires (4 ends) that are broken that are both light blue with a brown stripe. No idea why BMW would do something like that. Every wire is completely different coloring and striping and 2 identical wires lol. Thanks BMW, hopefully I wont blow up my car when I reattach the wires wrong.
When I rebuilt the trunk lid harness I also had the two same colored wires. So it seems that WDS is wrong about the wire color codes. I just left those two to reconnect last and after conneting those I just checked everything work as it should. I made a DIY on rebuilding the trunk lid wiring harness, it can be found here.
Reply With Quote
  #15  
Old 08-22-2013, 03:53 AM
bluebee's Avatar
bluebee bluebee is offline
Seek to understand,^Value
Location: San Jose, California
 
Join Date: Mar 2008
Posts: 25,199
Mein Auto: 02 BMW 525i M54 auto 130K
Quote:
Originally Posted by HTK12 View Post
When I rebuilt the trunk lid harness I also had the two same colored wires.
Are you guys talking about the BROWN (ground) wires?
Or other wires?

And, if the wiring diagrams are wrong, does that canonical thread have the updated information?
__________________
Please read the suggested threads and add value, either by pictures or by descriptions, so the next person stands on your shoulders.
See also: E39 Bestlinks & How to easily find what you need
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:40 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
© 2001- VerticalScope Inc. All rights reserved.