BimmerFest BMW Forum banner
acceleration issue
1-14 of 14 Results
  1. X3 E83 (2004 - 2010)
    Hey All, looking for some help with my new-to-me X3. I've had it for ~2 months now and have been working on it ever since. There's a lot of unresolved issues with the car it seems. 2008 BMW X3 with 72,000 mi The latest issue happened for the first time today while in traffic. I was coasting...
  2. X3 F25 (2011 - 2017)
    Hi All, I am just wondering has any one else come across this problem. While stopped in traffic, my 2014 X3 accelerated of its own accord and crashed into another car. I have dash cam footage of the accident for interested parties to see. I have had little or no satisfaction from the main...
  3. X5 E70 (2007 - 2013)
    I have a 2008 BMW E70 X5 4.8L I own a Carly Pro Bluetooth BMW code reader One year ago I replaced the alternator, battery, throttle body(VDO-Siemens Throttle Body/Housing) and also the Electronic Throttle Harness. After replacing the first 3, the problem remained, although not as frequently -...
  4. E46 (1999 - 2006)
    This is my first post in this forum... ever... I'm also new to owning a BMW, glad to be a part of the community. Let me start by saying that I'm dumb when it comes to these cars, but I am well versed in the world of mechanics and fabrication. Now to my problem, I have been hearing a...
  5. E90/E91/E92/E93 (2006 - 2013)
    Guys, I had my eccentric shaft sensor replaced last year (dealer found out oil leaked into this sensor while doing the VANOS recall). Recently in August I got my valve cover gasket replaced. Right after that, I started noticing occasional issues in acceleration. Like when I am going from 2500 -...
  6. E90/E91/E92/E93 (2006 - 2013)
    Hello everyone, Just registered - my first post. I own a 2010 328i Coupe Premium A/T Triptronic (production date 12/2009, last 6 of vin# P139927) Here is my issue: When I accelerate in any gear, either in automatic or manual mode the car starts to shake and vibrate as if the engine power is...
  7. E36 (1991 - 1999)
    Hey guys, so I've been having starting problems for a while now. When the engine is cold it takes a couple of goes to start and recently it's been getting worse. So I did some research and ordered a new CPS. I installed it and took her for a drive, gave it a bit of boot in 3rd and then I had no...
  8. Site Sponsors & Bimmerfest Group Buys
    Hello Guys We are New a Sponsor for Bimmerfeast. We Would like to Start with nice friendships We Really want to give Good Deal till march 5th 2015 We will offer $30 discount and Free Shipping to USA,Europe and Australia Coupon Code: BimmerfestDSC
  9. E34 (1989 - 1995)
    Hey guys I've been having a problem with my '90 525i for about two weeks now. When I'm in low rpm (under 3500) my car has hardly any acceleration, if I'm cruising at 50 in 4th and mash the gas it very slowly picks up. The other (worse) problem I have is jerking/stuttering around 1800-2200 rpm at...
  10. X3 F25 (2011 - 2017)
    I just purchased a beautiful 2013 silver x3 35i m sport last weekend. It's gorgeous. It now has about 140 miles on it. Twice when breaking slowly (in a parting lot) to stop, the car/engine has continued to try to accelerate. To the point I was basically standing on the break and it was still...
  11. E46 (1999 - 2006)
    i recently bought my first bmw a few months ago, a 02 325i, and it's started to give trouble. it runs terribly. it vibrates very rough at idle, almost bouncing, & it's difficult to get it to stay on when started for the first time that day. the acceleration is also down the drain. when i start...
  12. E34 (1989 - 1995)
    Hi, My bimmer has been experiencing some difficulties and I'm not sure what is going to fix it. The problem is that on acceleration the car stubles and has trouble getting up to speed. It does not happen all the time; mostly when the car is cold and in the morning after the engine has cooled...
  13. E36 (1991 - 1999)
    Hello all! I need your help. I have a problem. My e36 320i M52B20 (oct.'95) (275000 kilometers) accelerates unevenly most of the time (about 95%) and during this the fuel consumption gauge sways - rocks up and down evenly about once every second or less for a few liters (metric unit - about two...
  14. E60 / E61 (2004 - 2010)
    The car rides fine at slow speeds but under heavy acceleration the car starts to buck like a bronco when the tranny is trying to shift gears. It does not happen at any specific speed just nearly at any speed when you floor it. I have searched and saw some folks with similar issues but only at...
1-14 of 14 Results
Top