BimmerFest BMW Forum banner
camshaft positioning sensor

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. E90/E91/E92/E93 (2006 - 2013)
    Let me give you guys a quick timeline. I bought the car with 98,000 miles and at the time the car wouldn't exceed 2000 RPM but would reach 90+ MPH - eventually. At this time there was no check engine lights or codes and it's otherwise in great condition. Now what I mean by 'won't exceed 2000...
  2. E39 (1997 - 2003)
    Manufactured 07/98 and has 130k miles. I have replaced the CPS with a Chinese made then with Bremi, it still displays the message. The engine appears to have a single sensor, intake only. I appreciate information that will help me resolve this issue. In advance, thank you.
  3. X5 E53 (1999 - 2006)
    Hello guys, I recently just replaced the camshaft positioning sensor on my 2003 x5 3.0 (E53) because I was having an issue with it stalling if I don't keep the rpm above 700. I just left from the mechanic's workshop no more than 8 hours ago and it's happening again! If it doesn't stall, I get...
  4. E60 / E61 (2004 - 2010)
    Hey guys I am just posting this video for anyone that has a check engine light on code for P0013 this is a video I made just showing where you can locate these things. I am posting this because when I was looking to figure out this problem I did not find any good information on it about this 5...
  5. E46 (1999 - 2006)
    ok guys and girls, I need help..... I know this has been posted on numerous threads but, seeing how I cant narrow this down by myself and with the help of reading all the other threads, I figured I would start a new one. So excuse me if I get looked down upon for this. Here's the Car - 1999...
1-5 of 5 Results
Top