BimmerFest BMW Forum banner
camshaft sensor
1-17 of 17 Results
  1. F10 / F11 (2011 - 2016)
    So I’m looking at a 2013 528i xDrive with 91k miles, that a dude is letting go of for $4,000. The car doesn’t start, and he said he had a mechanic come over saying it’s the camshaft sensor. I checked it out myself, with a generic OBD reader and got codes P052B, P0012, P13C0, P054B, and P05CC...
  2. 7 Series - E38 (1995 - 2001)
    So my 2001 740iL acquired a cylinder 5 misfire and fuel cut off over night. When I ran the code scanner, one other code popped up. Not only was I getting the misfire code, I also got a “Camshaft Position Sensor A Circuit High Bank 1 or Single Sensor” (Code P0343). I didn’t know if this code...
  3. X3 M
    Hi there, I am new here and this is my first post. I am not good with cars and do no DIY. I live in London. Sequence of events: - The car ran fine until midday Sunday 14th Jul. No issues, messages on dash, etc. Parked at a local park, took the dog for a walk, came back and the car...
  4. E60 / E61 (2004 - 2010)
    My N52 engine has been giving me lots of fun times with the air flow, vanos, camshaft sensor... mixture codes. Car has 82K miles on it. I've recently replaced both Vanos solenoids, MAF sensor, Spark plugs, Coils, a bunch of the seals. I've been getting a lot of random codes that I clear and...
  5. E39 (1997 - 2003)
    I wanted to report my experience, and the final solution in hopes that it might help someone diagnose and quickly fix a similar issue like mine. It started a few months ago in my 2000 E39 with M52TU engine at 168K miles. While running, usually in city driving, after a stop at a red light etc...
  6. 7 Series - E38 (1995 - 2001)
    My check engine light came on so I took it to Autozone for a reading. Their computer showed my camshaft sensors were bad. I replace them BUT my 'check engine' light is still on. Are there some kind of codes or something that I must reset? If so, how can I do this. Thanks in advance.
  7. E90/E91/E92/E93 (2006 - 2013)
    Hello everyone, So my 328xi has been throwing some codes and acting strange and i can't figure out whats going on with it. First the codes P0430 and P0420 were coming on and off randomly when driving, those two codes are "catalyst system efficiency below threshold banks 1 & 2" which i thought...
  8. X5 E53 (1999 - 2006)
    My local indy shop here in Korea is doing some engine work so I would like your opinion as to what else I should do for PM. E53 M54 110K miles. Background: A couple months ago my expansion tank busted while driving ~100mph. I didn't see the low coolant light until 10-15 minutes later. I pull...
  9. E39 (1997 - 2003)
    My 530I is showing codes that indicate a bad Camshaft Position Sensor. I have ordered three diferent replacement sensors and even shopped at the local dealer, but none of the new ones fit! (Part #12141438081 has been replaced with Part #12147539165) They all are basically one diameter, but...
  10. E90/E91/E92/E93 (2006 - 2013)
    :thumbdwn: So my vehicle just recently turned the "Service Engine Soon" Light on and I was wondering if someone would give me some advice on what it could be. File attached is the picture taken of the codes shown.
  11. E39 (1997 - 2003)
    Hey guys I just change crankshaft and camshaft position sensor and oil separator (CCV) on my 97 e39 528i I took it for a quick test drive around the block, the car was running great, after 15min all of the sudden my breaks went all spongy, I had to really pump it to stop, pedal was going almost...
  12. E46 (1999 - 2006)
    Hi I have a BMW E46 2002 318i - Automatic. It's been causing me problems recently where: Car pulls off fine on start and drives fine for most of the time But sometimes, into the journey, starts feeling sluggish and slows right down when off accelerator - like I'm driving with a flat tyre or...
  13. E39 (1997 - 2003)
    :dunno: I have looked over and over and I am sure there is someone out there that has had the same or somewhat simular problem but I just can't find a post on it so here goes.... I have a 1998 540i e39 (9/97) with - well lets just say a LOT of miles on the M62 motor. Just before my waterpump...
  14. E36 (1991 - 1999)
    I have had a 93 325i vanos for over a year now. i had 18 thousand miles of pleasure from the vehicle then one day nothing! after replacing the fuel pump,relays and everything fuel related imaginable i came across a thread here for cps i located and changed the cps started first crank! thank you...
  15. X5 E53 (1999 - 2006)
    Hey guys, I've got some fault codes showing up when I tired to go through emissions to renew my plates this year. I've got a P1519: 'A' Camshaft Position Actuator Bank 1 and a P1522: 'A' Camshaft Position Actuator Bank 2. Can anyone help me locate where these sensors are so I can replace...
  16. E46 (1999 - 2006)
    I have an 01 BMW 325xi... it's been running rough. The error code came up saying that I need to change out the camshaft sensor position A. I was told that there is a left and a right... what does position A refer to?
  17. E90/E91/E92/E93 (2006 - 2013)
    Hi - first time poster. I've a 2005 E90 320D, always been a joy to drive, never any major issues. Took it in last week to dealer for its annual service, all normal except they said I needed a new camshaft sensor. Sensor was replaced, picked up from garage and drove home. All normal enough...
1-17 of 17 Results
Top