BimmerFest BMW Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-18 of 68 Results
  1. 7 Series - F01 / F02 / F03 / F04 (2008 - 2015)
    After an oil change from independent shop, the hidden menu was used to reset the oil service. The problem is that when I turn on the ignition, the instrument cluster is still saying “Service due since 5/2022“ and displays the RED car graphic. if I try to use the hidden menu again to reset, it...
  2. E39 (1997 - 2003)
    Hi, I recently opened my cluster to change the needles to red color, and when I put everything back together the RPM needle does not move. I removed the cluster cables from the back and reconnected them back again and then I worked just fine, turned the car off and on again after 10 minutes...
  3. E39 (1997 - 2003)
    When doing 100kph by gps, my speedometer is reading 118kph. I’ve searched these forums far and wide, but the generally accepted solution is “they were designed to read high” and “live with it.” My speedometer is completely useless if it’s reading that inaccurately. My passengers are also...
  4. E85 / E86 Z4 (2003-2008)
    Hello everyone, This is my first post on this forum. I have BMW e85 from 2006 lifting. I need to change the Cluster because it was wet. I bought new one with the same id nummer. It is not working correctly. When ignition is on, all lights is lighting on cluster. What i should do now? I need...
  5. E39 (1997 - 2003)
    Hi! I have an E39 520i 2002. As you can see in the video the car starts with the light switch. I thought of a bad ignition switch. Then I changed it, it was the same. If someone has a similar problem, please help me. You can see the video at this link. https://streamable.com/gaw66g
  6. E39 (1997 - 2003)
    I have a 520i 2002 e39. I had a cluster lying around and I wanted to test it with my car if it's fully functional. I disconnected my cluster and I forgot to disconnect my battery. then plugged in my other cluster, immediately the oil pressure, battery, ABS, and hand brake lamp were on when the...
  7. E39 (1997 - 2003)
    Hi! I'm wondering if a could activate the speed chime on my e39 2002 520i, low cluster. some people even call it a speed limiter. I would appreciate it if someone can tell me if I can activate it. Or If I could activate different types of chimes.
  8. E36 (1991 - 1999)
    Hi Everyone My 1997 328i Manual instrument cluster is acting up, the rev counter being the culprit. The car has a 240km/h cluster, but without the coding plug. I can get hold an older 260km/h 6-cylinder cluster to replace it with. So the question is (assuming the 260 cluster works fine): Can I...
  9. Interior
    Complete BMW steering column switch assembly. Bought for my son's 2007 BMW 328i a couple of years ago and he wound up totalling the car before installing. I believe it is part number 61319123056 and fits many different models BMW 325i 2006-2006 + BMW 325xi 2006-2006 + BMW 328i 2007-2013 +...
  10. E36 M3 (1995-1999)
    Hi all - Coming here to get my head on straight. I've been battling one small issue after another for about a year now. I finally got all my cluster lights addressed (even the seat occupancy sensor), and resolved bigger fixes like VCG, Starter and a coolant leak. Not bad for a guy that's never...
  11. X5 E53 (1999 - 2006)
    Hello friends, So I've got this problem with my instrumental cluster. Specifically, I have a problem with my outside temperature light. I have had a problem previously where 3 out of 5 cluster bulbs went out and I changed them quickly and they were working, but I had a problem with my...
  12. E60 / E61 (2004 - 2010)
    Hello, I am looking to swap my cluster. How can I verify that item will fit me? I have bmw e60 530i 2004. Online my part number says 62116958594 it means I can only install same part number? Clusters...
  13. BMW Coding and Programming
    Dear friends, I have on the working bench one Instrument Cluster (Full LCD version) from BMW G12, and I'm trying to wake-up it with can massages but without result. I was trying 0x130 as the E/F-Series of BMW - the consumption is ca. 500mA at 13V but the display stay off. When I push the cluster...
  14. E39 (1997 - 2003)
    Hello All, I got this weird electrical problem going on this morning. The Tachometer and speedometer were wayy off. the Tach would rise as if I was driving in first gear (rapidly) and the speedometer read I was going 60mph but I was only going about 15mph then it got stuck there then backed...
  15. E30 (1982 - 1993)
    So a few weeks ago I removed my cluster from my 1990 325I in an attempt to repair my fuel gauge and my temp gauge. The first fix I did I managed to fix the fuel gauge, speedo still worked, but the temp gauge still didn’t work. So this time I dissembled it further to take the temp gauge out to...
  16. F30 / F31 / F32 / F33 / F34 / F36 (2012 - current)
    Hi, I have a BMW F30 -2012 and I opened my cluster to change led to white, and everything worked fine, until I used my cruise control and saw that the green light that moves along with the speed arrow is on wrong position, I set speed to 30km/h and the green light says on 20km/h its 10km/h...
  17. E46 (1999 - 2006)
    Picked up a 2001 325xi with I think 122k on it. Drove it home and everything was fine. Guy who had it had an aftermarket stereo so I just had to run cables back for my subs and when I was disconnecting the positive cable the t-bolt snapped. But the cable back on and got it snug and when turn my...
  18. E90/E91/E92/E93 (2006 - 2013)
    Hi Guys, Newbie here, BMW owner for a few years now. in the attached image my OBD display blank, the bottom screen where it displays the mileage info etc is on fine. Just wondering if there was any solutions to this? Thanks!
1-18 of 68 Results
Top