BimmerFest BMW Forum banner

cps

  1. X5 E53 (1999 - 2006)
    Hey guys, I'm new here and new to the BMW world I recently purchased a 2001 X5 with the 4.4 and it came with a P0011 code. I figured it was an easy fix, and replaced both cam position sensors and both VANOS solenoids. I tested the solenoids (after i installed them) and both are known good...
  2. E60 / E61 (2004 - 2010)
    Good Afternoon All, So I had limp mode come on randomly one day while driving, it turned off after restart and then it came back intermittently over the next few weeks. Now it's on 100% of the time and it started to get harder to start the vehicle. The codes are 0700, 0335, and 1727. Did some...
  3. E34 (1989 - 1995)
    Hey folks, Would be great to get some confirmation from the experts before buying & replacing parts... 1995 525iT M50TU w/ 5sp swap 07/94 build date 197000 miles Not a DD -- more of a utility car. Does not get driven often, but car was starting & running perfectly fine. I was about 1/2 mile...
  4. E90/E91/E92/E93 (2006 - 2013)
    Hi - I replaced the Crankshaft Position Sensor this weekend in my 2010 328 xDrive. The car was running OK but I did feel slight engine hiccups specifically when I slowed down coming to a stop. Must say I did not need to remove the intake manifold and managed to accomplish this in about one...
  5. E30 (1982 - 1993)
    I have a 1984 318i. I bought it on Saturday and on the way home, with a full tank of gas, stalled out and died. The guy I bought it from had the fuel pump replaced and I replaced the fuel pump relay. I've been looking at the CPS as the issue. I don't know if this makes a crazy difference but it...
  6. E34 (1989 - 1995)
    Hi my 1994 530i cranks over but won't start It has no power going to fuel pump fuse when power is jumped to fuse pump pressurizes the system but still no start have power going to coils but I don't think I have spark either when starting fluid is sprayed into intake no change (cranks over but...
  7. E30 (1982 - 1993)
    So This may be a dumb question but do e30's have a cam position sensor? I know they have a crank position sensor (CPS) which is right by the ac pulley and I have replaced, but I am wondering if there is a Cam sensor that may need replacing. I've read up the symptoms and it seems like I have some...
  8. E36 (1991 - 1999)
    Hey guys, so I've been having starting problems for a while now. When the engine is cold it takes a couple of goes to start and recently it's been getting worse. So I did some research and ordered a new CPS. I installed it and took her for a drive, gave it a bit of boot in 3rd and then I had no...
  9. E39 (1997 - 2003)
    Hey guys, I have a 98 BMW 528i with 168k miles. My problem is that when I start my car in the morning it idles extremely rough and billows white oily smoke out of the exhaust. Once the car warms up to operating temperature it runs fine, just a little sluggish. I have done some research and I...
  10. E46 (1999 - 2006)
    I am trying to replace my CPS Harness but cant figure out where it routes too. Its such a small space I cant follow it with my hand. Does anyone know of a thread that has a DIY or a diagram of the cabling for the e46?
  11. E46 (1999 - 2006)
    So I had my 02 325 xi scanned and got p1343, p0491, p0492, and p0340. So far I checked for vacuum leaks, checked ignition coils, replaced spark plugs, new intake cps, and new maf with no improvements. The car is actually running worse. It hesitates bad on acceleration, sometimes stalls and...
  12. E36/7 Z3 (1996-2002)
    I have had the P0365 code come on and off for a few weeks now. The SES light will come on and off intermittently when starting the engine. I have searched a few forms about this issue, what I have gathered is that the M54 engines have two camshaft sensors (intake and exhaust) and this code is...
  13. E39 M5 (1998-2003)
    I'm hoping somebody else had this problem and was able to find the solution. I have a 2000 bmw m5. About a week ago, I started up my car and it was idling rough and when I started to drive it, it was somewhat under powered and running rough; I could hear it in the exhaust as well. Then, after a...
  14. E39 (1997 - 2003)
    Got a CEL - scanned and got a code P0340 / Cam Position Sensor Circuit A, Bank 1 malfunction. Which means on my '97 528i single VANOS engine - 1 sensor on the intake side. Had all the classic symptoms too: sluggish acceleration, and loss of ~ 4 MPG's. Current mileage is 72K, and VANOS was done...
  15. E36 (1991 - 1999)
    I have had a 93 325i vanos for over a year now. i had 18 thousand miles of pleasure from the vehicle then one day nothing! after replacing the fuel pump,relays and everything fuel related imaginable i came across a thread here for cps i located and changed the cps started first crank! thank you...
  16. E39 (1997 - 2003)
    So i got in my car earlier this morning and when i first tried to start her up, the car turned over several times but didnt fire up, followed by banging sounds :eeps: (several), and then i stopped it. on my second try the car started right up. i should also add that when it wasnt turning...
  17. E46 (1999 - 2006)
    I have a 2001 330xi. The cel is on and P0335 cps is indicated. I understand it is located under the starter near the transmission. I raised the can and removed the engine covers, but I cannot see the sensor. Has anyone ever had to replace on of these on an xi? Do I need to remove the transfer...
  18. E39 (1997 - 2003)
    I have a 528 1997 180K and already saw big improvements recently in replacing the crank case valve CCV (no more engine stop (jerk) when starting in the morning or white smoke from tail pipe while warming), replaced cam shaft sensor CPS (no more misfires), replaced/cleaned MAF (no rough idle)...
  19. E39 (1997 - 2003)
    Thought I'd write the issues and solutions to recent car problem I had.. Here is my story, hopefully done now. key words: o2, fuel filter, maf, cps, idle, lumpy acceleration, no power, CEL, check engine light. >For long time, no noticeable issue but for awhile in the morning it didn't hit on...
Top