BimmerFest BMW Forum banner

e83 x3

  1. X3 E83 (2004 - 2010)
    hi, greetings from here Indonesia i had a problem with my x3. the engine are vibrating at cold engine temperature followed with check engine light turned on. but right after 10 seconds or so the vibrate disappear. i took it to the dealer and they change the coils (#2, #5, #6). But, the problem...
  2. X3 E83 (2004 - 2010)
    Hey guy, this is my first time on here and I need some help. I just bought my 08 X3 3.0si 2 months ago and all has been well up until today. As I was driving to dinner, it started shifting hard and didn't seem to want to go passed 2500 rpm. Me and my dad just replaced the valve cover gasket last...
  3. X3 E83 (2004 - 2010)
    Hello guys, I have a 2006 X3 3.0i which recently had the 4x4 and service engine lights at about 68k miles. The car drives smooth but the lights have stayed ON ever since. When first scanned, the following codes came up; 5EB0 Steering-angle sensor,internal 5F3A Transfer case: malfunction 5E50...
  4. X3 E83 (2004 - 2010)
    I have a 2004 BMW X3 2.5i. Every diagram of engine pulley arrangements I see has an idler pulley on top and mine doesn't. I can't even find a picture of another one online. What gives?
  5. X3 E83 (2004 - 2010)
    Hi guys, I would like to replace license plate lights on my X3 2004 - e83, for a LED ones. I have no idea how to remove the actual light bulbs module :( :dunno: Thanks!!
  6. X3 E83 (2004 - 2010)
    So I went to Auto Zone this morning and had the code read for my SES light and it showed as p0171 - Bank 1 Lean. I have read several forums on this topic and have seen the various problems associated with this code - CCV valve, DISA valve, some sort of vacuum leak (intake hose or otherwise)...
  7. X3 E83 (2004 - 2010)
    Hi, I had my 07 X3 3.0D in for a routine service a little while ago and it came back with a list of things to be repaired. Two of these were the breather ( CCV I believe this is referred to generally ) and the intake manifold. Both of these shocked me as I hadn't had any problems with the car...
  8. X3 E83 (2004 - 2010)
    hi guys, so i purchased an x3 with 75,000 from the dealer and within the first month, i had to do the following things - - Four wheel alignment performed - Oil change using BMW syntethic oil & filter - Drive belts replaced - Air filters replaced - Oil separator plus all...
  9. Do-It-Yourself H.Q.
    I guess it is the relay, but I cannot locate it... Or can it be the control unit, which as far as I understand is attached directly to the rear wiper motor?? When I connect electricity directly to the washer pump it functions without problems. Thanks for any help
Top