BimmerFest BMW Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. X3 F25 (2011 - 2017)
    My 2013 BMW X3 (103,000 miles ) , went into Parking mode while at 70 mph speed and was not accelerating or going into drive mode and I had to pull it to an emergency lane. I turned off the engine button and then when I tried to turn it back on, nothing was happening. Everything was normal on...
  2. E90/E91/E92/E93 (2006 - 2013)
    Hi Guys, Looking for some opinions on my current issue. I have an 09' e93 320i (80k miles N43 Engine) that's seized, thinking on my next steps.. I noticed there as was a rattle on cold starts the last month or so (in hindsight, didn't put 2 and 2 together and think this was probably the timing...
  3. E60 / E61 (2004 - 2010)
    :(Looking form some advice. I recently bought (7/2012) 2010 535xi with 44,000 miles. Last week brought it to my local BMW dealer, with 49,900 miles, to have state inspection done and have them look at anything that may be needed before my bumper to bumper expires. I asked about some...
  4. 7 Series - E65 / E66 (2002 - 2008)
    A couple of months ago, my oil pan was cracked, unbeknownst to me and as a result, the oil leaked out and the engine locked. Is it possible to repair, or do I need a new engine ?
  5. X5 E53 (1999 - 2006)
    Here in WI it is very cold. Last Thursday was -15F with a colder wind chill. My X5 was parked in my garage, which is not heated but insulated. It was below 32 degrees in my garage. Drove to work Thurs am, all was good, parked outside in the lot. Came back at 5pm, started the car just fine, then...
1-5 of 5 Results
Top