BimmerFest BMW Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 190 Results
  1. E36 (1991 - 1999)
    I replaced the fuel pump recently after the previous one failed on me while driving on the highway. For the ~1hr that I was able to drive around with that pump, the car ran perfectly. Lambda looked great and it felt excellent. I replaced the pump and attempted to go for a drive, but the fuel...
  2. 7 Series - E38 (1995 - 2001)
    Hi All, Im having issues with my e38 735il non-vanos, built 10-1997. The issues stem from a lack of acceleration, when I put the pedal down in normal driving conditions it seems quite zippy (2000 rpm >). But when attempts to accelerate past that 2000 rpm barrier occur, they are normally met...
  3. 7 Series - E65 / E66 (2002 - 2008)
    I have desperately read every post on this website. My car has trouble starting when "warm." AKA my car starts on the first try only after I get gas and when I start my car for the first time of the day. My "Drive moderately" light is on, the DSC I believe. I just purchased this car with right...
  4. E36 (1991 - 1999)
    My 1996 318i e36 is getting no power to fuel pump. Replaced the crank sensor and got power to pump but still didn't start so replaced the fuel pump and wouldn't get power to pump again. No power through fuse either. relay is working.
  5. E46 (1999 - 2006)
    Introduction It took me a long time to understand fuel trims, despite excellent videos by 50skid and excellent posts by JFOJ on e46fanatics. I think I have a handle on them now, so I thought I would try to explain them as I understand them, and either help someone and/or get corrected. Here is...
  6. E90/E91/E92/E93 (2006 - 2013)
    Summary: 07 335i n54 (tuned) stage 2 fuel it walboro pump -misfire - no temp sensor So ive been experiencing slight misfire for a few months now, slight enough that i know its there but it doesnt affect me driving. My friend and i have used inpa to see any codes that my car has and 2 show up...
  7. E60 / E61 (2004 - 2010)
    Hello all, I found the culprit! Still need solution to solve Background: My e60 has been cranking but not starting. Long story short i changed a bunch of parts including fuel pump and fuel filter (both oem bosch) But still car isn't starting. Just now i had an idea to crank it with the fuel...
  8. E60 / E61 (2004 - 2010)
    Hello, My 530i is not starting, it cranks but doesn’t start. Last week I put in a new Bosch fuel pump, and filter. Still would crank but wouldn’t fire up. I decided to change the injectors, however in the process of disconnecting the fuel rail fuel supply hose on my n52 I realized that barely...
  9. 3 Series & 4 Series
    Just had the fuel pump replaced at the dealership 2 days ago. I smelled gas when I got the car back but the service dept said I would for a couple days. Still, the smell got worse and I looked under the car to see fuel dripping from the side of the tank and running down along the bottom of it. I...
  10. X3 E83 (2004 - 2010)
    How do you replace the fuel pump on a 2008 BMW X3 will I have to open both sides of the tank
  11. E36/7 Z3 (1996-2002)
    Adventures in Replacing a Fuel Pump on a 2001 Z3 M-Roadster Well I still have my M-Roadster since 2001 and now find that I have a fuel pump leak. Only happens when it runs and doesn't shoot out or anything, just sort of dribbles. Just enough that you smell it in the garage when I park it. I had...
  12. E60 / E61 (2004 - 2010)
    So just recently I started having issues with my 2006 525xi with just under 160k miles , I’ve only owned this car for only about 4-5 months. I try to do all the work needed that I can do, myself, so any help or insight on others similar personal experiences would be greatly appreciated. as of...
  13. E60 / E61 (2004 - 2010)
    I was driving down the highway when my ‘07 550 started sputtering and dying I could start it drive it at decreasing intervals till it just wouldn’t start any more. After some research I believed it was either the fuel pump or the Fuel pump control unit( I think it called the EKP but I could be...
  14. X3 F25 (2011 - 2017)
    Hey guys, I have a 2015 F25 35i (N55). When my wife was driving it the other day she complained of a couple rough “lukewarm” starts. The following day on the highway it began to run very rough, check eng. light came on and gave the Drivetrain Malfunction warning. My wife worrying about damaging...
  15. E60 / E61 (2004 - 2010)
    The back story... -Battery Tested at 11.8 -No check engine or other lights on dash -Shifter sometimes reads N when I've put it into P. Car is actually in park and remains in park but the shifter reads N and a warning pops up on the console screen regarding the issue. This happens about 1/3 of...
  16. E46 (1999 - 2006)
    Hey guys (And gals) I am new to the forum and just purchased an E46 325CI with fuel transfer issues to right side tank. Symptoms: Test 19:6.0 shows no fuel transfer from left to right side and runs out of fuel at 1/4 tank. I replaced the fuel filter (w/ new hoses), fixed vacuum leak on F...
  17. F30 / F31 / F32 / F33 / F34 / F36 (2012 - current)
    Was driving recently, fuel pump went out. Know this is covered under factory warranty/recall. Took it to certified bmw service, was told after diagnostics that both the HPFP and the Fuel Pump control unit were bad. I don’t want to shell out near a grand to fix something that my not actually be...
  18. E39 (1997 - 2003)
    Hey looking for some good ideas here. Two weeks ago went out to start car, and it would start and only idle at 300 RPM, and wouldn't accelerate. Don't have a scanner yet, so I replaced the Fuel Pump (old pump was original), and then replaced the Fuel Filter (original filter), then tried to...
  19. E90/E91/E92/E93 (2006 - 2013)
    Hi all, How are you?! Please, I need help with this problem. When I turn off the engine of my BMW 330i E90, seconds after the Start Stop button´s light turns off, the Start Stop button and the gas pump turns on again. I do not press any car key´s button. The car does this all alone. This loops...
  20. F10 / F11 (2011 - 2016)
    Hey all: I've been enjoying a headache-free life with my 2012 528i until about last month. I was running some errands about a month ago when my car decided to go into limp mode and the fuel system error came up on my iDrive. Checked the code, P142E. The car would absolutely not start after...
1-20 of 190 Results
Top