BimmerFest BMW Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 182 Results
  1. General BMW Questions
    I’ve been running my 2014 550i on 93 octane from a non-top tier gas station and want to switch to top-tier gasoline. The problem is, the only top tier gas station near me is Marathon and their highest octane they have is 91 octane. My question is, what is more important? Is it better to use 93...
  2. X5 E70 (2007 - 2013)
    Background: Absolute BMW noob here, at least as it relates to modern BMW cars, having owned only two old 2002s, two e36 318tis, and an old 528e. I am okay with cars/tools/general mechanical aptitude. The car is a 2013 X5 35i with about 135k on it, unknown maintenance history. Runs well...
  3. E60 / E61 (2004 - 2010)
    I have the leak at the sender unit. I can see small cracks at the base of the nipple but I think my leak may be coming from the fuel line. I don't know if it's a return line or a feed line. I've already ordered the sending unit/filter assembly, o-ring and new fuel line that attaches...
  4. E30 (1982 - 1993)
    It's right after the tank and right before the external fuel pump...
  5. E30 (1982 - 1993)
    For 1991 e30 convertible. The battery died and I was trying to jump it off. It would turn over but not crank and I started smelling gas. When I looked under the hood, I noticed fuel dripping out of the bottom of the Black Thing with the rubber nipple on top and the hoses coming in and out of...
  6. E30 (1982 - 1993)
    Hello, I have a 1984 E30 318i and recently I started my selling gas while running the car. Turns out there's a pin hole leak in the hose leading from the fuel filter (to the fuel rail?) Picture of the leak is here. The hose is running to this grey canister. So I thought about just...
  7. E60 / E61 (2004 - 2010)
    I have: 2009 535i xDrive Walbro 535 fuel pump 7.5 stepped fmic Charge pipe with tial bov I had a walbro 450 but had very very low LP pressure 20-35... Swapped in a new 535 and have the same low pressure... It has a new filter/regulator from FCP and I tested a new ekp3 unit.... Still low...
  8. E90/E91/E92/E93 (2006 - 2013)
    Experienced long cranking but no start. Checked fuses to find fuse #70 (30 amp behind glove box) melted and very damaged. After completely removing junction box and prying pieces of the blown fuse out of the harness I noticed some melting on the OUTSIDE of the connector itself. Would a bad fuel...
  9. E39 (1997 - 2003)
    Hey guys, another problem... So last night i had around 120km of range left, maybe 15 litres, something like that when i came home, this morning i started it it showed 76km, i know it first shows lower then it raises over a few minutes but this morning it actually dropped, covered maybe 6-7km...
  10. E30 (1982 - 1993)
    Hey guys, I recently rebuilt my head and replaced the fuel pump, filter, injectors, and relay. I had a cut out and the check engine light pops on and off and there would be a loud pop but i didn't think anything of it since it only happened once. now its reoccurring and i'm super confused on...
  11. General BMW Questions
    Hello so I was reading into another forum about a stuck cylinder 5 misfire and someone in the post said to check long fuel trims if it's above 5 it's worth investigation. Seeing as mind is at 11.7 What should I do to solve this issue? Would it be a vacuum line? Or would it be something else any...
  12. E36 (1991 - 1999)
    Hello everyone, i have a problem with my e36 that cranks but can't start. I figured it would be a fuel-related thing but now I have changed the fuse and fuel pump relay and it still does not work. I measured the volts to the relay and it only gives it 2V, and I think they should get 12V? correct...
  13. E39 (1997 - 2003)
    Hey looking for some good ideas here. Two weeks ago went out to start car, and it would start and only idle at 300 RPM, and wouldn't accelerate. Don't have a scanner yet, so I replaced the Fuel Pump (old pump was original), and then replaced the Fuel Filter (original filter), then tried to...
  14. F10 / F11 (2011 - 2016)
    Walked out of the BMW dealership with a deep sense of getting hosed. I drive a 2015 535i xDrive with 38000mi (adding roughly 5000-6000mi /yr). I was told to get a Fuel Injection System Service and a Fuel Optimizer Service to the tune of $530. They performed this same service 2yrs ago when the...
  15. E90/E91/E92/E93 (2006 - 2013)
    Hi, first post, but i've been lurking on here for a little while! Looked through, but not found a thread with the conditions i have showing up. I bought an e91 325d (2007 M57 engine) and the Particle Filter warning has come up. Checked the faults with mycarley (on a friends phone) which pulled...
  16. E90/E91/E92/E93 (2006 - 2013)
    Trying to resolve a problem on my car, e90 n52 218hp, some of you might have seen any of my posts on here before - So I'm on to testing the fuel pump, and I noticed it doesn't prime (turn on before the engine actually starts) at 1st or 2nd stage position ignition (fob pressed, Start button...
  17. E46 (1999 - 2006)
    Stock 2001 325i 5spd Manual I can hear the pump priming and had a buddy watch the open fuel delivery line while I primed the fuel pump and he said it sprayed out with good pressure. I already replaced the filter with attached pressure gauge along with all the hoses, but still nothing in the...
  18. E36 (1991 - 1999)
    I am very frustrated I had to change the rear brake line and in order to do so I had to drop down the fuel tank and I met up with 2 unexpected problems. The right side tension strap just won't fit in, it seems short the bolt just can't reach the hole I have tried hooking the strap and then...
  19. E36/7 Z3 (1996-2002)
    After a few days and some work I have figured out that my 97 1.9 Roadster isn't starting because of my fuel tank pressure sensor not being plugged in. Does anyone have any info or links that can point me in the right direction to finding where that sensor is located and where that pesky...
  20. E30 (1982 - 1993)
    Whats up guys? I’m having fuel issues with my 89 BMW 325i Sedan. I bought the car in running and operation condition 1 month ago. Car started with no trouble. However since then, car hasn’t started. The car still cranks, however it doesn’t start. Things I have done to the car: Installed a brand...
1-20 of 182 Results
Top