BimmerFest BMW Forum banner
icv
1-20 of 25 Results
  1. E39 (1997 - 2003)
    Hi, I've been having issues in the past with vacuum leaks and a broken DISA valve that I finally was able to fix. During that time I had my car stall on one occasion when coming to a stop at a traffic light. I figured it was caused by the rough running and misfires, but now it's happened again...
  2. E36 (1991 - 1999)
    Hi guys, I have a 98 328i. I'm getting a cylinder 2 misfire(P3020). I have replaces the coils, spark plugs, maf. I've cleaned the throttle body and the ICV and also checked for any vacuum leaks which there are none. The voltage to the coil rail is 12.2v. I've found that my engine runs too rich...
  3. E36 (1991 - 1999)
    Just a quick question for OBD1 guys/gals driving M50 cars. A friend and myself removed my ICV to clean it, and in the process ended up removing the hose that goes from the icv to the intake manifold; on that hose he told me it clicks into place, but i cant seem to get it to stay in solid. Does...
  4. E34 (1989 - 1995)
    Hey folks, Would be great to get some confirmation from the experts before buying & replacing parts... 1995 525iT M50TU w/ 5sp swap 07/94 build date 197000 miles Not a DD -- more of a utility car. Does not get driven often, but car was starting & running perfectly fine. I was about 1/2 mile...
  5. E30 (1982 - 1993)
    As stated -- 1984 318i has a rough idle and will stall occasionally when first started, but most times will stay running -- although in a very rough fashion. Once I drive down the street she will not stall and will hold the idle between 750-800 rpm, but it's a rough idle. Not super rough, but...
  6. E36 M3 (1995-1999)
    Any help with this would be greatly appreciated. I have a 1998 M3 sedan that has a fault preventing the car from running at idle. This pretty much happened all at once where one day I went to start the car and after the engine started it immediately died without going into idle. If I hold the...
  7. E39 (1997 - 2003)
    I have a 2002 530i that runs great, until it feels as if the gas isnt reaching my engine properly, and causing it to lose acceleration drastically until eventually spitting and sputtering to a stop, im thinking caty converter, diagnostic recommended i inspect exhaust system and cat, and spit...
  8. E36 (1991 - 1999)
    Hello, I have purchased a 1995 318si, and I have 1 problem. When I first got the Bimmer, I started it, and it would idle horrible, and then stall. If I got the RPMs up around 2k it would stay running. I then read the ODBI code using the gas stomp method. Here is the code I received. 1215 Mass...
  9. E39 (1997 - 2003)
    Today I went ahead and cleaned my ICV to try and make my idle much better, unfortunately I couldn't get the whole ICV unit out since the bolts were too tight and I almost was about to strip them... so I just took off the lower intake boot, and sprayed the mess out of the throttle body and ICV...
  10. E36 (1991 - 1999)
    I haven't seen any posts about this problem with the ICV. Beginning: Over several months noticed a drop in engine power/efficiency. Eventually CEL P1174 (vague fuel trim code) came up. This usually means vacuum leak. I set up a vacuum test pulling air up through the intake and listened for...
  11. E90/E91/E92/E93 (2006 - 2013)
    I'm in need of some help! I'm not very good with cars. I need help locating the idle control valve on my car. I've looked around the internet and i've not been able to find where it is at. I either need to clean it or repair it but first i need to get to it, Thanks!
  12. E36 (1991 - 1999)
    I have an audible buzzing with a steady ticking sound coming from under the intake manifold. There is also a strong vibration through the hose that runs from the intake bellows to the Idle Control Valve (ICV). This happens when I switch the ignition on and continues for a few seconds after I...
  13. E39 (1997 - 2003)
    hi, i have a 2001 530d e39, i have the intake manifold off and am trying to locate the icv, ive spent over an hour trying to find it but have had no joy. can anyone help me as to where it is and what it looks like, thanks, Andy
  14. E36 (1991 - 1999)
    I have a 92 325i 4 door. It had been idling rough for a few days, so I decided to clean out the ICV. When I put it back on and cranked it up, it idled very smooth, though a little low and the check engine light came on. I didn't drive it anywhere, just turned it off. The next day, I drove it to...
  15. E46 (1999 - 2006)
    Hey guys, today I decided to test my fuel pressure to maybe point me in the right direction with some cold start bogging. My car, though it hasn't done it in a long while, only stalled maybe twice but would come really close to stalling all the other times it did this bogging at startup. The car...
  16. E46 (1999 - 2006)
    Hey guys, ive read on here for years and have done a lot of DIY from your threads but i felt i needed to post my own question: My 2001 325i starts and drives fine but often the idle gets really jumpy when at a red light, jumps between 300-800 rpm and then will stall completely, not all the time...
  17. E36 (1991 - 1999)
    The car is '93 E36 with M42. In most cases the car doesn't start on the 1st attempt. Still, I could perfectly live with that as long as it starts on the 2nd one. But the problem is that when I start the engine, at the beginning it runs like a crap (not always, but very often). But then the car...
  18. E39 (1997 - 2003)
    I just completed (or thought I had) the longest, most drawn-out project I've ever undertaken. It started out with trying to determine if something in the wiring was causing P0335 (crankshaft position sensor) and P0727 (engine speed sensor). It turned into a marathon of: R&R the CCV and...
  19. E39 (1997 - 2003)
    This thread today, where a user went from a low altitude warm area to a high altitude cold area, got me wondering how the E39 adapts to altitude when it comes to engine control adjustments: I've noticed in the past when I drove from San Jose (about 100' ASL) to Tahoe (around 6,000' ASL), my...
  20. E46 (1999 - 2006)
    Well, at 150 miles on the trip odometer yesterday my SES light came on... again- same codes as before: PO171 CNF - Bank 1 System Too Lean PO174 CNF - Bank 2 System Too Lean I've been using a couple of threads as a resource as I've tried to track down the problem(s) and in particular this one...
1-20 of 25 Results
Top