BimmerFest BMW Forum banner
miss fire
1-6 of 6 Results
  1. E46 (1999 - 2006)
    I have been having a problem for the past 6 months, where I have been getting miss fire on 1 bank 3 cylinders at idle. When I am driving, I can't tell if the miss fires are present and car feels fine otherwise. My mechanic explained that it could be a vacuum leak. Car is a 2004 E46 330i...
  2. X3 E83 (2004 - 2010)
    I am having an issue and it seems to be engine power related. I had a code for upstream O2 sensor, replaced both, no more code. When driving on flat ground it accelerates normally, get a higher torque load, such as a hill, starts shuddering &/or missing in the 3000-4500 RPM range and goes away...
  3. E39 (1997 - 2003)
    I have read many posts but none helped. Started off with a miss and PO300 & PO303. Changed spark plugs. Cylinder 3 coil pack connector was burnt to the point it had to be replaced. Coil pack was also burnt so I replaced it also. Car ran fine for several minutes but then started miss firing on...
  4. E36/7 Z3 (1996-2002)
    I have a 1997 Z3 2.8L with 90,000 miles on it. I've had the car for a year and it ran fine until a week ago. The CEL came on and the car started running sluggish. Had the code read and cleared. Secondary air pump failure which I knew about. after clearing the code the car ran fine for two or...
  5. E46 (1999 - 2006)
    Hi. I have my e46. 2001 325ci I have misfire cylinder 1 !! - problem: I change the coil, the injection , the spark plug ,the VALVE COVER GASKET The Valve Cover Gasket Set, Crankcase vent valve, Engine Valve Cover The Breather Vent Valve Hose kit, Engine Valves I pay almost 2400 dollar try to...
  6. E46 (1999 - 2006)
    I have a 2000 323i with the 2.5 straight 6 engine. For the last month I have had problems that seemed to be fuel delivery. I got my check engine light checked, and it said i had a bad fuel pressure regulator and that both camshaft position sensors went off. The problems got worse. A slight...
1-6 of 6 Results
Top