BimmerFest BMW Forum banner
most bus issues
1-7 of 7 Results
  1. X3 M, X5 M, X6 M, Z3 M & Z4 M
    Hello all, I have a 2011 X5 50i XDrive. There is currently no sound from the speakers or door tones, parking sensor tones. I have been trying to trouble shoot this with a MOST fiber optic loop. All the modules in the rear drivers side (amp, bluetooth module, and TCU Module) seem to be...
  2. E60 / E61 (2004 - 2010)
    Hello Everyone, I have a 2005 525i with about 120k miles on it. I am a college student, so I am working on a budget. Any help at all would be appreciated.*A little over a week ago, I went to get into my car and the radio did not turn on and my screen was completely black. On the way to the auto...
  3. Car Navigation, Audio & Electronics
    Hello Everyone, I have a 2005 525i with about 120k miles on it. I am a college student, so I am working on a budget. Any help at all would be appreciated.*A little over a week ago, I went to get into my car and the radio did not turn on and my screen was completely black. On the way to the auto...
  4. E60 / E61 (2004 - 2010)
    Hi guys, I apologize in advance for such a long post, but I’m in desperate need of help. I’ve looked over this site for a few years now and you guys have been very helpful in solving many simple problems with my 535i and I thank you all for your contributions. I’ve looked around the forums...
  5. E90/E91/E92/E93 (2006 - 2013)
    Yesterday when I started my car, I got a warning message that said "SOS" with a phone symbol - all of which had a slash through it. I then realized that my radio and bluetooth stopped working. I'm not able to use any of my controls at the steering wheel (volume, input, etc) either. I checked all...
  6. 7 Series - E65 / E66 (2002 - 2008)
    so i unplugged my logic 7 amp last week to see if it was messing with the most bus. i put a lollipop on the end of the connector. it didn't make any thing better. long story short its my voice modual i plugged the amp back in and put the pannle that hides it back in place. i turn on the car and...
  7. 7 Series - E65 / E66 (2002 - 2008)
    Hello guys, I am new to the site and just recently purchased a 02 bmw with 70k miles on it, today the navigation stopped working ans so did the radio/cd player. the I-Drive monitor freezes on startup and all i can control on the dash is the Ac/ heater buttons, I was just wondering if anybody...
1-7 of 7 Results
Top