BimmerFest BMW Forum banner
n52 engine
1-11 of 13 Results
  1. E90/E91/E92/E93 (2006 - 2013)
    So today I bought my first E90. It's a 2008 328i wagon that cosmetically is decent. The engines a different story. I paid $900 for it so I didn't have high expectations for the internals and am fine with replacing the engine and transmission. It has the infamous oil filter mount leak that made...
  2. E60 / E61 (2004 - 2010)
    I recently put in a new fuel pump(RR)and sending unit(RL) and my car wont start ever since I made the switch. The sending unit tank is filled more with gas then the fuel pump tank. And I'm pretty sure the tank style is a saddle style. Is the gasoline suppose to flow over or is there a hose thats...
  3. E90/E91/E92/E93 (2006 - 2013)
    So I've been working on putting in a new engine on my 325i, when we were finally putting it in we noticed that the engine brackets right next to the engine mounts don't line up correctly at all. The n52 engine I got was taken off of a 5 series and those brackets don't align either. Does anyone...
  4. E60 / E61 (2004 - 2010)
    Hello i have a 2005 525xi with the n52 engine. A "professional" mechanic has worked on the car and my auxiliary water pump gets its ground under the airbox frame rail and the hoses have been cut up and are being held by zip ties the pump is also held in place with zip ties. Does anyone have a...
  5. .

    E60 / E61 (2004 - 2010)
    .
  6. E60 / E61 (2004 - 2010)
    My brother‘s 2007 530i has a flaky #1 cylinder. The car has a rough idle, but seems to drive okay. I have done a cylinder disable test and turning off each fuel injector causes the engine to stumble, except for #1. Turning that fuel injector on and off doesn’t make any notable change to the...
  7. 1 Series & 2 Series
    I own a 2011 bmw 128i - n52 with 80k miles on it. I was driving one day and then i got a yellow low coolant dashboard sign. I continued driving for 10 minutes without noticing anything odd then parked for 30 minutes. I did not check for coolant levels when i drove off AGAIN. After 20 mins...
  8. F10 / F11 (2011 - 2016)
    ]I have an F10 528 with an N52 engine. The car is a no start. I've replaced the cam sensors, cleaned and tested vanos solenoids and set timing. Car turns over it but turns quickly. I believe the starter is engaging the flywheel because it does not sound like it is just spinning. When doing the...
  9. E85 / E86 Z4 (2003-2008)
    So, I was doing some maintenance on my car, and chasing down the never ending cold rough idle. First thought was to check codes, nothing related popped up on my Foxwell. Hmm. 🤔 It’s not injectors, not spark plugs, no damaged vacuum lines, brand new O2 Sensors, never know with my MAF since I’ve...
  10. E90/E91/E92/E93 (2006 - 2013)
    can anyone identify what hose this is circled in the screenshot? I lost the spring clip that attaches it to the upper radiator hose and cant source seem to source it. OR if anyone can link me/tell me the name of the specific spring clip, it would be much appreciated. :dunno: EDIT: Source of the...
  11. E90/E91/E92/E93 (2006 - 2013)
    Hi, some days ago I purchased a '05 BMW 325i ( N52 engine / auto / 95k miles) It had some faults with the Vanos I changed both of the Vanos Solenoid - but still keep the faults (2A82 2A87 2A98) I checked the filter cap - fine I cleaned the Vanos Check Valves - both were dirty now the car runs...
1-11 of 13 Results
Top