BimmerFest BMW Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-14 of 15 Results
  1. E63 / E64 6 Series (2004 - 2010)
    I am getting fail codes on Catalytic converter.. also on BanK 2 up and down on the O2. Do you think it is the Cat or the O2 sensors? or something else. ?
  2. X3 E83 (2004 - 2010)
    Replaced it today. What a pain in the butt! Easy procedure in theory: 1. Remove plastic engine cover (I keep mine off so that was already done) 2. Remove two e8 bolts holding bracket above o2 sensor and pull out bracket 3. Remove O2 sensor. 4. Put everything back Tools: 22mm 3/8 inch crows...
  3. E39 (1997 - 2003)
    Hello BimmSmart Community. I recently purchased an e39 : 2001 : 525i. The CES light came on a few days and a couple hundred miles after I purchased her... Advanced Auto Parts ran the diagnostics and the code came up for 02 Sensor: Bank=1 Sensor=2. I've looked at some videos and diagrams...
  4. E85 / E86 Z4 (2003-2008)
    Hi, I have a 2007 z4 coupe. After the engine light appeared I have realised that both of my post catalytic converter oxygen sensors appear to have no reading. No voltage shown at idol or during acceleration. Does anyone know if these are fused ? For these Bosch sensors can anyone tell me how...
  5. X5 E53 (1999 - 2006)
    Hello, I have a 2003 BMW X5 3.0i. My issues began when the "service engine soon" light came on. I took the car to Auto zone and they told me i needed a new oxygen sensor. 2 days later, my remote key stopped working. It would not disarm the alarm, or unlock the doors. Several other things...
  6. E46 (1999 - 2006)
    My car just had an engine swap, and we want to replace the O2 sensors now. Some are faulty, and it's about time to change them. 125,000 miles, I was looking at the bosch sensors but I am unsure which ones to buy. I want to replace all 4 sensors for a 2002 325 CI. PLEASE HELP...
  7. 7 Series - E38 (1995 - 2001)
    Recently my 1995 740iL has developed a rough idle after starting. It gets better after warming up, but it still has a rough idle. Sometimes it wants to idle around 350rpm. I put a code reader on and got codes for oxygen sensor #1, lamda control #1 and lamda control #2. I tried again with the...
  8. E39 (1997 - 2003)
    Two codes since purchasing this car a few weeks ago and just got around to dealing with the first of them. It's a generic P0155 which is the first O2 sensor on bank #2. I believe that's the post cat sensor on right side of the car but I changed both post 02 sensors since I was there. I've...
  9. E36 (1991 - 1999)
    It appairs that these o2 sensor may even be the originals from 1998, the guy I bought it from had NEVER done any manteinance to this car. So I'm stuck with all the homework. I already sprayed PB blaster LOTS of it. Left it alone for a while. Ran the car so they would warm up. Blow torched the...
  10. E34 (1989 - 1995)
    Ok so a while ago I got a code for the mass air sensor. I replaced it and my air filter also cabin filter change the oil. After everything I reset the values via connecting both negative and positive wires from the battery for ten mins. I then got a oxygen sensor code so I replaced it as well...
  11. E36 (1991 - 1999)
    What brand/model O2 sensors work well in a 1997 328is? Looking to replace mine and found numerous options. Thanks.
  12. X5 E53 (1999 - 2006)
    Hi - I'm new to the forum and have been having some issues with my car lately. I drive a 2005 BMW X5. I do not know a lot about cars, so bear with me. My check engine light kept coming on and the mechanic found a hole in the tube that checks how much air is going into my engine. I had it...
  13. E36 (1991 - 1999)
    I have a '97 318ti with 167K. The check engine light is on, and the computer is telling me that I have a P0420 Mod$12 Catalyst Efficiency Below Threshold (Bank 1). I have said a prayer, and hope that it is not another catalytic converter but the oxygen sensor, as I replaced it 30k miles ago. I...
  14. 7 Series - E65 / E66 (2002 - 2008)
    I just had one of the oxygen sensors replaced and air flow meter but the car is still running rough when trying to accelerate. It wont go past 20-30mph without causing some problems and wont accelerate pass almost 2 rpms. Any one know what the problem might be, i read in another thread it can...
1-14 of 15 Results
Top