BimmerFest BMW Forum banner
p0340
1-11 of 11 Results
  1. X3 E83 (2004 - 2010)
    It is a 2010 BMW X3 3.0. Engine shut off while driving. Couldn't start after that. 1. At the beginning OBD read error code: P0012 and P0340. I replaced both intake and exhaust camshaft position sensor. 2. After replaced camshaft sensor, still couldn't start the engine and new error code:P0016...
  2. E36 (1991 - 1999)
    98 m3 pulling the p0340. Autologic 61 i think? Cam sensor signal IMPLAUSABLE. Cam sensor reading holds at 59° Code appears immediately at startup. Car symptom is just laggy power. Had 4 sensors run through from all brands including oem. Engine timed correctly, triple checked. Complete wiring...
  3. E46 (1999 - 2006)
    2002 BMW 330ci is the car I am dealing with. Hello all- I pray for help to this crazy issue that has popped up after some detailed repairs. Car was running rough at start up, but smoothed out after running a few minutes and drove fine. I pulled the codes and there were 2 indicating misfires as...
  4. E36/7 Z3 (1996-2002)
    Car recently pulled both codes. :eeps: Anyone have any experience with these and/or opinions on it being 02 sensor or camshaft or both?
  5. E39 (1997 - 2003)
    Don't crucify me, I'm new here. I searched through old posts and didn't find what I was looking for. I've been getting an intermittent SES light and the only code it's throwing is P0340, intake cam position sensor bank A. When I clear the code it won't reappear for a start or two. Is this normal...
  6. X3 E83 (2004 - 2010)
    Ok guys, I've been a long long time lurker, and I've fixed so many problems with my BMW through the help of y'all and old posts from way back when! So my problem is this, I have a 2005 BMW X3 3.0i, the car randomly went into limp mode right after I had my inner tie rod and ball joint replaced. I...
  7. E46 (1999 - 2006)
    Recently ive had a few things done to my car that include Spark Plugs(NGK Double Plat),Water Pump Replaced, Fuel System Treatment 3 times( 2 Royal Purple Max Clean, 1 Gum Out 2x All in one), Full Synthetic Oil Change 2000 miles ago, SeaFoam. So Far, My vehicle displays p0300- For the misfire...
  8. E39 (1997 - 2003)
    Hello, I've read on the subject but just wanted to get some input from the board members on this. I recently just changed my battery as the car was giving me signs of a bad battery Now though, the car has stalled on me twice within a three week period either at really low speeds, or at a stop...
  9. E46 (1999 - 2006)
    I had mycodes scanned and came to the conclusion to replace spark plugs, new maf sensor, new intake cps, and cleaned the disa valve. Its running worse now and I have coes: p1345, p1353, p1349, p0313, p0300, p0102, p0340, p0171. So alot of misfire. And still have the same code for the intake cps...
  10. E46 (1999 - 2006)
    I have had some problems with my 02 325xi. It seemed to start after I replaced the spark plugs. It is idling rough sometimes and when you try to give gas to accelerate it dies down and sometimes kills off all together. I have codes p0340, p1343, p0491 and p0492. I checked for vacuum leaks via...
  11. E46 (1999 - 2006)
    I am getting the P0340 code. I have replaced the CPS and that made no difference at all. My 2000 323i is still running with a rough idle and mis-firing on #6. Like I said I replaces the CPS - I also replaced all of the spark plugs (Needed to anyway). I am not sure what else it could be. Can...
1-11 of 11 Results
Top