BimmerFest BMW Forum banner
solenoid
1-20 of 32 Results
  1. E60 / E61 (2004 - 2010)
    Hello, I replaced my solenoids, sleeves, and pan then refilled the transmission with fluid and car didn’t start. I tried jumping the battery that didn’t work there is no issue with the battery. I dropped the transmission pan again made sure the sleeve and plug were put in right it still did not...
  2. X3 F25 (2011 - 2017)
    Hi all, A quick question: My CEL came on a week ago, not flashing but steady. I read the codes and there was one code - P24C6 which referenced the camshaft timing. I know that P codes are not BMW dealer codes but it was the best I could do. It referenced a EVAP canister or fuel tank leak, or...
  3. E60 / E61 (2004 - 2010)
    Hello, So here we go... I have a 550I 2008 70K Miles. I changed the VANOS solenoids, purchased SMP from Rock Auto. I stupidly switched the harnesses on bank 1, and my car was erratic. I drove for a little like that, because when i pulled off to test, it wasn't all that bad, thought oil just...
  4. E34 (1989 - 1995)
    Hi, I have a 1995 BMW 525i E34 that recently has a check engine light on. I performed an onboard diagnostic test and got the fault code of 1266. This seems to be related to the VANOS system. Does anyone have the experience of what to do to fix the problem? Any help will be greatly...
  5. 7 Series - F01 / F02 / F03 / F04 (2008 - 2015)
    F01 Background: Experienced low voltage error and trans code 400626 turbine sensor. Shop said possible bad battery due to no registration and would require a new battery. Once installed and registered the codes go away for 2 weeks. Code 400626 comes back along with 1D3901 Electronic...
  6. F10 / F11 (2011 - 2016)
    Hi everyone, I have fallen victim to the good ol N63. I had the drivetrain malfunction message this morning on my 2014 550i X-drive. My car is not in limp mode and still creates boost. Ive tried turning the car off and on, but nothing. I plugged my Zurich scanner in and I am reading code...
  7. E90/E91/E92/E93 (2006 - 2013)
    Hello my dear friends, i have an e92 2009, last year at 185000KM i had an issue with the engine started as rough idling to stalling to even shutting down on braking, so i checked fault cods and found p0012 which i related to vanos solenoids problem. I removed both and cleaned them, also i...
  8. X5 E53 (1999 - 2006)
    I have watched a dozen videos on how to clean my VANOS solenoids, bought everything I needed and then got under the hood. I can't find them anywhere on my 2002 X5 3.0. Can anybody tell me where they are located? Pictures would be great.
  9. E39 (1997 - 2003)
    I have a 7/98 528i with the GM 4-speed transmission. ~255k miles. I have owned and wrenched on the car since 2009 when it had a measly 73k miles. Thanks to this forum and google, I have been able to keep the car running great, but now I am stumped. The transmission was starting to have...
  10. E60 / E61 (2004 - 2010)
    What happens when you plug in the wrong VANOS Solenoid? e.g. plug in the intake vanos solenoid wire into the exhaust vanos solenoid and vice-versa.
  11. E90/E91/E92/E93 (2006 - 2013)
    I'm searching old threads, but so far I haven't found the answer, so meanwhile, I'm posting fresh. I have a 2007 328i that began running rough, whistling, and stalling at stops. I took it to a shop who said I need the valve cover changed. I am a little suspicious with mechanics, being a woma...
  12. F10 / F11 (2011 - 2016)
    This quite bothers me and no one seems to know why. This transmission always had a jerk when switching 1-2-3. After changing oil and filter it shifts smooth (in Drive) only after driving for a few miles, after engine temp and probably transmission temp get high. Otherwise, in the morning or...
  13. E90/E91/E92/E93 (2006 - 2013)
    Hello all. I'm new to this forum and I am looking forward to be apart of this community. I recently changed my VANOS solenoids on my N51 motor 328i coupe, both intake and exhaust. The car has a long crank and slight rough idle when cold if you're wondering why I'm changing it. I was about to buy...
  14. E90/E91/E92/E93 (2006 - 2013)
    I recently replaced the transmission solenoids in my 2006 325xi with 350k miles. The adaptation values have drastically changed from what they were before the solenoids were replaced and appear to be more similar to each other than before. The adaptations stopped changing around 1500 miles...
  15. E36 (1991 - 1999)
    1997 328i 4 door sedan So woke up today in a hurry to get to my classes. Hop in the car, start it up no problem but when I press the brakes and go to shift out of parking the shifter will not shift. The back lights work when I press the break, so that means the senors are working. I tried...
  16. X3 E83 (2004 - 2010)
    I had the classic symptoms of VANOS solenoid replacement, so I did...whistle, stutter, and stall reappeared within 100 miles. Thoughts? Next Step?
  17. E46 M3 (2001-2006)
    Hello, I have done a lot of reading on all the BMW forums, and my 2004 E46 SMG M3 has dreaded SMG problems. The car won't go into gear sometimes, sometimes it will get stuck in a gear, recently it seems it has been going into neutral when it says it's in gear, and once it wouldn't even start...
  18. E60 / E61 (2004 - 2010)
    Hi all, as a brand new owner of an E61, I am becoming aware of the myriad of problems with the rear hatch. However, I think I have found a new flavour: When I bought the car a week ago, the hatchback worked fine. However, a few days ago, the hatchback refused to open. The glass would still...
  19. E85 / E86 Z4 (2003-2008)
    Hi everyone! I seem to have an intermittent problem that comes and goes and relates to my powertrain. Usually during damp weather or after a motorway journey doing a constant 70mph (this may be in my head), i get hesitation during acceleration with partial throttle in any gear and any rpm but...
  20. E46 (1999 - 2006)
    I have an 04 325i that is having transmission issues. The car was running fine until I was at a stop light. When I pressed the gas to go it was very sluggish. The check engine light came on so I pulled into a gas station. I turned it off for a minute then started it again and it drove fine for...
1-20 of 32 Results
Top