BimmerFest BMW Forum banner
sputtering engine
1-7 of 7 Results
  1. E90/E91/E92/E93 (2006 - 2013)
    Hello, I briefly left my gas cap off after refueling. The gas cap was only off for about 20 minutes while I drove home. Two days later, my car sputtered at start-up and shook. About 2 minutes later, the "service engine soon" light came on. I've done very minor repair work on my car myself...
  2. E90/E91/E92/E93 (2006 - 2013)
    I just bought my 2010 335i hard top 100k, about 2 months ago. Iv had issue after issue with this car. I love it to death but I need help. It started about three weeks after I bought it with a check engine light. The light turned off so I don't know if it was a loose gas cap or what. about a...
  3. E60 / E61 (2004 - 2010)
    so i have had my 08 535i for a while now and i gased on it today and the check engine light came on and it started to breath kinda hard.. so i pulled over and turned it off and then when i turned it back on it was fine and no light was on.. :cry:
  4. E34 (1989 - 1995)
    My 1995 525i is running rough all the sudden. I tested with a Peake 5 tester, and it came up code "10". According to the chart, that is the Crank Sensor. The car runs rough at idle, and sputters a bit while pushing gas. As RPM picks up, the sputter disapates, but is still present. It runs like...
  5. E46 (1999 - 2006)
    Hey guy's. I started my car this morning and the check engine light came and caused the car to sputter and run like crap. I shut the car off and restarted it and it seems to be running ok. it's happened to me before, eventually the light went out and im assuming it will this time eventually...
  6. E60 / E61 (2004 - 2010)
    Hey Everybody, I know there's a million of these threads but I don't see anything exactly the same as this (maybe I'm just completely missing it). I have a 2004 530i. The past month or so it has been cranking a little longer than normal in the morning. Now it happens more often and the...
  7. F10 / F11 (2011 - 2016)
    I have a 525i, last week it began "sputtering" when I accelerate until about 30 mph and when I slow down. Any body out there experience the same thing. Thanks!
1-7 of 7 Results
Top