BimmerFest BMW Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. E46 (1999 - 2006)
    Hi Folks, This is an interesting one. My temperature gauge is not working. When I run the "hidden menu" test it does not move. However if I reset the software test 21 on the hidden menu the gauge will move. However when i start the car the gauge does not move. I have replaced the T-Stat...
  2. E36 (1991 - 1999)
    Hi,i I recently bought a 94 318is with a 1.8l 4cyl engine and automatic trans. guy i got it from said it needed brake pads and rotors. right? Turns out it needs a psychiatrist that speaks bmw (i am an acura girl, but have always admired bmws from a distance so i thought i would try one on) whoo...
  3. E39 (1997 - 2003)
    I have a 1997 540i that I have owned for about 6 months. It has 104K miles. In the past few days, I've had a number of issues that are probably unconnected, but I am hoping for some help since I can't afford to just start replacing everything. Known issues at purchase: -Check engine light for...
  4. X5 E53 (1999 - 2006)
    I have a 2002 BMW X5 44i v8 for the last two days I turn the key half way and my temp gauge go strait to hot the car is not even started. when I start it fire's right away but as soon as the temp go's in the red it turns it self off. There is no siting at idle it just start right up then shut's...
  5. E36 (1991 - 1999)
    Hello, recently became the proud owner of a 98' 328i Coupe. The car however was bought with the seemingly common problem of the tacho, temp gauge and cruise not working. Just looking for people who have had experience with this issue to shed some light on the situation on what I should try and...
1-5 of 5 Results
Top