BimmerFest BMW Forum banner
vacuum
1-20 of 39 Results
  1. 7 Series - E65 / E66 (2002 - 2008)
    Hello, this might be a long shot. I replaced my valve cover gaskets and one upper timing cover gasket. I watched a few videos and I'm also very mechanically inclined so I figured it wouldn't be too difficult. I was wrong. First I'll start of with when I pulled the valvetronic motors out they...
  2. X5 E70 (2007 - 2013)
    Hello all, I have been chasing an intermittent check engine light on my 2009 X5 with the 4.8 that we recently picked up, it has 140k miles. I replaced the CCV valve diaphragms as they were pretty bad as you can see in the pictures attached. When replacing the one on the drivers side, I noticed...
  3. X6 E71 / E72 (2008 - 2014)
    So something really weird and interesting happening. Door vacuum works perfectly fine for rear doors, yet front door vacuums work 90% of the time with the car only turned on to position two (i press the start button twice, yet don’t start the car). Once i fully start the car, the door’s don’t...
  4. E90/E91/E92/E93 (2006 - 2013)
    Vacuum pump went bad, it's a costly repair, going to try and tackle it. There are 3 proprietary tools for replacing the vacuum pump on the e90 https://www.newtis.info/tisv2/a/en/e90-328xi-lim/repair-manuals/11-engine/11-66-vacuum-pump/Jhqx0MnH...
  5. X3 E83 (2004 - 2010)
    2005 Bmw X3 3.0i. 138k miles I have watched all the videos and read through so many threads with no answers. I have replaced intake gaskets, CCV system including o-rings, (With the FCP kit), intake boot, DISA valve(About two years ago but tested it to see that it still worked.) plugged all vac...
  6. X5 E70 (2007 - 2013)
    Hey guys, could really use a bump on this thread. Ive got 4 o2 sensor codes showing lean upstream and downstream as well as a code for connection to pcm. Car has been stumbling at times for months before the codes showed up. Also, having intermittent random misfire codes. Could use some...
  7. E60 / E61 (2004 - 2010)
    Hi guys. My car E60 520D N47 2008 177bhp. Car has been sitting in front of my house for arround 1 year, not moved. Car was working perfect before to leave it there. I've been removed the engine, done the chains, dpf, cat and egr delete +remap. Fitted the engine back but now i don't have...
  8. 7 Series - E65 / E66 (2002 - 2008)
    I have a 2007 E65 750i and I replaced the DMTL pump TWICE but I am still getting the error code. When I reset the code it comes back on immediately. I have done / Checked the following work listed: New gas cap new valve stem seals - all 32 2 new / different DMTL pumps New vacuum lines up...
  9. E60 / E61 (2004 - 2010)
    Hello, I was wondering if anyone might know where this vacuum line (if that is what it is) goes? I was under the hood and found this line disconnected... probably related, I am getting P2096 Bank 1 too lean... I am guessing this is the reason but not sure where the end goes. This is a 2010...
  10. X3 E83 (2004 - 2010)
    Hey forum, I was hoping to get some advice/help on my 2008 X3 (e83, N52 engine) A few weeks ago I decided to undertake the work to change out the valve cover gasket myself, and while I did so with no roll-overs or gaps in the sealing, several other problems have arisen since then. 24 hours...
  11. X5 E70 (2007 - 2013)
    I have a 2009 X5 3.0L motor. There is an 1/8 inch vacuum port on top And in the rear of the valve cover that has crankcase vacuum. I bought the vehicle without a hose connected to this port. I cannot find where a hose would go if it were attached to the sport. I am assuming it needs to go...
  12. 7 Series - E65 / E66 (2002 - 2008)
    Good evening, I just recently replaced the valve stem seals on a 2007 BMW 750i with a 4.8L N62B48B engine. I went to start it up and the engine runs rough then stalls. This problem never existed prior to the job. I did disconnect the and remove the intake manifold during the process, upon...
  13. X3 E83 (2004 - 2010)
    Good Morning, All! I've been trying to solve this on my own, but to no avail. Cold or Warm, engine Sputters in Park/Neutral. Sometimes seems like it's misfiring while driving. Throwing codes P0171 and P0174, then Codes P0300-0306 (Never all together) *edit* Always P0171 and P0174, only...
  14. E36/7 Z3 (1996-2002)
    If anyone can give me any input I would really appreciate it. I am pretty frustrated. Sorry for the long story but I believe it is all relevant. OK so my 01 Z3 convertible. 2.5 L engine started running poorly. a little worse at a time over a long period. It has 190K miles on it. I started...
  15. E30 (1982 - 1993)
    1984 325e Started it today and the idle was really rough and surging, between 8 and 12 hundred rpm. Drove fine into town, when I went to get gas had a look. The vacuum hose for the fuel pressure regulator was torn at the manifold nipple. Not surprised, it was a very old hose and I had it...
  16. E46 (1999 - 2006)
    I bought a 2002 BMW 330Ci from a guy that seems to have overestimated his mechanical prowess. He installed headers without cats, so I expect some codes to be thrown. He told me that he had also replaced all the O2 sensors and spark plugs. Which leads me to my current dilemma. These are all of...
  17. E60 / E61 (2004 - 2010)
    Hi All, I need some help. I have been having a minor oil leak for a while now. Since it was minor I was waiting for the next oil service due date to have it checked. The dealership said oil was leaking from the valve cover gasket and vacuum pump. They are suggesting to change both the right and...
  18. E46 (1999 - 2006)
    I've done a lot to chase down the tricky 171/174 codes...new MAF, DISA rebuild, O2 sensors, Valve Cover gasket etc. I was looking at the CCV oil return line (I think that's what it's called) and I noticed some oil nearby. I opened up the area a bit to see better. I'm hoping some of the experts...
  19. E90/E91/E92/E93 (2006 - 2013)
    I initially checked the eccentric cam shaft, here is what it looks like. https://imgur.com/a/tcES7 There is oil in it and on the plug, so that means I should replace this part with one of the guides online? To recap my last post (on another site), basically the car had been shifting kinda...
  20. E34 (1989 - 1995)
    I have a E34 with a vacuum leak that is very bad and not drive-able, too loud to really pinpoint it :mad: , but it seems low in the engine bay I've searched for some techniques to find it, but they are all difficult/ sketchy as in using a fog machine at pressure which would probably damage it...
1-20 of 39 Results
Top