BimmerFest BMW Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-11 of 11 Results
  1. X3 E83 (2004 - 2010)
    First light snow of the year and I went to turn on the wipers only to find they would not move. After replacing the wiper relay and checking the fuses, I ordered a new wiper motor assembly for like $370! But I now see that both the front AND the rear wiper are not working. The stalk switch works...
  2. E60 / E61 (2004 - 2010)
    Just bought myself a used 2004 E61 530d SE a couple of weeks ago. After buying it, the car has developed a few issues, one of which is the fact that the rear windshield wiper stopped working this morning. This is quite irritating as you can imagine! When I turn it on and listen carefully, I can...
  3. E39 (1997 - 2003)
    I have been looking since yesterday in hopes someone else could point me in the right direction, but decided to post since I can't find one that matches. So, here goes my first thread. Yesterday, while I was driving in mild rain, the driver's side wiper all of a sudden got stick at about the 2...
  4. 7 Series - E38 (1995 - 2001)
    ok so I just recently bought a 97 740i off a private owner and got the engine tuned and brought up to speed but now the wipers aren't working. I took it to a dealership and they told me I have corroded wiper relay units and they need to be replaced in order for my wipers to work again, which...
  5. E36 (1991 - 1999)
    Hello all - lurked for a long time and have found a TON of good info. Cheers to all. I tried searching this but could not find the answer: I replaced the windshield hood cover this weekend and after I got the wiper arms back on and everything and the wipers run fine but when i turn of the...
  6. X3 E83 (2004 - 2010)
    Hello - Driving home from work in a snowstorm last night and the windshield (front) continually iced up. I had the defrost running, per the owner's manual (heat and fan on high, AC on, front defrost on) and windshield wipers running on high. The ice begins to form in the middle of the...
  7. Do-It-Yourself H.Q.
    I guess it is the relay, but I cannot locate it... Or can it be the control unit, which as far as I understand is attached directly to the rear wiper motor?? When I connect electricity directly to the washer pump it functions without problems. Thanks for any help
  8. E90/E91/E92/E93 (2006 - 2013)
    Can anybody help me.... Can anyone tell me if a wiper motor from an E90 320i will fit onto an E39 520i ? I have been adivsed that the fitments are the same, but I do not want to proceed to sell the item to the buyer if it will not fit? Any help would be much appreciated thanks Liam
  9. 7 Series - E65 / E66 (2002 - 2008)
    I am sure many of you have experienced the SZL issue. With my car it started within the first 4 months since I bought it new. The wipers turn on automatically and do not turn off until the ignition is turned off. All sorts of errors start to popup: Airbag and belt tensioners functions are not...
  10. E39 (1997 - 2003)
    My windshield wipers just modified on their own, they won't turn off. I'm not sure how or where to start troubleshooting this so help is appreciated. Here are the symptoms. I don't know the names of the modes so I made some up. wipers in off position - wipers act as if they are in...
  11. E39 (1997 - 2003)
    Hey guys, just got an 01 525iT last week. The wipers work fine, except they won't wipe the top of the windshield on the driver's side. The blade isn't making contact with the top 6 or 7 inches of the glass. I've replaced the blade (not just the rubber, the whole thing) and it didn't make a...
1-11 of 11 Results
Top