BimmerFest BMW Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hopefully someone can help me and my dealer. My 2001 740 has spent my time at the dealer than in my garage the last 2months.

Two issues, both intermittent problems. First the car will crank but not start. Cranks well but sometimes it takes 3 or 4 attempts. Also, in gear at idle it will occassionally stall. Will also ocassionally stall a speeds less than 30 mph. My dealer and I would appreciate any assistance.

Thanks!
 

·
E38 - Flight on 4 wheels!
Joined
·
122 Posts
toby,
If it cranks, then at least you have that, YOU HAVE TO FIND WHY IT HAS DIED. Your problem sounds like fuel and air, sensor or emissions related. You have to have the car checked with a fine tooth comb. If it is showing codes it may tell you what is wrong. Do you smell fuel? Do you see leaks?
 

·
Registered
Joined
·
62 Posts
could be fuel filter/pump or carb problem, or even bad gas. Do you have a Peake code reader? If not take it to autozone and they will usually read the regular codes for free. For the car specific BMW codes you need the Peake (or other brands) code reader. Then you have to go to the internet and look up what the codes mean.
 
Joined
·
186 Posts
For the car specific BMW codes you need the Peake (or other brands) code reader. Then you have to go to the internet and look up what the codes mean.
Mostly correct - the Peake tool will give you the most accurate, non-OBDII, BMW-Specific fault codes. There is no other brand of hand held tool that does this. Also, no need to go to the internet to look up codes - the included manual has vehicle specific tables with all the code definitions as written by the BMW factory. It is often helpful to take those definitions and search the internet for ideas and tips on the next step to correct any faults you may find.

We are proud to offer the complete line of Peake tools. You can see our selection at www.bmwscantools.com. If you have any questions, [email protected].

Good luck!

Ken
 

·
Registered
Joined
·
7 Posts
Has this problem been resolved

Any updates on this problem? I have the very same issue happening with my 2000 740i. I thought I had resolved this by cleaning the ignition connector on the steering console. No symptoms for several weeks now it is back. I am going to replace the one CPS that is original as I have head that could cause the problem.
 

·
Registered
Joined
·
7 Posts
Resolved

Problem was the ignition switch. I replaced the $50 part and the car has started right up and no stalls for the last couple of weeks. In my case there were no CPS faults so I decided to try the ignition switch first

I did the replacement myself and took me about 15 minutes.. very easy.

Hopes this helps.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top