BimmerFest BMW Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
323 Posts
Discussion Starter · #1 ·
--------------------------------------------------------------------------------

I was told by the dealer that the reason for "brake failure, transmission failure, roll over, dynamic drive failure" warnings and loosing power to the windows, the radio and the screen is caused by the ignition switch. Is this possible? Once I get all these warnings the car still drives but I am not able to put it in reverse or park. All I can do is shut it down and charge the battery. Once the battery is charged it all goes away. First time it happened I got 9 volts out of the battery. Once charged and with the car running it fluctuated between 13 and 13.5volts. Isnt the real problem my alternator? The dealer first had me replace the ignition switch. $1200 since I am out of warranty. I drove the car for about 60 miles and it happened again. This time they told me it was caused by the battery since it was aftermarket. Same battery was installed on car when they replaced the ignition switch. I have a bmw battery now and it happened again. I had the battery charged and it went away. Had another reading taken around noon and it also read between 13 and 13.5 with the car running. Around 3pm I had it checked again and the battery was down to 11volts with the car off and 13 with the car running. It actually drops when the car is accelerated. Anyone have any ideas?
 

·
Registered
Joined
·
323 Posts
Discussion Starter · #2 ·
Is there a way of testing the ignition switch? I made the dealer give me the one they took out of the car. I think they messed up. I've been trying to speak with the service manager for 2 days. If he is not in a meeting he is on his way to one. I think he is ignoring me hoping that I will go away..Any one have any suggestions on how to deal with mis-diagnosed issues? I am talking about hassel bmw in freeport. Anyone have similar experiance with them?
 

·
Registered
2015 535i, 2017 X3 x35
Joined
·
1,728 Posts
Sounds like the alternator to me. A weak battery will cause all sorts of fault codes and if the voltage drops on acceleration then something is not right. A bad diode in an alternator can allow current from a battery to flow back and drain an otherwise good battery. I would go to AutoZone or Advance Auto Parts and have the test the alternator (if they can).
 

·
Registered
Joined
·
2,001 Posts
Is there a way of testing the ignition switch? I made the dealer give me the one they took out of the car. I think they messed up. I've been trying to speak with the service manager for 2 days. If he is not in a meeting he is on his way to one. I think he is ignoring me hoping that I will go away..Any one have any suggestions on how to deal with mis-diagnosed issues? I am talking about hassel bmw in freeport. Anyone have similar experiance with them?
sorry to hear that , you dont call him you go see him and raise hell till you get a hold if him , you are a customer that just gave them business and payed them $1200 , they will find the manager for you , good luck
 

·
Registered
Joined
·
721 Posts
although you bought a TOWN CAR ... you have a possible issue with your battery or alternator ... I had the issue when I bought mine ... I had to have my AGM Battery recalibrated, search for that and you will see my thread and others that BMW_TECH has given input on. Good Luck
 

·
Registered
Joined
·
766 Posts
sorry to hear that , you dont call him you go see him and raise hell till you get a hold if him , you are a customer that just gave them business and payed them $1200 , they will find the manager for you , good luck
Now that's what I'm talking about. Tell them to fix it because you have already paid for the repairs. Good Luck.
 

·
Registered
Joined
·
2,019 Posts
although you bought a TOWN CAR ... you have a possible issue with your battery or alternator ... I had the issue when I bought mine ... I had to have my AGM Battery recalibrated, search for that and you will see my thread and others that BMW_TECH has given input on. Good Luck
AMEN!
 

·
Registered
Joined
·
323 Posts
Discussion Starter · #10 ·
After conctacting bmw north america, the service manager met me along with my attorney(wife). I let her handle it because I just get angry when I am getting screwed without any lubrication. In any event, "we will replace the alternator for you if that will make you happy" is what the mgr told us. I couldnt help myself, "it wont make me happy, it will fix the car". They swaped the alternator, problem solved. As per new SA, they never manually checked the alternator eventhough I told them I thought the alternator was bad on my first visit to them. I even gave the SA readings of 12.5V output. I'm still dealing with BMW NA since it doesnt cost $1200 to have a rebuilt alternator installed. I would have done the work myself had they diagnosed the problem correctly the first time. BMW=license to steal
 
1 - 10 of 10 Posts
Top