BimmerFest BMW Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I purchased a 2005 BMW 645ci from a private party (deep discounted) and was aware of a few electrical issues. The owner told me that "these things happen every now and then" when the radio and display screen would shut off time to time. There was also a dynamic drive malfunction fault that would appear. I took the chance on the ol' girl and brought her home. After a few months, the problem became more persistent. I dug deeper into the cause and found that the engine had several oil leaks, but the main culprit for the electrical issues was the alternator o-ring which was leaking onto the alternator providing less than suspect charging volts to the system. Once the leaks were all repaired and the alternator/battery replaced, she ran like a champ for a few months.
I later ran into the issue of misfiring. The engine, in order to preserve itself, shut down to half power and would sputter at idle and barely run when gas was applied. I have felt misfiring at cylinders before and decided to tune her up before taking it in to the stealership for a world of hurt. The plugs were average price and the coil packs were roughly 30 bucks a pop. At this price, I decided to replace all 8 and she is now running better than ever! I searched the forums for similar symptoms on my issues, so I figured writing this is a way of paying it forward... even it if only helps but one person. Good luck to you all!
 

·
Registered
Joined
·
5,787 Posts
Welcome to the forum and congrats on your 645 .. Good job in solving all the issues. Be ready for the coolant transfer pipe another issue that will come ..
 
1 - 2 of 2 Posts
Top