BimmerFest BMW Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Ok guys, just bought this 05 X3 about 2 months ago. Been doing the usual preventative maintenance but we've had one re occurring issue, sometimes totally at random the car won't start. It will turn over but not fire up. The solution seems to be pumping the gas pedal will get the vehicle started, sometimes resulting in a rough idle but not always, but its a constant aggravation. We did run seafoam through the car and intake before doing the tune up. Things we have done and still suffering the same issue:

1. All fluids and filters have been changed and flushed (trans fluid and filter, front and rear diff, brake fluid, air and cabin filters)
2. MAF has been cleaned, not replaced though.
3. Spark plugs (single prong NGK)
4. The usual cooling system overhaul (exp tank, thermostat, coolant, water pump)

It appears to have the original battery in it. I am at a total loss. Like I said, it will run fine for weeks at a time then one day it will decide not to start without pumping the gas pedal. ANY advice or help would be great.
 

·
Registered
Joined
·
943 Posts
Its really just a guess unless some codes are being thrown. A few possibilities could be:
Fuel filter
Fuel pump on its way out
Bad gas once in a while?
Idle control valve may cause rough idle
Vacuum leak due to a torn rubber intake can cause rough idle

May want to try the battery first. Most of the other items I listed are not very likely to be the main culprit of not starting. Keep us posted.
 

·
Registered
Joined
·
74 Posts
hey, hope your x3 is doing well now. I think, if you are having trouble starting the car, check out your starter first, then check your battery. If you are having a bad fuel pump you should get a check engine light, if there is a leak in your intake system, you should soon get a system too lean code, also, check your coil, your spark maybe in good condition but the if coil gone bad, then you are more likely having trouble start or rough idle.
1. Check your starter
2. Your battery, do a test or refill it or just get a new one
3. Check your coil, if you have misfire then replace the coil
Do you have any engine code now?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
Thanks for some quick replies guys. Want to start by answering some questions:

1. No check engine lights or codes have been thrown.
2. It is an M54 engine, in my previous 325xi I experienced starter failure and this doesn't seem like the same thing. To be clear it turns over when this happens, just doesn't actually start.
3. I would like to start with a fuel filter but I swear this doesn't have one or its built in to the fuel pump. I've checked on several of my "go to" sites for BMW parts and a fuel filter is not listed.
4. We've only run premium high grade fuel since purchase, now that's not to say the previous owner may have run bad gas.
5. I don't know if/when the coils have ever been replaced but I've been reassured from several BMW techy friends that if its a coil that a code will be thrown.
 

·
Registered
Joined
·
46 Posts
Had similar problems with my 06...rough idle, car stalled in traffic then wouldn't start, turned over fine, replaced the original battery a few months ago. Dealer advised that it was the idle control valve and torn intake boot. Made repairs, car has been starting fine since.


Sent from BimmerApp mobile app
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top