BimmerFest BMW Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi guys,

I have had a '98 740il for a couple of months now, overall great car, but i now have a couple of problems that happened all at once...

I got into the car the other day, popped the boot, and the screen and everything came on fine (It has a MKIV display fitted). When i hit the accept message on the screen, the screen died. Screen is dead and now the radio and CD won't play, screen will pop down to accept tape and has backlights when headlights are on, but other than that is completely dead.

At the same time the indicator lights on the dash have stopped working.

Then i went to close the boot (trunk) and the latch will not engage.

Kinda strange that all three things happened at once...

If you guys have any ideas that would be great..
 

·
Registered
Joined
·
272 Posts
As a quick fix, you could try disconnecting the battery for a few minutes to see if that resets the system? Could be that the I-Bus has locked up and needs a reset...

Rawdon
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
I tried unplugging the battery and left it for a good 15 minutes.

All of the settings on the dash reset, but the nav screen, boot and indicator lights on the dash still don't work.

I can't find fuse 46 or 49 or whatever number it says for the nav system. It is a right hand drive vehicle.

I have found the fuses in the glove compartment and in the boot near the battery, but neither contain the fuse.

Does anyone know where this fuse is on a RHD 740?
 

·
Absolute Car Nut....
Joined
·
8 Posts
On my LHD 98 740il the fuses are under the hood (bonnet for you?), near the firewall, under a black plastic cover.
 
1 - 5 of 5 Posts
Top