BimmerFest BMW Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hi All -

I'm new to the forum and apologize up front if this question/problem has been discussed before. In any case, the situation I have is the right side of the engine for my 1999 328I (80k miles/automatic) is rattling hard during cold morning start. It appears to come from the air intake where the mass airflow sensor is located...by I'm not sure. The rattling goes away after reaching normal operating temperature. My questions are as follows:
- is the problem with the mass airflow sensor?
- the temperature sensor?
- catalytic converter?
- another component?

I'd really appreciate any insights/experience. I'd hate to spend lots of money before finally finding the problem.

Thanks much!!
 

·
FixItFaster
Joined
·
1,936 Posts
Its probably the vano's unit, when was the last time the engine oil was changed?
You may also want to think about running synthetic if it turns out that sludgy oil is the culprit, as it stays much cleaner and is also very good at cleaning out carbon deposits in the engine (in your vano's unit). If you do this be sure to get another oil change before too long as all the deposits will be clogging up your oil filter and will be thrown about the engine.
Mass airflow sensors don't have any moving parts so it isen't sensible that it would be making noise.
Does it sound like pepples in a tin can??
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
The oil and filter are changed regularly as prescribed by the manual. Last tuneup (service type 2, I think) was performed 10k miles ago. Replaced were oil (synthetic) & filter, spark plugs, air filters, coolant. I do use the air frequently...during cold starts the rattle is present whether or not the air is on. As for the sound, it does sound like pennies in a can with a little hint of grinding mixed in.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #6 ·
Thanks for the welcome. You're right...I realized that this was the introduction forum after I posted. Sorry...will post to the correct forum next time.
 
1 - 6 of 6 Posts
Top