BimmerFest BMW Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Troubles with random misfires. Rough idle. Bogging out in mornings. Have cleaned injectors. And checked all vacuum lines. It will mostly start misfiring and rough idling when sitting at red lights for over 30 seconds, but when I turn off engine and restart it, it will run smoothly, that is until I get to the next red light. PLEASE HELP!
 

·
ROLL TIDE!
Joined
·
23,956 Posts
Sounds like bad coil packs. Are you throwing a check engine light? Even if you aren't, have an auto parts store scan the codes and post them here. Otherwise it is all guesses at this point.
 

·
Registered
Joined
·
5,550 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #4
Yes I have had codes ran a few times. I lost the paper but they have all been random misfires with fuel cut-offs. And also a MAF code. And I have checked vacuum lines for hours with no luck on finding broken/loose hoses. If any of that helps either of you two
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Have just replaced coil packs in the past year as well as valve cover gasket.. still think either of those could be the problem? And yes, I do have a check and service engine light come on, but it comes and goes
 

·
Keeping it surreal
Joined
·
43,204 Posts
Yes I have had codes ran a few times. I lost the paper but they have all been random misfires with fuel cut-offs. And also a MAF code. And I have checked vacuum lines for hours with no luck on finding broken/loose hoses. If any of that helps either of you two
You need those codes....no two ways about it!
 

·
Registered
Joined
·
5,349 Posts
How old is the fuel pump? When was the fuel filter last changed. Have the fuel pressure checked. It needs to be at least 45psi at all engine speeds.
 
1 - 7 of 7 Posts
Top