BimmerFest BMW Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I started to have some problems with the engine running rough. A trip to the dealer resulted in both cam sensors being replaced, and air flow sensor. The mechanic also updated the the system software (I dodn't know what software,(all, engine control, or what ever) . Since this service the battery will go dead at random intervals,( it takes at least 8 hours to drain the battery). I have never had a starting problen with this car prior to this. I doubt if this problen is related to the cam sensors, or the airflow sensor. When the battery goes dead the engine won't crank and the headlights and horn won't work. The battery measures approx. 8.5 volts. Several trips to the dealer later and no fix. The mechanic checked the charging system, Battery, Starting system, and current draw while the car is running and while the car is powered down. All systems seem to be operating normally. After 3 or 4 service calls with no help I had a new battery installed, no help. I have requested the mechanic call BMW of North America for help, He won't, he says that they can't help. Finally out of desperation I called BMW. The service rep I talked to seemed to know what was wrong with my car, but he refused to tell me (or call my dealership). He said that He could only discuss technical support issues with authorized BMW mechanics that call and request help. Has anybody had electrical problems like this?
I'm really tired of having to jump start this car. Has anybody had this problem?
Thanks
 

·
Registered
Joined
·
6,836 Posts
There is a TSB for the climate control. Do a search. It comes on when the car is off and drains the battery IIRC.
 

·
Registered
Joined
·
6,836 Posts
 

·
Registered
Joined
·
400 Posts
rick_timberman said:
I started to have some problems with the engine running rough. A trip to the dealer resulted in both cam sensors being replaced, and air flow sensor. The mechanic also updated the the system software (I dodn't know what software,(all, engine control, or what ever) . Since this service the battery will go dead at random intervals,( it takes at least 8 hours to drain the battery). I have never had a starting problen with this car prior to this. I doubt if this problen is related to the cam sensors, or the airflow sensor. When the battery goes dead the engine won't crank and the headlights and horn won't work. The battery measures approx. 8.5 volts. Several trips to the dealer later and no fix. The mechanic checked the charging system, Battery, Starting system, and current draw while the car is running and while the car is powered down. All systems seem to be operating normally. After 3 or 4 service calls with no help I had a new battery installed, no help. I have requested the mechanic call BMW of North America for help, He won't, he says that they can't help. Finally out of desperation I called BMW. The service rep I talked to seemed to know what was wrong with my car, but he refused to tell me (or call my dealership). He said that He could only discuss technical support issues with authorized BMW mechanics that call and request help. Has anybody had electrical problems like this?
I'm really tired of having to jump start this car. Has anybody had this problem?
Thanks
there is also a problem with ipod doing the same thing, its says follow the instructions to avoid sync errors with the ipod.
 

·
BMW NA Customer Relations
Joined
·
454 Posts
I'm with BMW of North America, LLC. I've passed this message on to a BMW NA Customer Relations Representative who will be in touch with you soon.
 
1 - 6 of 6 Posts
Top