BimmerFest BMW Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
2001 X5 - Sounds like something is loose - need advice

Hey,
I have a 2001 X5 with around 130,000 miles on it. In the past few weeks I have begun to noticed a noise coming from the front right side of the engine compartment when I drive. It sounds like something is a little bit loose and is bouncing into the area right behind my glove box when i go over even very slight bumps in the road. It doesn't drive any differently though. At first I thought the windshield wiper tank was loose but that turned out not to be the problem. A visual inspection into the engine compartment and the wheel well didn't reveal any loose bolts, plastic parts, panels, etc.
Has anyone encountered this before or have anything suggestions on how I might go about troubleshooting this sound?
 

·
Resident Curmudgeon
Joined
·
25,742 Posts
The upper mount for the front shock/spring is right there- it my be coming loose, or some of the rubber mounts may have degraded.

I'll bet that if you could return your car to "as new" condition, you would not say "it doesn't drive any differently". At that mileage a thorough R&R of all suspension parts- rubber mounts, etc, is a great idea. Assuming you will keep it another 70k...
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
I'll have to take a look at that. Thanks for the advice and you are right., if I get a chance to overhaul the suspension I wouldn't say it isn't driving any different. The plan is to keep the car as long as possible so I will have to consider a thorough R&R
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top