BimmerFest BMW Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My X5 is having this weird issue starting and taking off in first gear - intermittently. I took it to a BMW repair shop (not a dealership) just to get the codes checked, and the mechanic told me it was a Thermostat issue. HOWEVER, it's not overheating, the heat is fine, the engine temp is perfect - so I'm skeptical about this guy's diagnosis now...

Here's what happening: First, this is a 5 speed manual. Ocassionally on start-up it will take a few extra seconds than normal. The check engine light will come on when this happens, then go off after I've had the car off for a while. Giving it a little gas seems to expedite the start-up process when this does happen. The outside temperature seems to make no difference whatsoever. The worst part is that I'll be at a stop light / stop sign / or MOST DANGEROUSLY pulling out of a parking lot across a lane of traffic and it will just stall right out unless I really rev up the engine / give it extra gas than normal while I let up the clutch. Then I'll have to restart the engine, and when this happens, afterwards it ALWAYS needs a push on the gas peddle to turn over. And when this happens, it's only in first gear. And it doesnt always happen - I'd say it's getting more frequent, which concerns me, but it's still intermittent. Once it gets running - 2nd, 3rd, 4th... - I've got no problems at all - she runs beautifully.

Any help would be GREATLY appreciated. I'd like to figure out WHAT the problem is before I spend cash I dont have trying to fix things that arent really broken (like the thermostate for example) ...Thanks to everyone for your help. - Travis
 
1 - 1 of 1 Posts
Top