BimmerFest BMW Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello,
My wife has a 2002 X5 with 30K miles on it.
It's been a great car until we just had a problem in the last
week. With the A/C on, it would work for a while, then the fan
would stop blowing, then it would just kick on a few minutes later,
then go off again... It did this for a week, then finally completely
died today. I used my gauge and checked the freon, it was fine. I also
checked the fuses, they are fine.
I'm thinking it's some sort of sensor, or maybe the blower motor all together.
Any advise out there one what I should check or do ?
I think the car has a 50K mile warranty, so maybe a dealer trip is
the way to go, but I hate dealing with taking it in.

Any help would be greatly appreciated.

Thanks,
Ryan Poulos
Celina,TX
2002 X5 3.0 30K Silver
 

·
.oo=||=oo.
Joined
·
1,126 Posts
Is the outside temperature sensor working ok? I test drove a used X5, and it was showing an outside temperature somewhere below freezing when it was something like 60 degrees F. The A/C wouldn't come on until the end of the test drive when the outside temperature creeped up to show something above freezing. I suspected there had been some front-end damage to that X5, in the vicinity of the temp sensor.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Thanks.....

Thank you for the advise.
I'll check the external temp tomorrow. I think it is working.

Your probably right on the warranty deal. I guess it can't hurt to at
least have it looked at. It's the first problem we've had with the car,
and after pulling down the recall list earlier on the web, maybe it's
time to get everything else looked at to. We are the second owners
of this car and got it with 15K miles, so who knows what's been
fixed.

Take care, and I appreciate the help.

Ryan Poulos
2002 X5 3.0 30K Silver
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Car is at the dealer

Car is currently at the dealer. I found out I had a 36,000 mile warranty
and the local dealer said bring it in !!
So, stay tuned.

Thanks,
Ryan
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Done !!

Just to close out this thread.....
The dealer replaced the Final Stage Resistor just like you thought. Blower fan is fixed !!
They also did a brake fluid flush, changed the oil, and gave it a detail.
The only funny thing that happened was this.
About 2 months ago I did the brakes and had to reset the brake lining light. With that I reset the green service lights so they didn't do my 30K service which they said was an pil change and basic inspection. I didn't want to say I did it myself, and I had them very confused... he he.....

Anyway, thank you for all your help.....

By the way, where is the link on how to reset your service lights again ? I want to print it this time for future reference.

Thanks,
Ryan Poulos
Celina,TX
 
1 - 7 of 7 Posts
Top