BimmerFest BMW Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
hi any one know what might the be problem with hot start, ,engine turns over 10 15 sec or longer in stead of touch starter as it did before, it happened all of a sudden. when cold start starts with a click of key. but does idle rough until I give it a little throttle, also when idle goes from 700-900rpm up and down. Gas Milage went down about 65k and when and why I changed plugs but didnt help. then began hard hot starts. Before (6 speed) I got 24-26 around town and 33-35 on road up tyo 65k on odo. then went down..

Has 80k, put new plugs at 70k but thats it reg oil changes and a ir filter changes.

Any help or suggestions would be appreciated, i work on this myself as for plug change and oil changes. I am an Aircraft A&P and Pilot so quite familiar with engine work etc. a

Thanks
Dan
 

·
Michael
Joined
·
2,291 Posts
hi any one know what might the be problem with hot start, ,engine turns over 10 15 sec or longer in stead of touch starter as it did before, it happened all of a sudden. when cold start starts with a click of key. but does idle rough until I give it a little throttle, also when idle goes from 700-900rpm up and down. Gas Milage went down about 65k and when and why I changed plugs but didnt help. then began hard hot starts. Before (6 speed) I got 24-26 around town and 33-35 on road up tyo 65k on odo. then went down..

Has 80k, put new plugs at 70k but thats it reg oil changes and a ir filter changes.

Any help or suggestions would be appreciated, i work on this myself as for plug change and oil changes. I am an Aircraft A&P and Pilot so quite familiar with engine work etc. a

Thanks
Dan
Hi try the E85 forum where your thread would be more applicable, someone can surely help you there!!
 

·
Bimmerfest Founder
Joined
·
15,712 Posts
Welcome to Bimmerfest! I moved your thread over to the E85 Z4 forum. You should be able to get help from other Z4 owners here.

Good luck,
Tim
 
1 - 4 of 4 Posts
Top