BimmerFest BMW Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey. Brand new to this forum. Hoping somebody can offer me some knowledgeable insight. Recently got myself a 2004 645CI SMG. The car has Navigation, seem's to only have a one disk cd changer (however the screen shows multiple cd's to select but wont allow me to select and I don't think I can load additional) Car has no bluetooth. Anyway, the car sat for about a month without being started. Jumped the car and got a fail safe trans code - before the car sat for a month the car literally worked and functioned perfectly - anyway, I went to an independent BMW shop and had the battery replaced and programmed to the car, and was told they were going to "update the ccc" ... later that day, the shop informs me that the car isnt taking to the programming, and I may need a new ccc unit, but that he'd keep trying to get the updates to load. He later tells me it all worked and I'm good to go. Upon picking up my vehicle, I notice I have no audio coming from my stereo. He tell's me that I still may need a new ccc. I immediately start to have my doubts, as everything else on the ccc is working, including the nav (without any audio guidance. I have been able to access all functions of the ccc, change radio stations, play cd's, etc ... I'm just getting no sound. The shop suggests letting the car sleep over night, if that doesn't work then he suggested removing the battery and allowing the positive and negative battery cables to sit over night touching so they can loop. None of this has worked. I simply have a completely muted car. One strange side note - the car wouldn't even beep to upon locking/unlocking the doors, however yesterday I replaced a head light and all the sudden immediately afterwards, the car started emitting the lock/unlock chirp. Besides that however, I have no sounds. No seat belt chime, no stereo, no door ajar, no nothing. Any advice ?
 

·
Registered
Joined
·
3,646 Posts
Welcome to the forum.

If you have NAV there is one CD player just below the heating controls (for audio CDs) and directly below that should be a DVD player for the NAV DVD. The two frontloder disc slots are in the same trim plate below the temp controls.

The multiple CDs you see are from the CD changer which is located in the glove compartment. There is a chance you have an iPod interface installed instead of the CD changer in the glovebox.

The chirping during the lock/unlock comes from a horn in the rear bumper. The lock/unlock chirp and flash of corner lights can be set in iDrive. The settings were probably reset during the CCC programming.

The lack of audio was probably due to the CCC software update. I would bite the bullet and have the dealer try to to update the software. I would guess the indie gave you the wrong version of the software or it did not fully update during the flash. There is also a chance the indie accidentally unplugged the audio cable from the back of the CCC which leads to the amp in the trunk.
 
1 - 2 of 2 Posts
Top