BimmerFest BMW Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi! I have two things that I am seeking information about for my 2004 E63. I have a 2004 BMW 645ci. My top was working perfectly, drove it through a car wash and now it won't open. I unlock and push the button, the windows go down, but nothing else. Any idea what it could be?

Secondly, my Idrive screen and radio weren't working when I bought the car. The radio wouldn't receive cds, come on or anything, neither would the DVD player. The screen would just flash on and off continuously. I bought a new display screen and also a new CCC unit; the CD and DVD player will receive discs, but still no sound and the display screen will the BMW logo, black out and then flash the BMW logo again. Any idea on what could be the cause of this issue. I cant find any errors specifically because my screen is not working and I'd like to know before I send to a repair shop. Is there a way to find out? also what could possibly be causing these issues? Any help would be greatly appreciated. Thank you!
 

·
Super Moderator
Joined
·
9,942 Posts
The 1st thing to check on a BMW with electrical problems is the battery voltage must stay above 12 volts with the key & headlights turned on, engine not running. Check the voltage at the jump terminal under the hood, & also charge the battery if needed there also. You can reset the IDrive by holding the power button, along with both eject buttons at the same time. You will see the screen reboot at this time. If this does not work, you proably have a bad amp from water entering the trunk area where the electronics are stored. There are 4 drains in the top that need to be kept clear, so the water does not damage the electronics in the trunk. There is a DIY forum by clicking the helpful links, that will show you a lot of tips to repair your car as needed.

Charge your battery to see if this helps 1st, as the low battery voltage will shutdown the electronic modules to protect them.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
The 1st thing to check on a BMW with electrical problems is the battery voltage must stay above 12 volts with the key & headlights turned on, engine not running. Check the voltage at the jump terminal under the hood, & also charge the battery if needed there also. You can reset the IDrive by holding the power button, along with both eject buttons at the same time. You will see the screen reboot at this time. If this does not work, you proably have a bad amp from water entering the trunk area where the electronics are stored. There are 4 drains in the top that need to be kept clear, so the water does not damage the electronics in the trunk. There is a DIY forum by clicking the helpful links, that will show you a lot of tips to repair your car as needed.

Charge your battery to see if this helps 1st, as the low battery voltage will shutdown the electronic modules to protect them.
Will do those things. Thank you so much, I really appreciate your assistance.
 
1 - 3 of 3 Posts
Top