BimmerFest BMW Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
my 545i has 93000 miles on it and it seems as if the trans is slipping. when i give it gas the motor revs but takes the car a second to catch up. can something else cause this or is it definetly trans. this car has been very well kept, cant believe its trans problems now. please help. if so any idea of @cost to rebuild. thanks
 

·
Registered
Joined
·
5,787 Posts
I have no idea , but I reckon it's pricey . Maybe someone who's had that repair can chime in .
You should start calling some shops to get a price range . Then call the dealer so you know what not to pay . Lol
 

·
Registered
Joined
·
241 Posts
my 545i has 93000 miles on it and it seems as if the trans is slipping. when i give it gas the motor revs but takes the car a second to catch up. can something else cause this or is it definetly trans. this car has been very well kept, cant believe its trans problems now. please help. if so any idea of @cost to rebuild. thanks
As HF, stated sounds like the clutch is on its way out had the same issue here is the link to my thread so you can read my symptoms : http://www.bimmerfest.com/forums/showthread.php?t=558903&highlight=

Job cost me about$1500 but I had a leaking slave cylinder and my flywheel needed to be resurfaced at the time.
 

·
Registered
Joined
·
602 Posts
Your car is a manual transmission? If so, replace the clutch and move on with your life.

Automatic? You have more sever issues and probably need a new or rebuilt trans.

Well the thread title says manual, so you have your answer.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top